Reply to topic

One simple trick to fix constant Plasma crashes!

User avatar sandsmark
KDE Developer
Posts
64
Karma
0
OS
If you're using the intel graphics drivers and experience crashes all the time, it is most likely this bug: https://bugs.freedesktop.org/show_bug.cgi?id=86281

A very simple workaround is to put the following in for example /etc/X11/xorg.conf.d/20-intel.conf

Code: Select all
Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "AccelMethod"  "uxa"
EndSection


The bug also affects other applications that use OpenGL, like for example Kodi or Gwenview, and this workaround should fix it for those as well. Thanks should be directed to Philip Müller from Manjaro, I found out about the workaround from a post by him in the Manjaro forums.


User avatar muksidin
Registered Member
Posts
1
Karma
0
sandsmark wrote:If you're using the intel graphics drivers and experience crashes all the time, it is most likely this bug: https://bugs.freedesktop.org/show_bug.cgi?id=86281

A very simple workaround is to put the following in for example /etc/X11/xorg.conf.d/20-intel.conf

Code: Select all
Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "AccelMethod"  "uxa"
EndSection


The bug also affects other applications that use OpenGL, like for example Kodi or Gwenview, and this workaround should fix it for those as well. Thanks should be directed to Philip Müller from Manjaro, I found out about the workaround from a post by him in the Manjaro forums.


Thanks alot for sharing. :)
User avatar emrecio
Registered Member
Posts
12
Karma
0
OS
This doesn't work anymore as of today's update.
User avatar benbullard
Registered Member
Posts
22
Karma
0
OS
I'm using plasma 5 in OpenMandriva Lx 3 Alpha. It is using:

Code: Select all
$ lsmod
...
video                  20480  2 i915,asus_wmi


I'm wondering if driver should be i915 instead of intel?
User avatar benbullard
Registered Member
Posts
22
Karma
0
OS
Drat! I've tried 'intel' and 'i915' and freeze ups continue. This is frustrating.
CxOrg
Registered Member
Posts
4
Karma
0
OS
This issue has been giving me grief for a few weeks since the upgrade to Plasma 5 with Sabayon Linux. Regular crashes terminating KDE Plasma sessions. I finally found some guidance from https://wiki.archlinux.org/index.php/Intel_graphics here the suggestion to apply some boot time parameters to control Intel features seems to succeed. Phew!

Add to Grub2 boot parameters to test at boot time. Add permanantly to GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub and regenerate grub boot.
Code: Select all
i915.enable_rc6=1 i915.enable_fbc=1 i915.lvds_downclock=1 i915.semaphores=1
- PPS now disabled but probably can improve battery usage.

PPS. Mesa 11.0.2 arrived with a number of Plasma 5.4.2 updates (10/10/15) this my well be the fix we have been waiting for. In my case it resulted in my Plasma desktop configuration being no longer valid so I created a new user with a clean desktop and migrated my user files and essential configuration files (~/.local/share/applications, ~/.wine, ~/.mozilla etc). Then in a root session swapped the root home folder names and chown -R <user>:<group> <homefolder> in each case to have the correct ownership. Logging back in as my original user I have a clean configuration with all my files. All seems good and stable without any legacy KDE/plasma4 junk ;)

I think all users who upgraded from Plasma 4 should consider a fresh config!

Lenovo ideapad i7-4510U Haswell with Intel 4400 graphics, Mesa 11.0.3 driver, OpenGL 3.1, 4.2 Sabayon kernel, Plasma 4.5.2 - No Nvidia only Nouveau/Bumblebee installed/enabled
User avatar dotancohen
Registered Member
Posts
54
Karma
0
OS
CxOrg wrote:PPS. Mesa 11.0.2 arrived with a number of Plasma 5.4.2 updates (10/10/15) this my well be the fix we have been waiting for. In my case it resulted in my Plasma desktop configuration being no longer valid so I created a new user with a clean desktop and migrated my user files and essential configuration files (~/.local/share/applications, ~/.wine, ~/.mozilla etc). Then in a root session swapped the root home folder names and chown -R <user>:<group> <homefolder> in each case to have the correct ownership. Logging back in as my original user I have a clean configuration with all my files. All seems good and stable without any legacy KDE/plasma4 junk ;)

I think all users who upgraded from Plasma 4 should consider a fresh config!


Why not simply rename ~/.kde to ~/.kde-OLD? Are there KDE or Plasma configurations kept in other places?


dotancohen, proud to be a member of KDE forums since 2008-Oct.
Szpadel
Registered Member
Posts
1
Karma
0
None of above solved my problems,

UXA acceleration is unusable on laptops with 4K display.
I have hangs practically every time I plugged external monitor.

I resolved it by appending to kernel cmd (GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub)
Code: Select all
i915.enable_rc6=0

This keeps gpu in high power state all the time.


Best Regards
Piotr
anthonyfieroni
Registered Member
Posts
7
Karma
0
One better solution
Code: Select all
cat << EOF | sudo tee /etc/X11/xorg.conf.d/20-intel.conf
Section "Device"
    Identifier "Intel"
    Driver "modesetting"
    Option "AccelMethod" "glamor"
    Option "Backlight" "intel_backlight"
EndSection
EOF
rboyce
Registered Member
Posts
1
Karma
0
I have a ThinkPad t450s and I have struggled with this issue for quite some time on Kubuntu 15.10. The i915 driver is just very unreliable with the Broadwell-U Integrated Graphics. Disabled hardware acceleration in the driver's conf and within KDE system settings. Tried multiple kernels (4.2, 4.4, and 4.6 generic from ubuntu). Tried both the open source and proprietary intel drivers. I even temporarily switched to Unity and Windowmaker to see what was triggering the issue. Starting Konsole triggered the following error and then a crash:

QCoreApplication::arguments: Please instantiate the QApplication object first
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
konsole: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.0.
Konsole SessionManager destroyed with 1 session(s) still alive

Unfortunately, neither Xorg's log nor syslog gave any clue as to why the crashes were happening. So, wltimately I ended up disabling the Intel i915 driver entirely and having the system revert to the vesa driver. Here are the instructions I followed to make that happen (http://askubuntu.com/questions/696407/h ... deo-module). After removing the driver I had to have kde create a new .kde folder by moving the old one and then restarting kde.

The programs all seem to be working okay now on Kubuntu 16.04 with the default Ubuntu 4.4 kernel. The system did sleep when I closed the laptop but the display remained black after awakening it. To get around this I installed the 'hibernate' package which is a bit slower but seems to restore the system more stably. Also, the basic VESA driver does not support anything like an external display. Each time I need to use an external display, I have to go into BIOS on start up and modify the "Boot Display Device" e.g., from LCD to analog VGA.

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], bartoloni, Bing [Bot], Capitain_Jack, Dibo, Exabot [Bot], gerdeg, gfielding, Google [Bot], Kevaaq, luigitrezzi, lynnux, marthab, raddison, Sogou [Bot], Yahoo [Bot]