Reply to topic

Custom Shortcut to open Konsole doesn't work

User avatar sammuirhead
Registered Member
Posts
162
Karma
1
OS
sure, I will try it - but what do you mean by 'open a pop-up window'?


http://www.cameralibre.cc
Free Culture videos made with Free/Libre/Open Source Software about Open Hardware, Open Data, Open Everything
luebking
Karma
0
eg. a context menu, like when you rightclick a file in dolphin etc.
User avatar sammuirhead
Registered Member
Posts
162
Karma
1
OS
What if you run "sleep 5; konsole" (from eg. xterm), open a popup menu (NOT the alt+f3 titlebar menu, it will autp-close with new windows) and keep the up arrow pressed?

action:
in xterm: sleep 5; konsole
in dolphin: right click, hold up arrow

result:
xterm output: sleep 5; konsole
QCoreApplication::arguments: Please instantiate the QApplication object first
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
[email protected]m-S440:~$ Invalid Context= "Apps" line for icon theme: "/usr/share/icons/Paper/[email protected]/apps"
Invalid Context= "Mimetypes" line for icon theme: "/usr/share/icons/Paper/[email protected]/mimetypes"
Invalid Context= "Mimetypes" line for icon theme: "/usr/share/icons/Paper/symbolic/mimetypes"
The font for use in the terminal has not been matched exactly. Perhaps it has not been found properly.
The font for use in the terminal has not been matched exactly. Perhaps it has not been found properly.



in the context menu, the highlight/focus loops upwards as expected, and after a pause, konsole opens.


Since ctrl+alt+u seems somehow grabbed(?) try a random other combination (ctrl+alt+s etc.) to cross-check whether it is only this particular grab.

Pressing Ctrl+Alt+S has no discernable effect.


http://www.cameralibre.cc
Free Culture videos made with Free/Libre/Open Source Software about Open Hardware, Open Data, Open Everything
luebking
Karma
0
So the keyboard grab is a dead end.

> Pressing Ctrl+Alt+S has no discernable effect.
You mean if you assign the hotkey to this, the konsole window shows up and closes instantly likewise?
(Otherwise there's no shortcut and oc. nothing happens ;-)
User avatar sammuirhead
Registered Member
Posts
162
Karma
1
OS
ah, sorry, I misunderstood.

when I set Ctrl+Alt+S to the action 'konsole' it works!
so I was feeling optimistic and set it back to Ctrl-Alt-T, and that works now as well.I have run a few updates over the last days so I don't know what it was that fixed it.
EDIT: no, false alarm, in system settings it keeps reverting back to sleep 2; konsole.


http://www.cameralibre.cc
Free Culture videos made with Free/Libre/Open Source Software about Open Hardware, Open Data, Open Everything
User avatar sammuirhead
Registered Member
Posts
162
Karma
1
OS
that's a bit confusing, I will try to explain it more clearly:

In system settings I still have Ctrl+Alt+T set to the Action 'sleep 2; konsole'.
When I try to change this to just konsole and click Apply, it looks like I have successfully reset the shortcut.
However, the effect of using the shortcut is still sleep 2; konsole.
When I close and reopen system settings, or when I log out and log back in, it still displays sleep 2; konsole in the shortcut settings.

I then created a new custom shortcut, where Ctrl+Alt+S has the action'konsole'.
I Apply the shortcut, but it doesn't have any effect.
If I set Ctrl+Alt+S to 'sleep 2; konsole', then it will work as expected, but konsole alone has no effect.


http://www.cameralibre.cc
Free Culture videos made with Free/Libre/Open Source Software about Open Hardware, Open Data, Open Everything
luebking
Karma
0
khtokeys config writing before plasme 5.5 (frameworks version is irrelevant) is *massively* broken.
I resorted to handwriting ~/.config/khotkeysrc before finally fixing that (khotkeys isn't really maintained atm.)
If you edit that file, you need to stop the daemon in "kcmshell5 kded" before (and restart it after saving the file) - do not open the config kcm during that.
User avatar sammuirhead
Registered Member
Posts
162
Karma
1
OS
ok, great, thank you for all your help!

just to be sure (I don't want to break anything) I want to check if I have understood this correctly:
you need to stop the daemon in "kcmshell5 kded" before (and restart it after saving the file)

This means I will stop kcmshell5 kded in a terminal using:
killall kcmshell5 kded
and then edit the config file:
gedit ~/.config/khotkeysrc
and then restart kcmshell kded with:
kcmshell kded

is that right?


http://www.cameralibre.cc
Free Culture videos made with Free/Libre/Open Source Software about Open Hardware, Open Data, Open Everything
luebking
Karma
0
sammuirhead wrote:This means I will stop kcmshell5 kded in a terminal using:
killall kcmshell5 kded


NO! ;-)
run "kcmshell5 kded", that opens a config dialog for kded and in the lower section you can just stop the "input actions" daemon (select it and click the stop button)
Then edit stuff, then click the start button.

Do NOT kill kded unless you really know what you're doing.

sammuirhead wrote:gedit ~/.config/khotkeysrc

I'd user kwrite, but guess gedit will do the job in a somewhat inferor way as well ;-)
User avatar sammuirhead
Registered Member
Posts
162
Karma
1
OS
Do NOT kill kded unless you really know what you're doing.

as you may have noticed, I don't... :)

I followed the instructions and got the konsole shortcut to go back to Ctrl+Alt+T. So now I have both Ctrl+Alt+T & Ctrl+Alt+S set to trigger konsole.
With Ctrl+Alt+T, I get the same behaviour as earlier: konsole opens and immediately closes.
With Ctrl+Alt+S, nothing happens.


http://www.cameralibre.cc
Free Culture videos made with Free/Libre/Open Source Software about Open Hardware, Open Data, Open Everything

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], BigaAl, Bing [Bot], dcihon, giygas, Google [Bot], Majestic-12 [Bot], nachtgold, Sogou [Bot]