Reply to topic

Notification popup gone after updating to 5.5.3

User avatar kamathraghavendra
Registered Member
Posts
232
Karma
4
OS
Hello All,
I don't know if this is the right place to ask this.

I am using plasma 5 on arch , plasma 5 received some 5.5.3 updates.
after the update i noticed the notification popup stopped appearing only the sound plays.

Is there a way to test this and get meaning full output to file a bug report, more importantly can any else reproduce this ?


User avatar Rog131
Registered Member
Posts
828
Karma
10
General Troubleshooting: viewtopic.php?f=14&t=38828


Testing with the kdialog:

Code: Select all
:~$ kdialog --help
Usage: kdialog [Qt-options] [KDE-options] [options] [arg]

KDialog can be used to show nice dialog boxes from shell scripts
...
--passivepopup <text> <timeout> Passive Popup
...


At here: Arch/Plasma 5.5.3

Old user => no plasma popup

Making a new user => There is a plasma popup

After cleaning the old user configuration files => there is a plasma popup

The configuration files: http://standards.freedesktop.org/basedi ... atest.html
There is a single base directory relative to which user-specific configuration files should be written. This directory is defined by the environment variable $XDG_CONFIG_HOME.

$XDG_CONFIG_HOME defines the base directory relative to which user specific configuration files should be stored. If $XDG_CONFIG_HOME is either not set or empty, a default equal to $HOME/.config should be used.



Maybe: https://www.kde.org/announcements/plasma-5.5.3.php
[notifications] Refactor the screen handling code to fix 'Notification Settings wrong default display for notifications and notifaction position'. Commit. Code review #126408. See bug #353966. See bug #356461


Maybe the refactored code can't understand old config files ?
User avatar Rog131
Registered Member
Posts
828
Karma
10
Are you using the panel Auto Hide setting ?

After I toyed a bit with the plasma settings it seems that the Auto Hide option is blocking the plasma notifications at here.
User avatar kamathraghavendra
Registered Member
Posts
232
Karma
4
OS
Hi Rog131,

General Troubleshooting: viewtopic.php?f=14&t=38828


Testing with the kdialog:

Code: Select all
:~$ kdialog --help
Usage: kdialog [Qt-options] [KDE-options] [options] [arg]

KDialog can be used to show nice dialog boxes from shell scripts
...
--passivepopup <text> <timeout> Passive Popup
...



At here: Arch/Plasma 5.5.3

Old user => no plasma popup

Making a new user => There is a plasma popup

After cleaning the old user configuration files => there is a plasma popup

The configuration files: http://standards.freedesktop.org/basedi ... atest.html

There is a single base directory relative to which user-specific configuration files should be written. This directory is defined by the environment variable $XDG_CONFIG_HOME.

$XDG_CONFIG_HOME defines the base directory relative to which user specific configuration files should be stored. If $XDG_CONFIG_HOME is either not set or empty, a default equal to $HOME/.config should be used.




Maybe: https://www.kde.org/announcements/plasma-5.5.3.php

[notifications] Refactor the screen handling code to fix 'Notification Settings wrong default display for notifications and notifaction position'. Commit. Code review #126408. See bug #353966. See bug #356461



Maybe the refactored code can't understand old config files ?


Initially I tested with kdialog, it is not working with it.
It didn't occur to me to create a new user and check this. I'll clean the configs and check.
I am correctly in the middle of some other process so can't check this immediately


Are you using the panel Auto Hide setting ?

After I toyed a bit with the plasma settings it seems that the Auto Hide option is blocking the plasma notifications at here.


Yes I am using autohide. Good to know that it affects the notification, i'll see if disabling auto-hide makes a difference here.


User avatar kamathraghavendra
Registered Member
Posts
232
Karma
4
OS
Hi Rog131,

I have tested this with clean config, removed configs for everything and started from scratch.
The notifications are there but only when panel is visible if the it is set to "Always Hide" or "windows can cover" mode then the notifications don't show up when you reboot,
How ever if you switch to always visible and then switch again to other options then the notification is persistent.

I think this is because of recent changes in notification system as you pointed out.
So I am filing a bug report for now.

the work around for getting popup in "windows can cover" or "always hide" mode is to switch to "always show" and back to these mode again

thank you for checking and testing this.


User avatar david_edmundson
KDE Developer
Posts
359
Karma
1
OS
Is it this? https://bugs.kde.org/show_bug.cgi?id=357652

Edit. Nevermind clearly was. Sorry, ignore this.
User avatar kamathraghavendra
Registered Member
Posts
232
Karma
4
OS
Hi david_edmundson

that bug report is filed by me just now :)


User avatar mck182
KDE Developer
Posts
138
Karma
0
OS
Hey,

just to clear things up. The refactor that was mentioned has nothing to do
with old config files. The bug happens because the binary part of the applet
sends out the available screen resolution _before_ the applet is fully loaded
AND also whenever the screen changes in any way. This works fine with the
non-auto hiding panel because once the panel gets loaded, it changes the
available screen area (cause the part where panel is is reserved and windows
cannot go there) and that change is told to the binary part of the applet and
that part tells the positioning part.

However with the auto-hiding panel the signal about the changed available
screen space never arrives because the panel does not take that space when
it loads. And so the applet was left with "available screen space = 0x0" because
the first signal is sent out before the applet is fully loaded.

So the obvious fix is to simply ask for the available screen space _after_ the
applet has finished loading.

I've posted a fix at https://bugs.kde.org/show_bug.cgi?id=357652#c5 which you
can test without any compiling.

If you guys could test that, that would be great :)


KDE Telepathy | Plasma | Plasma Mobile
User avatar kamathraghavendra
Registered Member
Posts
232
Karma
4
OS
Hi Martin Klapetek
I did as you instructed in the bug report. It seem to have fixed the problem for me.

Thank you for the step by step instructions

thank you again



 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], dcihon, Google [Bot], Sogou [Bot]