Reply to topic

Web browsing widget error: «"QtWebKit" is not installed»

User avatar eemantsal
Registered Member
Posts
118
Karma
0
OS
The desktop widget Web Browser -I think its called so; my KDE is in spanish and it reads «Navegador web»- doesn't display anything but a rectangle with an error icon and this error message:
Code: Select all
Error al cargar archivo QML: file:///usr/share/plasma/plasmoids/org.kde.plasma.webbrowser/contents/ui/main.qml:21:1: module "QtWebKit" is not installed

Qtwebkit is installed -version 5.5.1-r1- and the file main.qml exists. What may be the problem? I'm on Plasma 5.5.3 and KF 5.18, BTW.

Cheers.
User avatar google01103
Manager
Posts
6668
Karma
25
you might be missing libQt5WebKit5 used for Integration of the HTML rendering engine WebKit


OpenSuse Leap 42.1 x64, Plasma 5.x

User avatar eemantsal
Registered Member
Posts
118
Karma
0
OS
Thanks for your help. :)
Is libQt5WebKit5 the standard name for the package? I just seem to find references to Ubuntu and Debian. In my distro, Gentoo, the most approximate package name I find is dev-qt/qtwebkit, which as I said I have installed in its version 5.5.1-r1. I suspect that libqtwebkit version 5 might be some library into dev-qt/qtwebkit package, no?
User avatar google01103
Manager
Posts
6668
Karma
25
sorry meant libKF5WebKit5 (or something similar as diff distros name things differently)


OpenSuse Leap 42.1 x64, Plasma 5.x

drosca
KDE Developer
Posts
14
Karma
0
OS
User avatar eemantsal
Registered Member
Posts
118
Karma
0
OS
google01103 wrote:sorry meant libKF5WebKit5 (or something similar as diff distros name things differently)

Yes, those name changes suck...
Anyway, everything I find on the net seems related to Debain based distros and Suse, but searching its description «Integration of the HTML rendering engine WebKit» I find https://packages.gentoo.org/packages/kd ... /kdewebkit, which provides libKF5WebKit.so, libKF5WebKit.so.5 and libKF5WebKit.so.5.18.0. I had it installed too, but I've reinstalled, with no different result. :-\
I have just read in Gentoo forums someone with a slighty somilar problem being adviced to install PyQt with webkit compilation flag on; but PyQt isn't required among the dependencies for plasma-addons package in Gentoo. Could it be a error by Gentoo packagers, missing that dependency, or I'm complicating myself and effectively PyQT isn't required at all so better investigate other options?
User avatar eemantsal
Registered Member
Posts
118
Karma
0
OS
drosca wrote:You need qml-module-qtwebkit

Damn, there isn't either any name like that in Gentoo. Don't you know the original upstream name? Gentoo usually -not always, unfortunately- respects upstream package names.
Ok, I edit this to say that examining the files your link shows contained by qml-module-qtwebkit, and searching the one that seems more specific, libqmlwebkitplugin.so, for Gentoo I find 3 packages which contain it: dev-qt/qtwebkit, dev-qt/qtquick1 and dev-qt/qtdeclarative. All of them are installed in their last version, 5.5.1-r1. :-\
Thanls for your suggestion anyway.

Last edited by eemantsal on Sun Jan 24, 2016 8:42 pm, edited 1 time in total.
drosca
KDE Developer
Posts
14
Karma
0
OS
eemantsal wrote:Don't you know the original upstrean name?


Sorry, I missed the Gentoo part.
That file comes from qtwebkit, you need to just build it with QML support (that should be qml build flag in Gentoo package).
User avatar eemantsal
Registered Member
Posts
118
Karma
0
OS
drosca wrote:
eemantsal wrote:Don't you know the original upstrean name?

...qtwebkit, you need to just build it with QML support (that should be qml build flag...

Cool, I had it installed, but without QML flag on. Reinstalling now with it. Since this computer is not the most modern, precisely, compilation is going to take some time. But your point seems a good candidate. Let's see what happens.
Thank you. :)

Appendix
Ole! You were right. By default Gentoo's ebuild for Qtwebkit has the flag "qml" disabled. I just had to enable it, reinstall Qtwebkit, and now the widget works. Thanks a lot. :)

BTW, just out of curiosity, are you the guy behind Qupzilla?
User avatar eemantsal
Registered Member
Posts
118
Karma
0
OS
I have marked the problem as solved, but the title doesn't change. I thought it would be made automatically. Should I add something like «[Solved]» to the title, so people who may find this thread as a result in a web search can rapidly see the problem was solved? Because if not, even if it's marked as solved here, in the forum, outside it nothing indicates it's solved, right?
I don't really understand this system, sorry if I sound a bit retarded. x'D
User avatar google01103
Manager
Posts
6668
Karma
25
you should file a bug (?) with Gentoo suggesting the qml flag be enabled by default


OpenSuse Leap 42.1 x64, Plasma 5.x

User avatar eemantsal
Registered Member
Posts
118
Karma
0
OS
google01103 wrote:you should file a bug (?) with Gentoo suggesting the qml flag be enabled by default

I don't know. Gentoo by default enables the minimum options for things to function for an average use. If I haven't missed QML support in Qtwebkit but for the browser widget may be it's an intentioned dcision by Gentoo team to keep the distro's default lightness. Anyway I think I can follow your advice and just ask them, and see what they think.

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], BigaAl, Bing [Bot], dcihon, Google [Bot], Sogou [Bot], stnowell, Yahoo [Bot]