Reply to topic

Autohide Panel in Plasma 5.5 goes missing.

kirstinsjo
Registered Member
Posts
10
Karma
0
Using Plasma 5.5 on Kubuntu, Breeze theme.

I had my main Panel at the bottom edge. I created a second panel on the left, populated it with some widgets. I then set the first, main Panel to Visibility > Autohide.
It disappeared and now, it doesn't re-appear. When I go to the bottom edge with my cursor, I see a blue glowing line, but the Panel doesn't reappear and I can't access its settings. I know its there still, because it was my Main panel and so system update notifications still appear at the bottom edge, rather than the left where the second panel is.

- How can I change the first panel's setting back to Visibility > Always Visible
or
- How can I delete that panel? (So I can start again.)

Thanks!
kirstinsjo
Registered Member
Posts
10
Karma
0
Or... alternatively... how can I reset all of Plasma to default settings?
User avatar eemantsal
Registered Member
Posts
118
Karma
0
OS
I also have auto hide option enabled to take advantage of all my screen space, and the panel sometimes hides, some not. I think is a feature that needs more polishing. :-\

Ok, your problem: There are a couple of files: ~/.config/plasma-org.kde.plasma.desktop-appletsrc and ~/.config/plasmashellrc that contain info about the widgets.
I hope some other member will come with a more elegant solution, but you can try and search "panel" in said files and delete their entries. Before you do it, of course, make a copy of them so in case something fails you only have to restore them to go back to what you have now. I think you need to edit them from outside Plasma; I'n not sure, but I think that yes.
If you want to restore completely your desktop to default settings, exit your KDE session and, from a terminal or any other desktop environment, if you have any, delete all files named plasma[whatever] in ~/.config/ and restart your session:
Code: Select all
rm -f ~/.config/plasma*

It would be better some graphical tool for removing widgets when you can't access them, but AFAIK there isn't any. Editing the mentioned files is the only solution that comes to my mind, perhaps other users can tell you more.
User avatar google01103
Manager
Posts
6668
Karma
25
you can try editing the rc file ~/.config/plasmashellrc


probably [Panel 1]
line planelVisibility=
value I think should be 0

you may need to kquitapp plasmashell for it to take affect and then restart it


OpenSuse Leap 42.1 x64, Plasma 5.x

User avatar google01103
Manager
Posts
6668
Karma
25
eemantsal wrote:I also have auto hide option enabled to take advantage of all my screen space, and the panel sometimes hides, some not. I think is a feature that needs more polishing. :-\

Ok, your problem: There are a couple of files: ~/.config/plasma-org.kde.plasma.desktop-appletsrc and ~/.config/plasmashellrc that contain info about the widgets.
I hope some other member will come with a more elegant solution, but you can try and search "panel" in said files and delete their entries. Before you do it, of course, make a copy of them so in case something fails you only have to restore them to go back to what you have now. I think you need to edit them from outside Plasma; I'n not sure, but I think that yes.
If you want to restore completely your desktop to default settings, exit your KDE session and, from a terminal or any other desktop environment, if you have any, delete all files named plasma[whatever] in ~/.config/ and restart your session:
Code: Select all
rm -f ~/.config/plasma*

It would be better some graphical tool for removing widgets when you can't access them, but AFAIK there isn't any. Editing the mentioned files is the only solution that comes to my mind, perhaps other users can tell you more.


couple of notes:
1) don't think you would want to delete the plasma-workspace folder as that would supposedly contain env and shutdown scripts
2) you don't need to restart the session, just kquitapp plasmashell before deleting the plasma files then restart plasmashell
3) always backup just to be safe


OpenSuse Leap 42.1 x64, Plasma 5.x

kirstinsjo
Registered Member
Posts
10
Karma
0
google01103 wrote:you can try editing the rc file ~/.config/plasmashellrc


probably [Panel 1]
line planelVisibility=
value I think should be 0

you may need to kquitapp plasmashell for it to take affect and then restart it


This totally sorted it.
I should say that is seems counter-intuitive that visibility = 0 is "you can see it", at least to a n00b like me.
But I massively appreciate the quick and utterly helpful reply!
Massive, massive thanks!
User avatar eemantsal
Registered Member
Posts
118
Karma
0
OS
google01103 wrote:
eemantsal wrote:I also have auto hide option enabled to take advantage of all my screen space, and the panel sometimes hides, some not. I think is a feature that needs more polishing. :-\

Ok, your problem: There are a couple of files: ~/.config/plasma-org.kde.plasma.desktop-appletsrc and ~/.config/plasmashellrc that contain info about the widgets.
I hope some other member will come with a more elegant solution, but you can try and search "panel" in said files and delete their entries. Before you do it, of course, make a copy of them so in case something fails you only have to restore them to go back to what you have now. I think you need to edit them from outside Plasma; I'n not sure, but I think that yes.
If you want to restore completely your desktop to default settings, exit your KDE session and, from a terminal or any other desktop environment, if you have any, delete all files named plasma[whatever] in ~/.config/ and restart your session:
Code: Select all
rm -f ~/.config/plasma*


couple of notes:
1) don't think you would want to delete the plasma-workspace folder as that would supposedly contain env and shutdown scripts
2) you don't need to restart the session, just kquitapp plasmashell before deleting the plasma files then restart plasmashell
3) always backup just to be safe

Well, I especified to edit only the files if she just wanted to remove the buggy panel, but since she later asked for a default Plasma reset I recommended to delete all Plasma related stuff under ~/.config.
Also I thought it were less tricky to exit Plasma and make it from a terminal, but yes, she can open Konsole or any other terminal emulator in her Plasma session, kill plasmashell, do what she needs to do and relaunch plasmashell.

Another note: Kirstinsjo, in help forums it's usally recommended to mark an issue as solved when it is solved, so if any other user comes with the same problem, and sees several threads but only a few with the "solved" mark they can save time reading only the ones that have given a solution. You have a button which reads «Accept this answer» that marks the thread as solved.

You are massively welcome, BTW. :)

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], BigaAl, Bing [Bot], dcihon, giygas, Google [Bot], Majestic-12 [Bot], nachtgold, Sogou [Bot], suongmai