Reply to topic

Recommendations for Plasma 5 on ATI Mobility Radeon 7500?

lebkoungcity
Registered Member
Posts
1
Karma
0
Hello,

I'm writing this on my IBM ThinkPad R40 running gentoo and newly installed Plasma 5. Unfortunately I had/have some kind of trouble with the transition from KDE 4 to Plasma 5. Before I started to migrate I read somewhere (sorry I don't remember where it was) that the hardware requirements of Plasma 5 where similar to those of KDE 4 (it sounded like: "If you could run KDE 4 then you can run Plasma 5"). And in addition to that I don't have a real chance to stay with KDE 4 as support for it will be dropped. I always liked KDE and I want to stay with it and Plasma 5 is as far as I can see quite nice but here comes the 'big but': Hardware acceleration doesn't work on my little fellow and as it is a laptop I can't change it's hardware (and I don't have the money nor I'm willing to buy something new - the machine isn't broken).

I've already posted my question in the gentoo forums, so I take some parts from my postings from there: https://forums.gentoo.org/viewtopic-t-1047308.html

The graphics adapter is a:
Advanced Micro Devices, Inc. [AMD/ATI] RV200/M7 [Mobility Radeon 7500] which is capable of OpenGL-1.3.

First I had my graphics set to 'VIDEO_CARDS="radeon"' but this did not work so I switched to 'VIDEO_CARDS="vesa"', updated the system according to this and now SDDM and Plasma 5 are working - more or less usable but kind of annoyingly slow. Compositing is switched off (I also turned of all effects just to be sure...).

What happens in the case I try to run Plasma 5 with 'VIDEO_CARDS="radeon"':
    - if user 'sddm' is in the 'video' group SDDM shows a complete white screen; if user 'sddm' isn't in the 'video' group sddm acts normal and I can log in (using lightdm does not change anything in the following)
    - screen turns completly black
    - after a while mouse cursor appears (it is in the design that was chosen in systemsettings5 while I used "VIDEO_CARDS="vesa"') but nothing else is shown at this moment
    - after another while KMail-window opens (telling that the connection to akonadi isn't already established but some moments later that's OK) and I'm able to minimize/close this window
    - screen stays black
    - and another while later drkonqi shows up and tells me that plasma has died
    - (left / middle / right) clicking on the still black background doesn't do anything
    - I'm able to start konsole via clicking in the drkonqi-window the dialog which starts gdb (this opens up konsole in which gdb is being run) and then I can open up new tabs inside this window
    - I can start systemsettings5 via konsole but it instantly dies when I want to go to the setting to disable compositing giving me these lines:
Code: Select all
Constructing a KPluginInfo object from old style JSON. Please use kcoreaddons_desktop_to_json() for
"/usr/lib/qt5/plugins/kwin/effects/configs/kcm_kwin4_genericscripted.so" instead of kservice_desktop_to_json() in your CMake code.
QOpenGLShader: could not create shader
QOpenGLShader: could not create shader
QOpenGLShader: could not create shader
QOpenGLShader: could not create shader
QOpenGLShader: could not create shader
QOpenGLShader: could not create shader
QOpenGLShader: could not create shader
QOpenGLShader: could not create shader
QOpenGLShader: could not create shader
QOpenGLShader: could not create shader
Speicherzugriffsfehler


So I turned back to 'VIDEO_CARDS="vesa"', disabled compositing in systemstettings5 and after this changed to 'VIDEO_CARDS="radeon"' again, restarted the system to be 100% sure
--> everything is still the same (black screen, cursor appears, KMail shows up, plasma dies)

I found this thread:
https://bugs.kde.org/show_bug.cgi?id=356839
and added the given lines to ~.bashrc:
Code: Select all
QT_XCB_FORCE_SOFTWARE_OPENGL=1
LIBGL_ALWAYS_SOFTWARE="true"

but without an effect on my problem.

After this I remembered 'eselect qtgraphicssystem' and tried the different alternatives but this didn't help so I set it back to default:
Code: Select all
eselect qtgraphicssystem list
Available Qt Graphics Systems:                                                                                               
  [1]   native                                                                                                               
  [2]   opengl (experimental)                                                                                               
  [3]   raster (default) *


I found this quote:
KDE5 makes *much* more use of *much* more advanced OpenGL in *many* more GL contexts (QtQuick being the main driver here, but we also removed the OpenGL 1.3 backend from KWin) - it's very likely that this knocks out the virtualbox GL driver, yes.

(https://forum.kde.org/viewtopic.php?f=289&t=127425)

So I guess I'm stuck with 'VIDEO_CARDS="vesa"' because my machine will never be supported again? Or are there other things I could try to get a better performance (like it used to be with KDE 4)?


Thanks a lot for reading through this!

Greetings,
Andy

Reply to topic

Bookmarks



Who is online

Registered users: acrux, Baidu [Spider], bassamanator, Bing [Bot], blue_bullet, colstar, dixonpete, drspudbear, farid, Google [Bot], koffeinfriedhof, Lachu, Majestic-12 [Bot], Sogou [Bot], trixon, waynes, Yahoo [Bot]