Reply to topic

Plasmashell High CPU

paulcee
Registered Member
Posts
3
Karma
0

Re: Plasmashell High CPU

Sat Dec 23, 2017 2:00 pm
Registered here just to post something that might be releated, with a possible fix. Using openSUSE Tumbleweed, all updated and working fine. Yesterday, I decided to monkey around with my desktop settings, and spruce things up a bit. Long story short: I changed fonts on the display from the "Noto Sans" to another font I like much better. Upon powering up this morning and logging in...I got the dreaded plasmashell-100%-CPU-usage. I could still run yakuake, and terminal window responded.

Logged in as my test-user, and everything worked perfectly, with a different KDE profile. So it wasn't related to the versions/updates of KDE nor its components. Back to my 'regular' user, and ran "systemsettings5" from the command-line, and changed fonts back to Noto Sans. Restarted X with CTRL-ALT-Backspace (twice), and logged back in. And CPU was back to normal.

This could be related to font rendering. Just a thought.
metzman
Registered Member
Posts
171
Karma
3
OS

Re: Plasmashell High CPU

Sat Dec 23, 2017 2:56 pm
Welcome to the KDE Community Forums :)

paulcee wrote:This could be related to font rendering. Just a thought.


It may be one of what seems a myriad of differing reasons/causes proffered by users.

What fonts did you use?

Also running TW (currently 20171220) with fonts other than default, (I'm using Ubuntu) and don't have high or excessive CPU utilisation.

http://paste.opensuse.org/view/raw/38f17274
paulcee
Registered Member
Posts
3
Karma
0

Re: Plasmashell High CPU

Sat Dec 23, 2017 4:24 pm
metzman wrote:Welcome to the KDE Community Forums :)

Thanks.
metzman wrote:
paulcee wrote:This could be related to font rendering. Just a thought.

It may be one of what seems a myriad of differing reasons/causes proffered by users. What fonts did you use? Also running TW (currently 20171220) with fonts other than default, (I'm using Ubuntu) and don't have high or excessive CPU utilisation.
http://paste.opensuse.org/view/raw/38f17274

Using Avenir (or tried to), Truetype font, and it displayed that behavior. Tried it a few more times, and could duplicate the behavior. Have only gone back to Noto Sans, and haven't tried any others than that for my 'default', so it *COULD* be coincidental, but seems like it does follow the font change. May experiment more, though, but like I said, I'm just reporting things in the hopes it may help someone else/help the developers see something to actually get it resolved.

openSUSE Tumbleweed, plasma version 5.11.4, framework version 5.41.0, QT version 5.9.3. 64 Bit CPU, kernel 4.14. Nothing loaded from source, all from the Tumbleweed repos, so I only get the updates that are pushed down (well, for this at least..:) )
metzman
Registered Member
Posts
171
Karma
3
OS

Re: Plasmashell High CPU

Sat Dec 23, 2017 4:51 pm
paulcee wrote:Tried it a few more times, and could duplicate the behavior. Have only gone back to Noto Sans, and haven't tried any others than that for my 'default', so it *COULD* be coincidental, but seems like it does follow the font change. May experiment more, though, but like I said, I'm just reporting things in the hopes it may help someone else/help the developers see something to actually get it resolved.


If you're able to consistently reproduce the effect then it's probably better to create a bug report for it on bugzilla.
https://bugs.kde.org/enter_bug.cgi?prod ... nt=general

Include (obviously) all the relevant information and the steps needed to reproduce. On openSUSE (and probably other distributions) Avenir is not a distribution provided font, you may want to include a link to it in the bug report. (It may be a general problem with that font of course, but if you've used it previously that's less likely).
paulcee
Registered Member
Posts
3
Karma
0

Re: Plasmashell High CPU

Sun Dec 24, 2017 4:46 pm
metzman wrote:
paulcee wrote:Tried it a few more times, and could duplicate the behavior. Have only gone back to Noto Sans, and haven't tried any others than that for my 'default', so it *COULD* be coincidental, but seems like it does follow the font change. May experiment more, though, but like I said, I'm just reporting things in the hopes it may help someone else/help the developers see something to actually get it resolved.


If you're able to consistently reproduce the effect then it's probably better to create a bug report for it on bugzilla.
https://bugs.kde.org/enter_bug.cgi?prod ... nt=general

Include (obviously) all the relevant information and the steps needed to reproduce. On openSUSE (and probably other distributions) Avenir is not a distribution provided font, you may want to include a link to it in the bug report. (It may be a general problem with that font of course, but if you've used it previously that's less likely).

Just submitted it, thanks. Who knows if it's related or not at this point, but it may at least help some folks if they're struggling with this to get the information out.

Last time this happened, I wound up nuking my KDE configuration and restarting, which is a pain. Never occurred to me to look at the font, but this time I decided to brute-force it and undo changes one at a time, until it started working.
nvrs
Registered Member
Posts
2
Karma
0
OS

Re: Plasmashell High CPU

Fri Jan 05, 2018 1:18 pm
joshuaclayton wrote:I'm also experiencing high CPU usage for kwin_x11 and plasmashell.

The reason may or not be the same as yours.
For instance right now:
Code: Select all
Tasks: 248 total,   1 running, 247 sleeping,   0 stopped,   0 zombie
%Cpu(s): 15.3 us,  5.4 sy,  0.0 ni, 71.9 id,  7.1 wa,  0.0 hi,  0.2 si,  0.0 st
KiB Mem : 16172064 total,  1661924 free,  5758964 used,  8751176 buff/cache
KiB Swap: 17790796 total, 17790796 free,        0 used.  9068408 avail Mem

  PID USER      PR  NI    VIRT    RES    SHR S  %CPU %MEM     TIME+ COMMAND     
 1836 joshua    20   0 3247172 121944  67536 S  30.0  0.8  54:55.88 kwin_x11   
17046 joshua    20   0 1094668 138272  76816 S  17.8  0.9   5:03.76 systemsett+
 1057 root      20   0  353472  95180  62296 S  14.9  0.6  35:13.62 Xorg       
 1840 joshua    20   0  0.254t 344604 185172 S  11.9  2.1   9:35.03 plasmashell


I can consistently reproduce the issue by disconnecting the external hdmi monitor, running without it, and reconnecting the external monitor.

I'm wondering if there is something I can monitor (maybe dbus?) to gain insight into why the cpu usage goes way up, never comes back down, and eventually starts becoming unbearably slow to interact with.


I am experiencing the exact same issue, on a Dell XPS 15 9560 with the Nvidia drivers not installed and Nuveau black listed - i.e. i only use Intel gfx. Whenever i connect an external monitor through USB-C -> HDMI converter, plasmashell and kwin_x11 hogs on CPU core almost 100%. If a restart plasma via
Code: Select all
kquitapp5 plasmashell ; /usr/bin/plasmashell &
everything is fine.

Now, i have been running plasma on this machine since Arpil and this is the only major issue. Last time i came up against it, i eventually created a new user and the problem was gone! So it has to be some configuration setting which i either changed manually at some point or a plasma update triggered (is that even possible?) and now has re-surfaced. At any case, it's a very annoying problem but i am having trouble to trace the root cause.

edit: I have never touched the font settings (always used default Noto Sans) so it's not that and also, plasmashell / kwin_x11 never crashes, it's just eats up 1 cpu almost 100% and becomes really sluggish (after a while typing text into a browser / editor with any kind of feedback becomes very slow and almost unusable).

edit2: also i have looked through the logs while that's happening and i found nothing useful. Being a developer myself and having installed debug symbols - submitted a few traces / bug reports already, i would love to help if someone pointed me to the right direction.

edit3: this https://bugs.kde.org/show_bug.cgi?id=387321 may be related

edit4: I confirm that as the linked bug report describes (and also was mentioned by another poster in this thread), if i a) turn off the second monitor and only use a single display (event the external one) or leave the laptops screen as the primary one, this doesn't happen.
nicholasditoro
Registered Member
Posts
1
Karma
0

Re: Plasmashell High CPU

Sun Apr 29, 2018 6:32 am
After trying several posted experimental fixes related to Kubuntu/KDE in vain, I solved the problem of high CPU usage by installing Lubuntu, which does not use KDE.

Lubuntu uses LXDE which is not as flashy as KDE, but gets the job done in a much faster manner.

Hope that helps.
User avatar SecretCode
Registered Member
Posts
33
Karma
0
OS

Re: Plasmashell High CPU

Thu May 03, 2018 2:21 pm
I am also experiencing this issue - but on KDE 4 as well as KDE 5!
I've been running Kubuntu 14.04 for years, very stable. This issue only started affecting me early in March this year. After being unable to find a resolution I decided it was time to bite the bullet and upgrade, so I installed Kubuntu 18.04 ... and found the exact same issue. What could be causing this issue between different KDE versions and on fresh installations? (My theory is some "fix" from KDE 5 backported to Kubuntu 14.04 around that time.)

My symptoms are pretty much the same as described above. It's not immediate, but can happen within minutes of connecting the external monitor. System load slowly increases, CPU utilisation for kwin (kwin-x11 on KDE 5), plasma-desktop (plasmashell on KDE 5) and X slowly increases. The kwin fps effect (which you can find in desktop effects) goes crazy - fps value, normally around 61 for me, drops to single digits. Other KDE apps - Dolphin, Kate, etc - also show high cpu load. Non-KDE apps don't.

Disconnecting the external monitor allows all these values to return to normal, but it can take a minute or two.

Same laptop and same external monitor that have been fine for years. It's possible of course the hardware has developed a fault (in the cable, in the graphics adapter, in the monitor). Intel VGA controller, no special drivers.

The workarounds suggested, namely logging in with no external monitor, or setting the laptop as the primary display, haven't help. The high CPU still hits after a while.


I'd rather be locked out than locked in
User avatar SecretCode
Registered Member
Posts
33
Karma
0
OS

Re: Plasmashell High CPU

Tue May 08, 2018 9:46 pm
Well, I have a workaround ... add cooling. I've put my laptop on a stand with USB-powered fans. Now I'm able to run with an external monitor as normal and kwni, plasma and X utilisation aren't excessive (not exactly low but probably the same as what they always have been).

Why does heating cause a slowdown? I suppose because CPU frequency gets scaled down above certain temperatures to protect the hardware.

There must still be some issue with something in plasma or kwin or X (or all 3) causing the CPU or graphics card to get hot when an external monitor is plugged in, but I wouldn't be surprised if this varies with the hardware and settings.


I'd rather be locked out than locked in
aaron89
Registered Member
Posts
1
Karma
0

Re: Plasmashell High CPU

Wed Sep 19, 2018 1:17 am
Hi! I'm experiencing the same problem on Manjaro KDE with two monitors connected (VGA and HDMI ports) and AMD propietary graphics driver. A workaround that worked for me is suspend the composition with Alt+May+F12, and now all go much faster, even the tab switching in the browser and opening menus. I'm really considering disable composition forever, it's another experience now, it's blazing fast xD

However, plasmashell still uses around 16% of CPU.

UPDATE: After closing the Octopi animated icon in tray, plasmashell dissapeared from TOP command :O
airdrik
Registered Member
Posts
1854
Karma
5
OS

Re: Plasmashell High CPU

Wed Sep 19, 2018 6:32 pm
Animation speeds are configurable under System Settings -> Desktop Effects and in the settings for certain Application Styles such as Breeze.


airdrik, proud to be a member of KDE forums since 2008-Dec.
betlog
Registered Member
Posts
6
Karma
0

Re: Plasmashell High CPU

Thu Feb 13, 2020 12:46 am
Old, but google found it..and not much else, so I'll just say:
After this NUC being on overnight, I'm currently getting 45% CPU usage from kwin_x11 and 3% from google-chrome-stable.... yet when I killed chrome the kwin_x11 usage dropped to the usual; almost nothing. When I start chrome again it immediately starts ramping up kwin_x11's % again. Currently at 20% after only a few minutes.

I've been restarting plasmashell a lot lately, (i actually made a taskbar quicklauncher because i do it so often, kquitapp5 plasmashell && kstart plasmashell) due to unwarranted high usage and long delays in responsiveness, but I'm starting to think chrome is entirely responsible. Leaving it running or allowing it to use it's 'run in the background even when you quit' default-on option, is at least partially responsible.

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], Google [Bot], hensem, rabi, robgriff444, Section_8, Sogou [Bot]