Reply to topic

Plasma 5.11.0: Unable to switch user

User avatar sparhawk
Registered Member
Posts
430
Karma
0
OS
I just upgraded to Plasma 5.11.0, and I'm no longer able to switch user. That is, I click Kickoff > Leave > Switch User, which brings up the overlay saying "New Session". I click "Switch", and nothing happens. Alternatively, I can lock screen, and start the switcher from there, but that just brings up a blank blue screen, and I'm locked out of the system.

I'm using Arch Linux. I tried downgrading packages to determine the problem. If I downgrade plasma-workspace (5.11.0-1 => 5.10.5-4), the problem is fixed. (N.B. I also have to downgrade drkonqi (5.11.0-1 => 5.10.5-4), because of conflicting files.)

Presumably this is too large a bug to have been overlooked, so I wonder if there's something in my config that is preventing user switching?
kbroulik
KDE Developer
Posts
131
Karma
0
OS
Presumably this is too large a bug to have been overlooked, so I wonder if there's something in my config that is preventing user switching?
I'm sorry, I noticed the bug (with broken "Switch" button) a while ago and even knew what was the cause but didn't realize it had gotten into 5.11 :(

I just reverted the breaking commit. Plasma 5.11.1 to be released next Tuesday will contain this fix. Sorry about that.
User avatar sparhawk
Registered Member
Posts
430
Karma
0
OS
kbroulik wrote:I'm sorry, I noticed the bug (with broken "Switch" button) a while ago and even knew what was the cause but didn't realize it had gotten into 5.11 :(

I just reverted the breaking commit. Plasma 5.11.1 to be released next Tuesday will contain this fix. Sorry about that.

No worries. Thank you for the quick response. I can confirm that patching /usr/share/plasma/look-and-feel/org.kde.breeze.desktop/contents/components/UserDelegate.qml as per your commit fixes it for me. Cheers!
SomaTalos
Registered Member
Posts
2
Karma
0
OS
I can't switch too.. and there's some troubles with the User Manager.. I see only the user 1000, so I suppose some kind of connection with the user switching issue.

Patching does nothing for me.
SomaTalos
Registered Member
Posts
2
Karma
0
OS
Even with 5.11.1 there's something broken.

Now in the User Manager:

user 1001 see 1000 and 1001;
user 1000 see 1000.

user 1000 is an admin and 1001 is not.

If you play switching the two users and then log out one of two logged in, a black screen occurs.
twuxtlinus
Registered Member
Posts
1
Karma
0
OS
Hi,

I have the same problem as the OP (cannot switch user), also with ArchLinux. However, versions do not match - I am currently using Plasma v5.12.2, Frameworks v5.43.0, Qt v5.10.1. I posted on the ArchLinux Forum as well but until now without response.

Is this configuration related or a bug? How can I track it down?

Thanks!

 
Reply to topic

Bookmarks



Who is online

Registered users: alvinwong, Baidu [Spider], Bing [Bot], claydoh, Google [Bot], Lupccs, rblackwell, samo, Sogou [Bot], YaCy [Bot]