Reply to topic

Plasma 5.13 Wayland Session Refresh Rate Options

mccannmatt
Registered Member
Posts
4
Karma
0
Greetings,

I'm currently using Plasma 5.13 on openSUSE Tumbleweed. Fantastic release. However, one issue that I've found is that on my Ivy Bridge laptop with Intel 4000 graphics under the X11 session I'm able to select from several choices for display refresh rate. Setting it to 59.96 gives me 60 fps on the Kwin fps counter and the desktop is visibly smoother. All other options result in a refresh rate of 40 fps. Under the Wayland session In only have auto, 60 hz, and 40 hz as refresh options which results in 40 fps on the benchmark and a visibly less fluid experience. There is no 59.96 option to select in the drop down.

Is there any way other way to specify the refresh rate of the display under Wayland?

Thank you.
User avatar subdiff
Registered Member
Posts
59
Karma
0
OS
It should use automatically the 60fps. Why you don't use the 60fps option if it's available?
mccannmatt
Registered Member
Posts
4
Karma
0
Sorry, I thought I made that part clear. Even if I set the refresh rate to 60hz it stays at 40hz. The 60hz option has no impact on the refresh rate. The only option which has any impact is the 59.96 hz option which is not available under the Wayland session for whatever reason and thus my dilemma.

Meanwhile on one of my other machines with AMD graphics and a Dell monitor it is running perfectly at 60hz. I'm not sure if that means the laptop screen edid info isn't being directly identified or if the issue lies elsewhere, that was why I was wondering if I could manually set the refresh rate under the Wayland session.

Thank you for your reply so that I could (hopefully) clear that up.
mccannmatt
Registered Member
Posts
4
Karma
0
I should also mention that under Wayland on the Intel 4000 laptop the refresh rates are reported as 60,001.00hz and 40,001.00hz. On my AMD based desktop under Wayland the refresh rate is reported as 60,000.00hz. Not sure what that discprepency means.
mccannmatt
Registered Member
Posts
4
Karma
0
It seems that it could be an Intel driver bug from the comments I'm reading in this thread.

https://www.reddit.com/r/kde/comments/7 ... ng_screen/

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], daret, Exabot [Bot], Google [Bot], j8a, jejel, jmacleod, kfunk, knutter, lololapile, muscatelle, scottpetrovic, waynes