Reply to topic

[SOLVED] Not have advanced mouse settings - double click

Thommen
Registered Member
Posts
13
Karma
0
I want to set the double-click interval, but I do not have an advanced settings tab. In KDE, now I have → https://image.ibb.co/kthtmU/cRzWcyz.png, I am looking for a solution to get → https://image.ibb.co/dvAURU/GUvqCjs.png.
plasmashell 5.13.4
Qt: 5.11.1
Szkielety KDE: 5.49.0
kf5-config: 1.0
OS: Arch Linux

Last edited by Thommen on Tue Oct 09, 2018 8:54 am, edited 1 time in total.
tosky
Registered Member
Posts
190
Karma
3
Double click settings were moved under Desktop Behavior -> Workspace settings, because they are not specifically mouse-specific.


tosky, proud to be a member of KDE forums since 2008-Oct.
tosky
Registered Member
Posts
190
Karma
3
Oh, sorry, double click *interval*. That configuration panel was refactored, and I suspect that there is no much to do for this release.


tosky, proud to be a member of KDE forums since 2008-Oct.
Thommen
Registered Member
Posts
13
Karma
0
tosky wrote:Oh, sorry, double click *interval*. That configuration panel was refactored, and I suspect that there is no much to do for this release.

Did I understand correctly that I can not set a interval double click?
jcompton
Registered Member
Posts
8
Karma
0
I have found this setting under:

Settings -> System Settings -> Hardware -> Input Devices -> Mouse -> Advanced (I translated these items from my language, not sure if my translation is 100 % correct).

You can set the double click interval there, plus a few other things.
My Plasma version is 5.12.5, hopefully it hasn't been removed since.
User avatar Lembritt
Registered Member
Posts
4
Karma
0
OS
jcompton wrote:I have found this setting under:

Settings -> System Settings -> Hardware -> Input Devices -> Mouse -> Advanced (I translated these items from my language, not sure if my translation is 100 % correct).

You can set the double click interval there, plus a few other things.
My Plasma version is 5.12.5, hopefully it hasn't been removed since.


Same place in Plasma 5.13.4
Thommen
Registered Member
Posts
13
Karma
0
jcompton wrote:I have found this setting under:

Settings -> System Settings -> Hardware -> Input Devices -> Mouse -> Advanced (I translated these items from my language, not sure if my translation is 100 % correct).

I do not have this Advanced tab
reubot
Registered Member
Posts
2
Karma
0
You need to be using evdev instead of libinput to have the advanced settings tab.

You can change the double click rate manually by changing
Code: Select all
DoubleClickInterval
in the
Code: Select all
KDE
section of ~/.config/kdeglobals

The other mouse settings are in ~/.config/kaccessrc and ~/.config/kcminputrc
Thommen
Registered Member
Posts
13
Karma
0
reubot wrote:You can change the double click rate manually by changing
Code: Select all
DoubleClickInterval
in the
Code: Select all
KDE
section of ~/.config/kdeglobals

The other mouse settings are in ~/.config/kaccessrc and ~/.config/kcminputrc

I have


reubot wrote:You need to be using evdev instead of libinput to have the advanced settings tab.

I not remove libinput, because I have dependencies qt5-base and xf86-input-libinput
Rog131
Registered Member
Posts
818
Karma
10
Backend

The KDE System Settings can show both the old evdev and the new libinput settings.

Configuration with the X

The default is the new libinput:

Image


The older evdev can be enabled from the X configuration file - /etc/X11/xorg.conf.d/xorg.conf:

Code: Select all
Section "InputClass"
    Identifier "evdev-mouse"
    MatchIsPointer "yes"
    Driver "evdev"
EndSection


Image

Earlier

- Bug 398610 - Mouse settings have lost lot of settings: https://bugs.kde.org/show_bug.cgi?id=398610
- KReddit: https://www.reddit.com/r/archlinux/comm ... put_fails/


With the:
Operating System: Arch Linux
KDE Plasma Version: 5.13.90
Qt Version: 5.11.2
KDE Frameworks Version: 5.50.0
Kernel Version: 4.18.12-arch1-1-ARCH
Thommen
Registered Member
Posts
13
Karma
0
Rog131 wrote:Backend

The KDE System Settings can show both the old evdev and the new libinput settings.

Configuration with the X

The default is the new libinput:

Image


The older evdev can be enabled from the X configuration file - /etc/X11/xorg.conf.d/xorg.conf:

Code: Select all
Section "InputClass"
    Identifier "evdev-mouse"
    MatchIsPointer "yes"
    Driver "evdev"
EndSection


Image

Earlier

- Bug 398610 - Mouse settings have lost lot of settings: https://bugs.kde.org/show_bug.cgi?id=398610
- KReddit: https://www.reddit.com/r/archlinux/comm ... put_fails/


With the:
Operating System: Arch Linux
KDE Plasma Version: 5.13.90
Qt Version: 5.11.2
KDE Frameworks Version: 5.50.0
Kernel Version: 4.18.12-arch1-1-ARCH

This is an exhaustive answer. Thank you very much!
User avatar compatico
Registered Member
Posts
87
Karma
0
OS
Rog131 wrote:Backend
The KDE System Settings can show both the old evdev and the new libinput settings.

The default is the new libinput:

Image


That might be an Arch config thing - I'm running Kubuntu 18.04 and don't have the new libinput as default. I did a clean install of 18.04 after putting in a new SSD drive and the older style was default, then I had to install evdev package to get my mouse to work properly for acceleration. I may have to play around with this now...perhaps libinput was simply not working due to a KDE config setting...
Rog131
Registered Member
Posts
818
Karma
10
compatico wrote:

That might be an Arch config thing - I'm running Kubuntu 18.04 and don't have the new libinput as default. I did a clean install of 18.04 after putting in a new SSD drive and the older style was default, then I had to install evdev package to get my mouse to work properly for acceleration. I may have to play around with this now...perhaps libinput was simply not working due to a KDE config setting...[/quote]


Nate Graham - https://bugs.kde.org/show_bug.cgi?id=398610#c2
...What changed is that in Plasma 5.13, we now support Libinput when used as a mouse driver. So if you have Libinput installed, you will see the Libinput-specific configuration interface that lacks controls for features Libinput doesn't support...


Ubuntu - plasma-desktop: https://packages.ubuntu.com/search?keyw ... ection=all
bionic (18.04LTS) (kde): Tools and widgets for the desktop [universe]
4:5.12.4-0ubuntu1: amd64 arm64 armhf i386 ppc64el s390x
bionic-updates (kde): Tools and widgets for the desktop [universe]
4:5.12.6-0ubuntu0.1: amd64 arm64 armhf i386 ppc64el s390x



The Kinfocenter will show the plasma version: https://www.kde.org/applications/system/kinfocenter/

Image
User avatar compatico
Registered Member
Posts
87
Karma
0
OS
Rog131 wrote:Nate Graham - https://bugs.kde.org/show_bug.cgi?id=398610#c2
...What changed is that in Plasma 5.13, we now support Libinput when used as a mouse driver. So if you have Libinput installed, you will see the Libinput-specific configuration interface that lacks controls for features Libinput doesn't support...

Ah that explains it...Kubuntu 18.04 is still on 5.12 branch. I guess it'll get updated soon to 5.13 branch and then it'll work.
Thanks Rog131
;D

 
Reply to topic

Bookmarks



Who is online

Registered users: armandoo, Baidu [Spider], Bing [Bot], Exabot [Bot], Google [Bot], kc1di-qrp, rbreu, satyakimandal, Sogou [Bot], vilmasolo, Yahoo [Bot]