Reply to topic

Plasma Segmentation fault

User avatar Eazy
Registered Member
Posts
22
Karma
0
OS

Plasma Segmentation fault

Mon Nov 12, 2018 5:54 pm
Hi!
Have just installed KDE Neon and have finished setting up it how I want it. Now, whenever I try to change a icon Plasma segfaults. This happens when I use oxygen icon theme. I have tried to reinstall oxygen icon theme, but does not help. Am I alone with this? Anyone got a clue how to fix it?
albenson
Registered Member
Posts
5
Karma
0

Re: Plasma Segmentation fault

Mon Nov 12, 2018 8:26 pm
Yes, I am having the same issue with the Oxygen icon theme. It happens with a lot of third-party icon themes too, though some of them work fine.

Instead of showing the icon select dialog, it segfaults Plasma Shell, often with no DrKonqi popup.

When I do get the DrKonqi popup, it reports that the debug symbols are not installed, even though I do have plasma-workspace-dbg installed (same version as plasma-workspace), which I have gathered is the package needed for this. The automatic debug symbols installer fails silently in a few seconds.

Since the quality of the report is 0 stars, it won't submit it.

Plasma 5.14.3, Frameworks 5.51.0, Qt 5.11.2, kernel Ubuntu 4.15.0-39, on Neon user edition. Using Nvidia proprietary driver 415.

My laptop running the same KDE Neon version, but with Intel Integrated graphics, does not crash when I attempt to change icons with the Oxygen icon theme in use.

Eazy, are you using Nvidia proprietary drivers by any chance? This thing causes no end of frustration with Plasma... much worse than with Cinnamon, but I want to stick with KDE for its many good points, and the hope that the long standing issue with Nvidia drivers will someday be fixed.
User avatar Eazy
Registered Member
Posts
22
Karma
0
OS

Re: Plasma Segmentation fault

Mon Nov 12, 2018 8:41 pm
Yes I also use the Nvidia proprietary drivers and I use 4.15.0-38-generic kernel. I didn't have the same problem a week ago when I installed KDE Neon as a test install (before I decided to use KDE Neon) on the same machine and same Nvidia driver. Perhaps a bug report is needed.
User avatar Eazy
Registered Member
Posts
22
Karma
0
OS

Re: Plasma Segmentation fault

Tue Nov 13, 2018 6:10 pm
Today there was some updates that I installed. One of them was oxygen icon theme. After a reboot my problem seems to be fixed. Don't know if it was the updated icon theme that fixed it as there was many other updates.

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], Exabot [Bot], glenl, Google [Bot], thunder422, weegie, Yahoo [Bot]