Reply to topic

Can't launch Application launcher: Error loading QML file

boblundgren
Registered Member
Posts
29
Karma
0
Error loading QML file: file:///usr/share/plasma/plasmoids/org.kde.plasma.kicker/contents/ui/main.qml:27:1: module "org.kde.plasma.private.kicker" is not installed

I run Operating System: Kubuntu 18.10
KDE Plasma Version: 5.14.5
Qt Version: 5.11.1
KDE Frameworks Version: 5.52.0
Kernel Version: 4.18.0-15-generic
OS Type: 64-bit
Processors: 4 × Intel® Pentium® CPU 4415U @ 2.30GHz
Memory: 11.5 GiB of RAM

I was trying to fix a sound problem with pulse audio, I deleted pulse audio from GUI Discover, I have installed Them again.

Some of my latest code before KDE was broken:

sudo apt-get -u dist-upgrade
sudo apt-get -f install

Thanks
User avatar acheronuk
KDE Developer
Posts
113
Karma
2
Start by installing from Konsole:
Code: Select all
sudo apt install kubuntu-desktop plasma-desktop

Might also be worth looking in /var/log/apt/history.log to see what other packages were removed at the same time by Discover, via the apt packagekit backend.
boblundgren
Registered Member
Posts
29
Karma
0
Thanks for the fast reply!

Running: "sudo apt install kubuntu-desktop plasma-desktop"

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
plasma-desktop : Depends: libcanberra-pulse but it is not going to be installed
Recommends: plasma-pa (>= 4:5.14) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

HERE IS MY: /var/log/apt/history.log

Start-Date: 2019-02-13 21:54:15
Commandline: apt-get upgrade
Requested-By: shy1 (1000)
Upgrade: php7.2-common:amd64 (7.2.10-0ubuntu1, 7.2.15-0ubuntu0.18.10.1), php7.2-cli:amd64 (7.2.10-0ubuntu1, 7.2.15-0ubuntu0.18.10.1), gvfs-backends:amd64 (1.$
End-Date: 2019-02-13 21:54:55

Start-Date: 2019-02-14 19:01:33
Commandline: packagekit role='update-packages'
Requested-By: shy1 (1000)
Upgrade: flatpak:amd64 (1.0.6-0ubuntu1.1, 1.0.7-0ubuntu0.18.10.1), libflatpak0:amd64 (1.0.6-0ubuntu1.1, 1.0.7-0ubuntu0.18.10.1)
End-Date: 2019-02-14 19:01:38

Start-Date: 2019-02-15 11:52:03
Commandline: packagekit role='update-packages'
Requested-By: shy1 (1000)
Upgrade: grub-common:amd64 (2.02+dfsg1-5ubuntu8.1, 2.02+dfsg1-5ubuntu8.2), grub2-common:amd64 (2.02+dfsg1-5ubuntu8.1, 2.02+dfsg1-5ubuntu8.2), initramfs-tools$
End-Date: 2019-02-15 11:52:34

Start-Date: 2019-02-16 12:58:47
Commandline: apt-get remove --purge pulseaudio
Requested-By: shy1 (1000)
Purge: plasma-pa:amd64 (4:5.14.5-0ubuntu1~ubuntu18.10~ppa1), pulseaudio:amd64 (1:12.2-5~bionic1), latte-dock:amd64 (0.8.75+git20180923.1046-0~ubuntu18.04~ppa$
End-Date: 2019-02-16 12:58:54

Start-Date: 2019-02-16 13:06:39
Commandline: apt autoremove
Requested-By: shy1 (1000)
Remove: accountsservice-ubuntu-schemas:amd64 (0.0.7+17.10.20170922-0ubuntu1), plasma-browser-integration:amd64 (5.14.5-0ubuntu1~ubuntu18.10~ppa1)
End-Date: 2019-02-16 13:06:40

Start-Date: 2019-02-16 13:21:54
Commandline: packagekit role='install-packages'
Requested-By: shy1 (1000)
Install: libpam0g:i386 (1.1.8-3.6ubuntu2, automatic), libjson-glib-1.0-0:i386 (1.4.4-1, automatic), libxdmcp6:i386 (1:1.1.2-3, automatic), libkrb5-3:i386 (1.$
Remove: libpulsedsp:amd64 (1:12.2-5~bionic1), rtkit:amd64 (0.11-6), gstreamer1.0-plugins-bad:amd64 (1.14.4-1ubuntu1), libfluidsynth1:amd64 (1.1.11-1), vlc:am$
End-Date: 2019-02-16 13:22:16

Start-Date: 2019-02-16 13:23:33
Commandline: packagekit role='remove-packages'
Requested-By: shy1 (1000)
Remove: pulseaudio-equalizer:amd64 (2.7.0.2-5~webupd8~xenial0)
End-Date: 2019-02-16 13:23:35

Start-Date: 2019-02-16 13:23:51
Commandline: packagekit role='remove-packages'
Requested-By: shy1 (1000)
Remove: pavucontrol:amd64 (3.0-4)
End-Date: 2019-02-16 13:23:55

Start-Date: 2019-02-16 13:31:27
Commandline: apt install sddm xserver-xorg
Requested-By: shy1 (1000)
Start-Date: 2019-02-16 13:23:33
Commandline: packagekit role='remove-packages'
Requested-By: shy1 (1000)
Remove: pulseaudio-equalizer:amd64 (2.7.0.2-5~webupd8~xenial0)
End-Date: 2019-02-16 13:23:35

Start-Date: 2019-02-16 13:23:51
Commandline: packagekit role='remove-packages'
Requested-By: shy1 (1000)
Remove: pavucontrol:amd64 (3.0-4)
End-Date: 2019-02-16 13:23:55

Start-Date: 2019-02-16 13:31:27
Commandline: apt install sddm xserver-xorg
Requested-By: shy1 (1000)
Install: xserver-xorg:amd64 (1:7.7+19ubuntu8), python3-requests:amd64 (2.18.4-2ubuntu0.18.10.1, automatic), apport:amd64 (2.20.10-0ubuntu13.2, automatic), py$
End-Date: 2019-02-16 13:31:34

Start-Date: 2019-02-16 13:41:03
Commandline: packagekit role='install-packages'
Requested-By: shy1 (1000)
Install: pavucontrol:amd64 (3.0-4)
Remove: libsdl2-2.0-0:amd64 (2.0.8+dfsg1-4ubuntu1)
End-Date: 2019-02-16 13:41:07

Start-Date: 2019-02-16 13:41:39
Commandline: packagekit role='install-packages'
Requested-By: shy1 (1000)
Install: libgtkmm-2.4-1v5:amd64 (1:2.24.5-2, automatic), pavumeter:amd64 (0.9.3-4build2)


I think maybe this code: apt-get remove --purge pulseaudio messed it up?

I can't access my dock aswell.

Any help will be greatly appreciated, thanks!
boblundgren
Registered Member
Posts
29
Karma
0
Trying to install pulseaudio from terminal:

sudo apt-get install pulseaudio
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
pulseaudio : Depends: libpulse0 (= 1:12.2-0ubuntu4) but 1:12.2-5~bionic1 is to be installed
Depends: pulseaudio-utils but it is not going to be installed
Recommends: rtkit but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
User avatar acheronuk
KDE Developer
Posts
113
Karma
2
boblundgren wrote:The following packages have unmet dependencies:
pulseaudio : Depends: libpulse0 (= 1:12.2-0ubuntu4) but 1:12.2-5~bionic1 is to be installed


That suggests that you have broken package dependencies by installing from this unsupported 3rd party PPA.

https://launchpad.net/~mikhailnov/+arch ... lseeffects

You should remove (or downgrade to the official Ubuntu version) all packages installed from that PPA, then disable the PPA entirely.
boblundgren
Registered Member
Posts
29
Karma
0
Thank you very much, much appreciated!

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], bassamanator, Bing [Bot], bovender, Google [Bot], grosser, Majestic-12 [Bot], Merlimau, norobot, pareekyashovardhan, samidon, Sogou [Bot], Yahoo [Bot], zachalexy