Reply to topic

Plasma is laggy with nvidia drivers - possible fix?

MRK0017
Registered Member
Posts
20
Karma
0
OS
I was getting annoyed at how laggy Plasma is on Neon with the Nvidia drivers installed. Pretty much anything had some kind of lag on startup, even the application launcher (start menu). I messed around for like 4 hours and found no solutions whatsoever, I even installed the graphics drivers manually somehow (and yes they work just fine, and by fine I mean laggy as hell just like when I install them form the PPA and everything else) it was always laggy when starting anything. Eventually I installed this
kde-config-qt-graphicssystem
I couldn't find it in the software manager (Muon) so I grabbed the deb package from ubuntu.

It allowed me to open Plasma Renderer. I switched the settings to Rendering Backend: software, Render Loop: basic. Restarted plasmashell and everything now is twice as fast and responsive, I can even see the application launcher menu opening animation (which was killed by the starting lag I had before). There is still lag while starting an application (very noticeable when launching large apps such as the browser).

That being said, I don't think this is the most elegant solution to switch to software rendering. Also I don't think using this is a proper solution for removing the lag when installing nvidia drivers.

I really want to know why using Nvidia Drivers make everything so damn laggy.
Also using Nouveau instead of Nvidia, the responsiveness is just perfect, but I need the nvidia drivers for games and stuff.

And finally, I found this: https://bugs.kde.org/show_bug.cgi?id=406180
It appears that they solved it in Qt 5.12.4, but I have 5.12.3 on the latest Plasma. Some smart **** says "Update Qt", assuming that is even possible, I'd like to know how to do it.

List of things that I've tried and didn't solve the lag in the slightest
>Reinstalling the nvidia drivers from ppa
>purging the nvidia drivers
>reinstalling the driver from the official .run package
>changing refresh rate, composition pipeline, compositor settings, enabling the nvidia drm kernel module
>swearing loudly and repeatedly
MRK0017
Registered Member
Posts
20
Karma
0
OS
I made a mistake, this is related to Plasma 5 not Plasma.
Sorry.
Humbly requesting to move to the right board.

 
Reply to topic

Bookmarks



Who is online

Registered users: andreaaxx, Baidu [Spider], Bing [Bot], di3, farid, Google [Bot], magkoc, rye, Sogou [Bot]