Reply to topic

Wacom and Plasma issues

sreckom
Registered Member
Posts
18
Karma
0

Wacom and Plasma issues

Tue Aug 20, 2019 3:41 pm
I am having issue with some KDE apps and Wacom. For example System settings window works fine until I click Activities section, under Desktop Effects, all off the sudden I can not click anywhere, or there are some offset from cursor, until I restrt System settings window. Some apps, like Contact, it register hover but does not accept left click. Also Gwenviewer I can not grab and drag image. Some apps works perfectly. Everything works fine when using mouse. This happens on default Breeze theme, vanilla install too.

Using Nvidia drivers (two graphic cards, Titan and GTX1080Ti), KDE Neon, Plasma, latest updates.

Here is my post one Reddit, with video https://www.reddit.com/r/kde/comments/cr4nga/issue_with_wacom_in_kde_neon/

Anyone experiencing this?
sreckom
Registered Member
Posts
18
Karma
0

Re: Wacom and Plasma issues

Fri Sep 06, 2019 3:35 pm
Is it possible that this is only affecting me ....
Beerfoo
Registered Member
Posts
1
Karma
0

Re: Wacom and Plasma issues

Fri Oct 04, 2019 5:24 pm
I have exactly the same issue. Using a Wacom Intuos Pro M (via USB) as a mouse replacement due to hand issues.

Affected applications: Activities section under Desktop behavior, same Gwenviewer problem.
In addition i cannot click on anything in Virtualbox (start, configure, etc.), Menubar does not work.
Libre Office: Clicks not registered anywhere except in window decorations and some dialoges (after opening them with a shortcut), making Libre Office unusable.
I do not have Kontact installed at the moment, but had similar issues there.
Other applications work fine for me.

System info:

OS: Manjaro 18.1.0 Juhraya
Kernel: x86_64 Linux 5.2.11-1-MANJARO
Shell: bash 5.0.9
Resolution: 5120x1440
DE: KDE 5.61.0 / Plasma 5.16.4
WM: KWin
GTK Theme: Breath [GTK2/3]
Icon Theme: breeze-dark
Font: Noto Sans Regular
Disk: 196G / 476G (44%)
CPU: Intel Core i7-4770K @ 8x 4.5GHz [42.0°C]
GPU: GeForce GTX 780 Ti
RAM: 4591MiB / 32104MiB

Driver is Nvidia 435.21

It would be great if someone could look into this. Willing to help supply more information on the issue if it would help hunting the problem down.

Thanks!
Jflemaire
Registered Member
Posts
1
Karma
0

Re: Wacom and Plasma issues

Tue Nov 05, 2019 1:12 pm
I too have the same issues. I've been using KDE with a wacom tablet for years and this problem cropped up with KDE5/Qt5. It slowly got worse over the recent years, then slightly improved the last weeks (I'm on openSUSE Tumbleweed, so pretty up to date). There's a recent fix in Qt5 (5.11 I think) about mouse hover events that might explain the recent slight improvement.

For example, I'm a user of QCAD Professional, which is released in two versions: the qt4 build works perfectly, the qt5 one is totally unusable.

Anyway, I'm pretty confident this is Qt5-related and that applications are more or less impacted according to how they interact with the Qt code in handling the stylus.
KDlac
Registered Member
Posts
1
Karma
0

Re: Wacom and Plasma issues

Thu Nov 07, 2019 4:36 pm
Same issue :|

For example :
KO : Kontact, Virtualbox, Digikam, LibreOffice, VLC
OK : Firefox, Calibre, Chromium, Grsync, Inkscape, Dolphin, Krita, Gimp, Scribus, Okular

Asus N76VM
NVIDIA GeForce GT 630M with Optimus technology
Wacom Bamboo Pan CTL-470
Kubuntu 19.10
Breeze-dark theme for QT and GTK
sw
Registered Member
Posts
1
Karma
0

Re: Wacom and Plasma issues

Thu Jan 30, 2020 9:04 pm
i have/had the same problem and found this workaround to start applications with the problem:

Code: Select all
QT_XCB_TABLET_LEGACY_COORDINATES=1 application


For more info go to:
https://bbs.archlinux.org/viewtopic.php?id=248540

Updating to QT 5.14.1 may fix the problem complete. But didn't had the time and guts to test that.
https://bugreports.qt.io/browse/QTBUG-77826
ferweer
Registered Member
Posts
5
Karma
0

Re: Wacom and Plasma issues

Sat Feb 01, 2020 7:32 am
Hi, This issue is relevant to all users of tablets using 19.10kubuntu, neon, and qt-based software, but It may not be seen as an urgent problem for some reason.
Because it is considered that few users use these software using tablets? I dont know.

The address of the related problem.
https://github.com/linuxwacom/xf86-input-wacom/issues/93
One of them is a bug tracker that I post.
https://bugs.kde.org/show_bug.cgi?id=416361
Currently we can check software such as vlc, obs, libreoffice and kdenlive. If anyone has additional information on this issue, would you please post it on the bug tracker?

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], Bucham, dacorsa, debugster, Google [Bot], ipwizard, lwalper, therealkizu, Yahoo [Bot]