Reply to topic

Panel disappeared

equaeghe
Registered Member
Posts
64
Karma
0
OS

Panel disappeared

Wed Jan 22, 2020 12:04 pm
Hi,


My KDE Plasma panel has disappeared upon a reboot. This is the second time this happens. Previous time was last week and it ‘fixed’ itself a day later due to unknown causes.

Even when I try to add a (new) panel, nothing happens. Previously, when my panel appeared again, the new panels I had tried adding also appeared. I looked at my logs (systemd journal) and nothing appears when I try to add a panel.

In case anyone has experience with this kind of thing or can help diagnose the cause, I would really appreciate your help.


Best,

Erik
User avatar Mamarok
Manager
Posts
6041
Karma
16
OS

Re: Panel disappeared

Thu Jan 23, 2020 11:28 am
A little bit more information would be helpful:
Which exact Plasma version?
Which Plasma theme do you use?
Are you talking about the regular panel?
if yes, is it configured to be always visible?


Running Kubuntu 22.04 with Plasma 5.24.5, Frameworks 5.95.0, Qt 5.15.3, kernel 5.15.0-37 on Ryzen 5 4600H, AMD Renoir, X11
FWIW: it is always useful to state the exact Plasma version (+ distribution) when asking questions, makes it easier to help ...
equaeghe
Registered Member
Posts
64
Karma
0
OS

Re: Panel disappeared

Thu Jan 23, 2020 11:44 am
Mamarok wrote:Which exact Plasma version?

Plasma 5.17.4, Frameworks 5.64.0, KDe Apps 19.08.3, Qt 5.13.2
Mamarok wrote:Which Plasma theme do you use?

Breeze
Mamarok wrote:Are you talking about the regular panel?

Yes, I think so, with apps like the clock, menu, notifications, etc.
Mamarok wrote:if yes, is it configured to be always visible?

No, auto-hide. (That is not the problem.)

It just happened again, now in a running session. Again, no clues in the logs. I have been using Plasma 5 without this problem since it was stabilized on Gentoo, so for years. I was hoping that someone else had encountered it before and knew a fix. Googling hasn't helped me, the results are always about different issues.
User avatar Mamarok
Manager
Posts
6041
Karma
16
OS

Re: Panel disappeared

Thu Jan 23, 2020 11:50 am
What did you do exactly when this happened? I have never seen this happening, but I do not have it in auto-hide. Maybe an update to Plasma 5.17.5 could be a start..


Running Kubuntu 22.04 with Plasma 5.24.5, Frameworks 5.95.0, Qt 5.15.3, kernel 5.15.0-37 on Ryzen 5 4600H, AMD Renoir, X11
FWIW: it is always useful to state the exact Plasma version (+ distribution) when asking questions, makes it easier to help ...
wizonesolutions
Registered Member
Posts
4
Karma
0

Re: Panel disappeared

Tue Jan 28, 2020 2:55 pm
I am encountering the same issue. I use Manjaro Linux 18.1.5.

I can work around it by deleting
Code: Select all
~/.config/plasma-org.kde.plasma.desktop-appletrc
, but it will come back after updates. I have not been able to isolate the problem more narrowly than these steps:

1) Do a "large" system update; generally includes the kernel. For example, this pending update looks like it might cause the issue

Code: Select all
:: Synchronizing package databases...
 core                                                              167.9 KiB   542 KiB/s 00:00 [########################################################] 100%
 extra                                                            1970.7 KiB  5.96 MiB/s 00:00 [########################################################] 100%
 community                                                           5.8 MiB  11.1 MiB/s 00:01 [########################################################] 100%
 multilib                                                          192.5 KiB  9.40 MiB/s 00:00 [########################################################] 100%
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...

Packages (56) ansible-2.9.4-1  ca-certificates-20181109-3  ca-certificates-mozilla-3.49.2-1  ca-certificates-utils-20181109-3  dbeaver-6.3.3-1
              dbus-1.12.16-5  docker-compose-1.25.3-1  electron-7.1.10-1  etckeeper-1.18.14-1  ffmpeg-1:4.2.2-2  grub-2.04-10  gst-plugins-bad-1.16.2-2
              gst-plugins-good-1.16.2-2  intel-media-sdk-19.4.0-4  lib32-alsa-lib-1.2.1.2-2  lib32-dbus-1.12.16-2  lib32-nss-3.49.2-1
              lib32-p11-kit-0.23.19-1  lib32-util-linux-2.35-1  libmfx-19.4.0-4  libsecret-0.20.0-1  libutil-linux-2.35-1  libuv-1.34.2-1  lilv-0.24.6-2
              linux54-5.4.14-2  linux54-acpi_call-1.1.0-17  linux54-headers-5.4.14-2  linux54-ndiswrapper-1.62-17  linux54-nvidia-440xx-440.44-14
              linux54-nvidiabl-0.88-17  linux54-virtualbox-host-modules-6.1.2-3  lv2-1.16.0-3  manjaro-browser-settings-20200124-1  mkinitcpio-27-2.1
              nss-3.49.2-1  nvidia-440xx-utils-440.44-4  octopi-0.9.0-22  octopi-notifier-frameworks-0.9.0-22  p11-kit-0.23.19-1  perl-ffi-checklib-0.26-1
              python-mako-1.1.1-1  python-zipp-1.0.0-1  qt5-wayland-5.14.0-3  serd-0.30.2-1  sord-0.16.4-1  sratom-0.6.4-1  systemd-242.153-3
              systemd-libs-242.153-3  systemd-sysvcompat-242.153-3  telegram-desktop-1.9.8-1  thunderbird-68.4.2-0.1  thunderbird-i18n-en-us-68.4.2-0.1
              thunderbird-i18n-sl-68.4.2-0.1  udiskie-2.0.4-1  util-linux-2.35-1  wpa_supplicant-2:2.9-4

Total Download Size:    426.32 MiB
Total Installed Size:  1259.01 MiB
Net Upgrade Size:        10.44 MiB

:: Proceed with installation? [Y/n]


2) Reboot
3) After logging into the system again, the taskbar might have disappeared

I am not sure if it's the update of something from KDE itself that causes the issue. My taskbar is not even customized anymore; I just use the default settings, since I keep having to reset them anyway.

After I delete the config file mentioned above, I run:

Code: Select all
kquitapp5 plasmashell && kstart5 plasmashell &


to get the taskbar back.

I am not sure what I might look for in `journalctl` or other logs in order to figure out why the taskbar does not appear. It is probably a bit too time-consuming for me to install updates one-by-one to figure out exactly which one is causing the issue. I'm also not sure if it's related to mkpcinitio (which would explain why it seems to happens after kernel updates).

Any tips for further debugging welcome. I was about to post this issue myself.
User avatar Mamarok
Manager
Posts
6041
Karma
16
OS

Re: Panel disappeared

Tue Jan 28, 2020 3:02 pm
How about filing a bug report? https://bugs.kde.org is the place I suggest continuing this discussion. And please specify the exact Plasma version, the distribution numbering is not really helping, that would need us to remember in which number of distribution xy a specific Plasma version is in use...


Running Kubuntu 22.04 with Plasma 5.24.5, Frameworks 5.95.0, Qt 5.15.3, kernel 5.15.0-37 on Ryzen 5 4600H, AMD Renoir, X11
FWIW: it is always useful to state the exact Plasma version (+ distribution) when asking questions, makes it easier to help ...
wizonesolutions
Registered Member
Posts
4
Karma
0

Re: Panel disappeared

Tue Jan 28, 2020 3:21 pm
Will do so. I didn't really have concrete information, so I didn't want to waste the developers' time, but if you are suggesting I file a report anyway, that's good enough for me :)
equaeghe
Registered Member
Posts
64
Karma
0
OS

Re: Panel disappeared

Tue Jan 28, 2020 3:38 pm
FWIW, the bug report I filed: https://bugs.kde.org/show_bug.cgi?id=416739
taoxu
Registered Member
Posts
3
Karma
0

Re: Panel disappeared

Sun Sep 20, 2020 8:50 am
wizonesolutions wrote:I am encountering the same issue. I use Manjaro Linux 18.1.5.

I can work around it by deleting
Code: Select all
~/.config/plasma-org.kde.plasma.desktop-appletrc
, but it will come back after updates. I have not been able to isolate the problem more narrowly than these steps:
...


Thanks, my default panel comes back after removing
Code: Select all
~/.config/plasma-org.kde.plasma.desktop-appletrc
vgbdev
Registered Member
Posts
1
Karma
0

Re: Panel disappeared

Wed Sep 23, 2020 9:05 pm
On Arch, I had the same issue after I installed xf86-video-intel package. Remove the package and reboot seem to fix the issue.
equaeghe
Registered Member
Posts
64
Karma
0
OS

Re: Panel disappeared

Thu Sep 24, 2020 7:09 am
vgbdev wrote:On Arch, I had the same issue after I installed xf86-video-intel package. Remove the package and reboot seem to fix the issue.

Please add this information to the bug https://bugs.kde.org/show_bug.cgi?id=416739 (if you haven't done so already).
danielplan
Registered Member
Posts
1
Karma
0

Re: Panel disappeared

Sun Dec 20, 2020 12:44 pm
Same issue after update on arch linux system. plasma-desktop 5.20.4-2
Removing ~/.config/plasmashellrc did the workaround

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], claydoh, Google [Bot], ipwizard, Sogou [Bot], tnittner