Reply to topic

KDE has narcolepsy

Reziac
Registered Member
Posts
8
Karma
0

KDE has narcolepsy

Mon Mar 16, 2020 6:16 am
KDE-current on PCLinuxOS-current, all updated (rolling). I'm not sure if this is a bug or just something I'm missing.

Normally it doesn't fall asleep while it's busy. Sleep happens after 20 minutes of total idleness, in the desired fashion....

EXCEPT for two cases:
1) while QMMP is streaming audio
2) while Synaptic is downloading updates

In either case, after 20 minutes it goes to sleep, which naturally cuts off the network connection. This means I have to babysit big updates, and it's not much use for background music. This didn't used to happen, but I'm not sure when it started.

It does NOT fall asleep while:
-- streaming video in a browser.
-- streaming audio via WinAmp in a WinXP VM.
-- PCLOS/Trinity is downloading updates in a VM.

"Energy Saving" is set to: Suspend Session and Automatically Sleep after 20 min.
(I think this was the default, other than maybe the minutes.)

Is there something else I need to look at or do?? I really like having it autosleep, because this machine's usage is so irregular that it's not practical to do it more manually (I'd wear out the power button), so I don't want to fundamentally change how it operates -- just fix these two instances, if possible. Otherwise it works perfectly.

It wakes up on demand, no issues there. (Well, once in a long while I have to tap the power button to get its attention, but it still wakes up.)

Also, is there any particular advantage to hibernate or hybrid sleep? regular sleep puts it into effectively zero power use, which is nice cuz I can just leave it on when not in use.
User avatar Mamarok
Manager
Posts
4363
Karma
11
OS

Re: KDE has narcolepsy

Wed Mar 18, 2020 12:32 am
Which exact Plasma version is this about?

FWIW: we can't know which distribution ships which Plasma version as current, this is too much subject to change, and there are quite a few distributions out there...


Currently running Kubuntu 19.10, Plasma 5.18.3, Frameworks 5.67.0, Qt 5.12.4, kernel 5.3.0-42
FWIW: it is always useful to state the Plasma version and distribution when asking questions in this forum, makes it easier for us to help ...
Reziac
Registered Member
Posts
8
Karma
0

Re: KDE has narcolepsy

Wed Mar 18, 2020 1:32 am
System Information sayeth:

Operating System: PCLinuxOS 2020
KDE Frameworks Version: 5.68.0
Qt Version: 5.12.7
Kernel Version: 5.5.6-pclos2
OS Type: 64-bit
Processors: 8 × Intel® Core™ i7-3770 CPU @ 3.40GHz
Memory: 23.5 GiB of RAM

and stuff like Dolphin and KFind says "version 19.12.3"

I wish the KDE About tab (on Help About any app) still had KDE version info, but it doesn't!

Anyway I think this drowsiness started about 3-4 months ago??
User avatar Mamarok
Manager
Posts
4363
Karma
11
OS

Re: KDE has narcolepsy

Wed Mar 18, 2020 1:36 am
so the Plasma version is 5.18.3 I guess...

"KDE version info" should not be used anymore, as the desktop you get is Plasma, KDE is the community behind it, and AFAIK we do not have different versions of ourselves :-)


Currently running Kubuntu 19.10, Plasma 5.18.3, Frameworks 5.67.0, Qt 5.12.4, kernel 5.3.0-42
FWIW: it is always useful to state the Plasma version and distribution when asking questions in this forum, makes it easier for us to help ...
Reziac
Registered Member
Posts
8
Karma
0

Re: KDE has narcolepsy

Wed Mar 18, 2020 1:45 am
Mamarok wrote:so the Plasma version is 5.18.3 I guess...


[roots through Synaptic, since I can't find the version for sure anywhere else]

Yes, 5.18.3-1pclos2020, or so it tells me.
User avatar Mamarok
Manager
Posts
4363
Karma
11
OS

Re: KDE has narcolepsy

Wed Mar 18, 2020 3:54 pm
KInfoCenter and the System Settings both have this information, much easier :-)


Currently running Kubuntu 19.10, Plasma 5.18.3, Frameworks 5.67.0, Qt 5.12.4, kernel 5.3.0-42
FWIW: it is always useful to state the Plasma version and distribution when asking questions in this forum, makes it easier for us to help ...
Reziac
Registered Member
Posts
8
Karma
0

Re: KDE has narcolepsy

Wed Mar 18, 2020 4:50 pm
Mamarok wrote:KInfoCenter and the System Settings both have this information, much easier :-)


Didn't occur to me to look there... the hazard of it not being my daily driver, I forget these things :)
Reziac
Registered Member
Posts
8
Karma
0

Re: KDE has narcolepsy

Fri Mar 20, 2020 7:46 am
So I installed the same original ISO on a different system. Before any updates, this is it:
(the narcoleptic has been kept updated; rolling has ruined me)

Operating System: PCLinuxOS 2019
KDE Frameworks Version: 5.66.0
Qt Version: 5.12.6
Kernel Version: 5.4.11-pclos1
OS Type: 64-bit
Processors: 2 × Intel® Pentium® CPU P6200 @ 2.13GHz
Memory: 3.5 GiB of RAM

It does NOT seem to have the narcolepsy problem.

ETA: Well, yes, it does, but differently. It apparently finished downloading, but didn't finish installing, tho it closed Synaptic before it went to sleep. <scratching head>

This system is a laptop, if that matters; the other is a desktop.

===

Unrelated: Is there a way to remap a single key? this laptop's F key does not work, but if I could map Capslock to F, that would do.
User avatar Mamarok
Manager
Posts
4363
Karma
11
OS

Re: KDE has narcolepsy

Fri Mar 20, 2020 6:29 pm
Only answering the last questions as I don't know a solution for the previous one:

The actual letter F or did you mean the Fn key? For the letter: not that I know of, only functions and key sequences can be remapped, but if the Fn key doesn't work then this is a hardware issue that can't be solved by remapping the key.


Currently running Kubuntu 19.10, Plasma 5.18.3, Frameworks 5.67.0, Qt 5.12.4, kernel 5.3.0-42
FWIW: it is always useful to state the Plasma version and distribution when asking questions in this forum, makes it easier for us to help ...
Reziac
Registered Member
Posts
8
Karma
0

Re: KDE has narcolepsy

Fri Mar 20, 2020 9:25 pm
Mamarok wrote:The actual letter F or did you mean the Fn key? For the letter: not that I know of, only functions and key sequences can be remapped, but if the Fn key doesn't work then this is a hardware issue that can't be solved by remapping the key.

Yes, the actual letter F key. It's definitely hardware (doesn't work in any context). It can be remapped in Windows (you should see the horrible things a friend does with AutoHotKey!), but I don't need another Windows laptop.

I tried using alt-numpad as I can in Windows or DOS, but this doesn't seem to work.
User avatar toad
Global Moderator
Posts
1259
Karma
7
OS

Re: KDE has narcolepsy

Sat Mar 21, 2020 9:11 am
If you want to keep the default 20 minute sleep setting but not have it affect your updates or keep the music running you could always create a new activity which prevents the box from shutting down. Simply change the activity and the new settings will take effect.

HTH :)


Debian testing
Reziac
Registered Member
Posts
8
Karma
0

Re: KDE has narcolepsy

Sat Mar 21, 2020 2:56 pm
toad wrote:If you want to keep the default 20 minute sleep setting but not have it affect your updates or keep the music running you could always create a new activity which prevents the box from shutting down. Simply change the activity and the new settings will take effect.

HTH :)


I thought about doing something like that, but the problem is if I want to leave a big update running and go to bed (cuz my connection is that slow) ... well, you can see how that won't work for Synaptic. However it might do for streaming music... what small activity would you suggest? I haven't messed with activities at all, so use small words. :)

I do something similar with an external hard drive that insists on going to sleep every 30 minutes (WinAmp runs on that box in silent mode, 24/7, so every 4 minutes it has to retrieve another file -- not enough activity to be a problem, but enough to keep it awake.)
User avatar toad
Global Moderator
Posts
1259
Karma
7
OS

Re: KDE has narcolepsy

Sun Mar 22, 2020 7:21 am
On your empty desktop press ALT + D to open the activity dialogue. Click on Create New and select an appropriate icon (or not) and give it a name. While you are at it take a look at the keybindings for switching between activities in the next tab.

To change the default behaviour for the new activity go into SystemSettings - Power Manangement - Power Management - Activity Settings. In the dialogue box you'll have two tabs representing your activities. The rest should be self explanatory and yes, it will work with Synaptic, too.

All the best.


Debian testing

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], farid, Google [Bot], Majestic-12 [Bot], PanMat, Sogou [Bot], Stephen Leibowitz