Reply to topic

Couldn’t install Plasma Mobile on Nexus 5x

joergw
Registered Member
Posts
9
Karma
0
I tried to install several times the Plasma Mobile on my Nexus 5x, which fails. The script of the pm-flashtool could push the image, but after the script has finished, the device shows a message, that the operation system is corrupt.

Because a custom ROM was installed on my Nexus 5x, I did install the latest factory image of Android 6.0.1 with the script
Code: Select all
./flash-all.sh
from https://developers.google.com/android/images to solve this issue.

After setting up the phone, I followed the instructions on https://plasma-mobile.org/nexus-5/ and executed
Code: Select all
./pm-flash -p neon
without the optional HALIUM based IMG.

My Nexus 5x did reboot several times, so it seems, that the script works partly, but it ended up in the TWRP tool.

The last lines of the console output are …
Code: Select all
+ echo 'Installing lxc userspace tools'
Installing lxc userspace tools
+ adb push cache/lxc-android.tar.gz /data/
cache/lxc-android.tar.gz: 1 file pushed. 6.3 MB/s (887488 bytes in 0.134s)
+ adb shell tar xf /data/lxc-android.tar.gz
+ echo 'Installing plasma rootfs'
Installing plasma rootfs
++ readlink -f cache/pm-rootfs.tar.gz
readlink: illegal option -- f
usage: readlink [-n] [file ...]
+ adb push /data/pm-rootfs.tar.gz
Android Debug Bridge version 1.0.39
Revision 3db08f2c6889-android
… before the output says, that the stuff is „Installed as … adb“ followed by a list of adb commands.

If I select „Reboot“ and „System“ in TWRP, my Nexus 5x shows just the word „android“.

I tried the following commands:
Code: Select all
adb root
adb shell
lxc-start -n system -F
The output says:
Code: Select all
lxc-start: lxc_start.c: main: 295 Executing '/sbin/init' with no configuration file may crash the host
It seems, that the system didn’t start:
Code: Select all
lxc-stop -n system
system is not running
If I force a reboot with adb the Nexus 5X shows a message, that the device is corrupt.

Has someone an idea to solve this issue? I would like to evaluate Plasma Mobile as the base system for professional product development.

Reply to topic

Bookmarks



Who is online

Registered users: alainroger, Baidu [Spider], Bing [Bot], boudewijn, ChompTheTrike, chrisogilvie, Exabot [Bot], Google [Bot], johssw, jsola, louis94, scummos, smankowski, Sogou [Bot], Yahoo [Bot]