Reply to topic

QML Cannot Find org.kde.plasma... import packages

jroc
Registered Member
Posts
1
Karma
0
Hoping someone can point me in the right direction with this one; having spend days googling around for an answer, but so far none to be had. I am attempting my first plasmoid. Using the simple KDE tutorial for this I have built the files. But any of the modules of type "org.kde.plasma..." (as in: import org.kde.plasma.components 2.0 as PlasmaComponents) fail to be found with the import statements. This shows up in KDevelop or when I attempt to launch the QML hello world document from the console. In hunting through my file system they all do seem to be there under /usr/lib64/qt5/qml/org/kde/plasma. So why can't the QML engine find them? Note that it *does* successfully find QtQuick 2.0 (as in: import QtQuick 2.0).

I do have kf5-plasma 5.38 package installed; as well as kf5-frameworkintegration; and all the development packages for Qt5 and the KDevelop plugins.

Does this sound familiar to anyone? Or any ideas? Or know of anyone who might be able to help me?

Reply to topic

Bookmarks



Who is online

Registered users: aitorpazos, Baidu [Spider], Bing [Bot], Capitain_Jack, dudoser, Exabot [Bot], ggael, Google [Bot], Majestic-12 [Bot], paolof, reinhardgelen, smankowski, Sogou [Bot], sspphheerraa, TheraHedwig, Yahoo [Bot]