Reply to topic

New Kate build, no plugins

coosadog
Registered Member
Posts
1
Karma
0

New Kate build, no plugins

Thu Nov 06, 2014 6:52 pm
I just built the latest Kate from repository. I couldn't get it to show the plugins. I then did make install, hoping that would fix it, but no. No plugins. They are in this directory:
/usr/lib/x86_64-linux-gnu/plugins/ktexteditor/

I have a shell script in ~/.kde by the name of set-kate-vars.sh. (not sure this is the correct location...)

I found the script information in the installation instructions. This file contains:

#!/bin/bash
export KATE_DIR=/usr
export PATH=$KATE_DIR/bin:$PATH
export LD_LIBRARY_PATH=$KATE_DIR/lib:$KATE_DIR/lib64:$LD_LIBRARY_PATH
export KDEDIR=$KATE_DIR
export KDEDIRS=$KDEDIR:$KDEDIRS
export XDG_DATA_DIRS=$KATE_DIR/share:$(kde4-config --prefix)/share:$XDG_DATA_DIRS

I looked in the source code for something that sets the path to plugins but only found 'ktexteditor' set. I think it can't find the plugins because of the path and I see no environment variable for setting it. I'm not familiar with KDE and it's internals. I have used Kate for years and like it but it's not worth fooling with w/o plugins. Here is a console log when executing it:

tom@tom-A770E3:~$ kate
Couldn't start kglobalaccel from org.kde.kglobalaccel.service: QDBusError("org.freedesktop.DBus.Error.ServiceUnknown", "The name org.kde.kglobalaccel was not provided by any .service files")
"Theme tree: (Oxygen)"

My opsys is Xubuntu 14.10, 64 bit. I appreciate any help very much, thanks!
User avatar domson
Registered Member
Posts
20
Karma
0
OS

Re: New Kate build, no plugins

Sat Feb 23, 2019 9:11 pm
It has been some time, but same situation here!
Have you found a solution?


The ships hung in the sky in much the same way that bricks don't. - Douglas Adams

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], gfielding, Google [Bot], hiteshshah, lucianosalomoni, Majestic-12 [Bot], nharvey, pseco, TheBeheader, Yahoo [Bot]