Reply to topic

kio-extras Build Dependencies

User avatar Calum
Registered Member
Posts
1
Karma
0

kio-extras Build Dependencies

Mon Sep 03, 2018 9:18 pm
Hello. I'm following https://community.kde.org/Get_Involved/development#Set_up_your_development_environment and can't find a way to install the dependencies for kio-extras. I'm running KDE neon.
Code: Select all
sudo apt build-dep kio-extras
[sudo] password for calum:
Reading package lists... Done
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Starting pkgProblemResolver with broken count: 1
Starting 2 pkgProblemResolver with broken count: 1
Investigating (0) libexiv2-dev [ amd64 ] < none -> 0.26-2~+16.04+xenial+build15 > ( libdevel )
Broken libexiv2-dev:amd64 Depends on libssh-gcrypt-dev [ amd64 ] < none -> 0.6.3-4.3 > ( libdevel )
  Considering libssh-gcrypt-dev:amd64 0 as a solution to libexiv2-dev:amd64 0
  Holding Back libexiv2-dev:amd64 rather than change libssh-gcrypt-dev:amd64
Investigating (1) builddeps:kio-extras [ amd64 ] < none -> 1 > ( unknown )
Broken builddeps:kio-extras:amd64 Depends on libexiv2-dev [ amd64 ] < none -> 0.26-2~+16.04+xenial+build15 > ( libdevel )
  Considering libexiv2-dev:amd64 0 as a solution to builddeps:kio-extras:amd64 9998
  Re-Instated libssh-gcrypt-dev:amd64
  Re-Instated libexiv2-dev:amd64
Investigating (1) libssh-dev [ amd64 ] < none -> 0.6.3-4.3 > ( libdevel )
Broken libssh-dev:amd64 Conflicts on libssh-gcrypt-dev [ amd64 ] < none -> 0.6.3-4.3 > ( libdevel )
  Considering libssh-gcrypt-dev:amd64 0 as a solution to libssh-dev:amd64 0
  Holding Back libssh-dev:amd64 rather than change libssh-gcrypt-dev:amd64
Investigating (2) builddeps:kio-extras [ amd64 ] < none -> 1 > ( unknown )
Broken builddeps:kio-extras:amd64 Depends on libssh-dev [ amd64 ] < none -> 0.6.3-4.3 > ( libdevel ) (>= 0.6.0)
  Considering libssh-dev:amd64 0 as a solution to builddeps:kio-extras:amd64 9998
  Re-Instated libssh-dev:amd64
Investigating (2) libssh-dev [ amd64 ] < none -> 0.6.3-4.3 > ( libdevel )
Broken libssh-dev:amd64 Conflicts on libssh-gcrypt-dev [ amd64 ] < none -> 0.6.3-4.3 > ( libdevel )
  Considering libssh-gcrypt-dev:amd64 0 as a solution to libssh-dev:amd64 0
  Holding Back libssh-dev:amd64 rather than change libssh-gcrypt-dev:amd64
Investigating (3) builddeps:kio-extras [ amd64 ] < none -> 1 > ( unknown )
Broken builddeps:kio-extras:amd64 Depends on libssh-dev [ amd64 ] < none -> 0.6.3-4.3 > ( libdevel ) (>= 0.6.0)
  Considering libssh-dev:amd64 0 as a solution to builddeps:kio-extras:amd64 9998
Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 builddeps:kio-extras : Depends: libssh-dev (>= 0.6.0) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
Any help would be greatly appreciated. Thank you! :D

Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], freddylegen, Google [Bot], gregorib, irvingarrietavazquez, luther, nrykhe, paleo, rblackwell, Sogou [Bot], thunder422