Reply to topic

When use the Fcitx, it can not be entered in the qt5 apps

User avatar balloon
Registered Member
Posts
9
Karma
0
OS
Fcitx is the input method the asia users is mainly used. (In particular, Chinese, Korean and Japanese)
If you are a know the name, such as IBus and uim, Ubuntu package it was replaced by the Fcitx recently.

https://fcitx-im.org/
https://github.com/fcitx/

When using a Fcitx in KDE neon, a problem with the application of fcitx-frontend-qt5 package will occur.
Accordingly, in the qt5 applications it can not be done the input using the Fcitx.

Installation with apt, this state is entered:

Code: Select all
[email protected]:~$ LANG=C sudo apt install fcitx-frontend-qt5
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Starting pkgProblemResolver with broken count: 1
Starting 2 pkgProblemResolver with broken count: 1
Investigating (0) fcitx-frontend-qt5 [ amd64 ] < none -> 1.0.5-1 > ( libs )
Broken fcitx-frontend-qt5:amd64 Depends on qtbase-abi-5-5-1 [ amd64 ] < none > ( none )
  Considering libqt5core5a:amd64 2528 as a solution to fcitx-frontend-qt5:amd64 10005
  Considering libqt5core5a:amd64 2528 as a solution to fcitx-frontend-qt5:amd64 10005
Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 fcitx-frontend-qt5 : Depends: qtbase-abi-5-5-1
E: Unable to correct problems, you have held broken packages.
[email protected]:~$

I was reported to the Fcitx earlier, but seem unwilling to perform the correspondence by Fcitx.
So I went post to here:

https://github.com/fcitx/fcitx-qt5/issues/17

It is inconvenient in this state in the Asian users to use the KDE neon.
For the development of KDE, Plasma and neon...


BALLOON a.k.a. Fu-sen. in Japan (ふうせん Fu-sen.)
neon をつかおう | KDE neon Japanese Information https://kde-neon.jimdo.com/
User avatar apachelogger
KDE Developer
Posts
512
Karma
5
OS
Unfortunately, none of the devs uses fcitx which prevents us from supporting it. If you would like to help maintain a fcitx input support hop on IRC to join the dev chat in #kde-neon we'd be thrilled to have a better CJK experience.


Annoyed with bbcode since 1999.
User avatar balloon
Registered Member
Posts
9
Karma
0
OS
I apologize for appending to the old posts. sorry...

I noticed that Kubuntu term solved this problem with Kubuntu backports:
https://launchpad.net/~kubuntu-ppa/+arc ... ter=xenial

This seems to work for KDE neon as well.

Note: Plasma has changed to 5.9, Qt has been updated to 5.7. At the timing of posting this package is for Qt 5.6.


BALLOON a.k.a. Fu-sen. in Japan (ふうせん Fu-sen.)
neon をつかおう | KDE neon Japanese Information https://kde-neon.jimdo.com/
User avatar balloon
Registered Member
Posts
9
Karma
0
OS
I confirmed the provision of the fcitx-qt5 package from Twitter:
https://twitter.com/KdeNeon/statuses/829114225310236672

I updated the package with User Edition and successfully typed in Fcitx:
Image

Thanks for the correspondence! :)


BALLOON a.k.a. Fu-sen. in Japan (ふうせん Fu-sen.)
neon をつかおう | KDE neon Japanese Information https://kde-neon.jimdo.com/

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], dwlamb, Google [Bot], Sardus-X, semper, Sogou [Bot]

cron