Reply to topic

[Solved] 5.8.1 Cannot Start Display

User avatar Cobber
Registered Member
Posts
53
Karma
0
OS

[Solved] 5.8.1 Cannot Start Display

Wed Oct 12, 2016 4:04 pm
The upgrades that came with 5.8.1 have broken my display.

I can login, and get the logo and spinner, but then the screen goes black. Login sound is working. Right-clicking on the desktop has no effect, but Ctl+Alt+Del brings up the shutdown options. Ctl+Alt+F2 enables me to re-enter my login details, but gives me a message about being unable to start the display.

What do I do now?

Last edited by Cobber on Thu Oct 20, 2016 5:25 am, edited 1 time in total.


The Town Site Buy your own town and promote it however you want.
bshah
Registered Member
Posts
76
Karma
0
OS

Re: 5.8.1 Cannot Start Display

Wed Oct 12, 2016 4:14 pm
Can you start konsole from KRunner? Press alt+space -> type konsole and launch it? If you can launch konsole, can you run plasmashell from it?
User avatar Cobber
Registered Member
Posts
53
Karma
0
OS

Re: 5.8.1 Cannot Start Display

Wed Oct 12, 2016 4:33 pm
No I cannot access KRunner.

I am running a triple boot system, defaulting to Mint with options for Neon and Windows. When I update Grub from Mint, it doesn't pick up that Neon is now 5.8.1

I did a Neon recovery boot and updated Grub, but that didn't help. Neither did starting with the older kernel.

It is 1am here, so I won't be online for at least 12 hours. I would appreciate any other advice in the meantime that I can try tomorrow.


The Town Site Buy your own town and promote it however you want.
User avatar claydoh
Registered Member
Posts
390
Karma
5
OS

Re: 5.8.1 Cannot Start Display

Wed Oct 12, 2016 5:59 pm
Same here after updates this morning, a mixture of Neon updates and Ubuntu systemd updates

I don't get a login screen but a blank screen, but I can enter my password, and I can hear the login sounds. I can't bring up krunner or any application (or rather I am unable to see them)

I can get to a vt easily enough but startx or stopping/restarting sddm does nothing.

browsing through my xorg.0.log I see this:

Code: Select all
BUG triggered: 'if axnum >= dev->valuator->numAxes)'


followed by another BUG line then a few of a backtrace


The above looks to be unrelated to this as it relates to mice/input devices


Switching from my laptop's Nvidia gpu to intel fixes this for me


claydoh, proud to be a member of KDE forums since 2008-Oct, and KDE user since 2001
User avatar kinoe
Registered Member
Posts
70
Karma
0
OS

Re: 5.8.1 Cannot Start Display

Wed Oct 12, 2016 8:58 pm
Same with me: I can use the mouse-cursor on a blank display but I can open a terminal and Dolphin through an xfce-panel.
This is the result of running plasmashell:
Code: Select all
$ plasmashell
QFont::setPointSizeF: Point size <= 0 (0.000000), must be greater than 0
No metadata file in the package, expected it at: "/usr/share/wallpapers/Next/contents/images/"
No metadata file in the package, expected it at: "/usr/share/wallpapers/Next/contents/images/"
No metadata file in the package, expected it at: "/usr/share/wallpapers/Next/contents/images/"
QPainter::begin: Paint device returned engine == 0, type: 2
QPainter::save: Painter not active
QPainter::translate: Painter not active
QPainter::scale: Painter not active
QPainter::worldTransform: Painter not active
QPainter::setPen: Painter not active
QPainter::setBrush: Painter not active
QPainter::setRenderHint: Painter must be active to set rendering hints
QPainter::setRenderHint: Painter must be active to set rendering hints
QPainter::worldTransform: Painter not active
QPainter::setWorldTransform: Painter not active
QPainter::worldTransform: Painter not active
QPainter::setWorldTransform: Painter not active
QPainter::brush: Painter not active
..........
.........
QPainter::setWorldTransform: Painter not active
QPainter::setWorldTransform: Painter not active
QPainter::setOpacity: Painter not active
QPainter::setWorldTransform: Painter not active
QPainter::restore: Unbalanced save/restore
QPainter::end: Painter not active, aborted
file:///usr/share/plasma/shells/org.kde.plasma.desktop/contents/views/Panel.qml:83: TypeError: Cannot read property 'Layout' of null
Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
file:///usr/lib/x86_64-linux-gnu/qt5/qml/QtQuick/Controls/Button.qml:100: TypeError: Cannot read property of null
file:///usr/lib/x86_64-linux-gnu/qt5/qml/QtQuick/Controls/Button.qml:100: TypeError: Cannot read property of null
file:///usr/lib/x86_64-linux-gnu/qt5/qml/QtQuick/Controls/Button.qml:100: TypeError: Cannot read property of null
file:///usr/lib/x86_64-linux-gnu/qt5/qml/QtQuick/Controls/Button.qml:100: TypeError: Cannot read property of null
KCrash: Attempting to start /usr/bin/plasmashell from kdeinit
sock_file=/run/user/1000/kdeinit5__0
KCrash: crashing... crashRecursionCounter = 2
KCrash: Application Name = plasmashell path = /usr/bin pid = 17437
KCrash: Arguments: /usr/bin/plasmashell
KCrash: Attempting to start /usr/lib/x86_64-linux-gnu/libexec/drkonqi from kdeinit
sock_file=/run/user/1000/kdeinit5__0
QSocketNotifier: Invalid socket 8 and type 'Read', disabling...
QSocketNotifier: Invalid socket 18 and type 'Read', disabling...
QSocketNotifier: Invalid socket 9 and type 'Read', disabling...

[1]+  stopped              plasmashell


While that command and output is running, Plasma apparently starts for a second before it dies again.
I would aknowlegde any help.


Reality is frequently inaccurate.
Image
User avatar Cobber
Registered Member
Posts
53
Karma
0
OS

Re: 5.8.1 Cannot Start Display

Thu Oct 13, 2016 4:06 am
The problem appears to be related to Activities.

I restored an image of 5.8.0 and set everything to Breeze defaults. I also deleted all my activities. I then did the updates again.

Then I logged out (not reboot) and everything was fine. I rebooted and all was good. Changed my workspace settings to use Oxygen and rebooted. Still good.

I then created a new activity, only giving it a name - not any function. Logged out and got the black screen problem back again. Rebooted and still have the problem.

So it would appear there is a bug with "Activities" in the updates. This is my first experience with a rolling distro, and the sort of thing I was afraid might happen.


The Town Site Buy your own town and promote it however you want.
ndavis
Registered Member
Posts
5
Karma
0
OS

Re: 5.8.1 Cannot Start Display

Thu Oct 13, 2016 4:39 am
I had the same problem, but I fixed it by uninstalling my proprietary nvidia drivers and installing the nouveau-firmware package.
User avatar Cobber
Registered Member
Posts
53
Karma
0
OS

Re: 5.8.1 Cannot Start Display

Thu Oct 13, 2016 5:38 am
ndavis wrote:I had the same problem, but I fixed it by uninstalling my proprietary nvidia drivers and installing the nouveau-firmware package.


Don't know if this applies to my system. Output of inxi -G:

Code: Select all
Graphics:  Card: Intel Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller bus-ID: 00:02.0
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1920x1080@60.00hz
           GLX Renderer: Mesa DRI Intel Ivybridge Desktop
           GLX Version: 3.0 Mesa 11.2.0 Direct Rendering: Yes


I don't have any section in system settings for "Additional Drivers".

Last edited by Cobber on Thu Oct 13, 2016 8:02 am, edited 1 time in total.


The Town Site Buy your own town and promote it however you want.
User avatar Cobber
Registered Member
Posts
53
Karma
0
OS

Re: 5.8.1 Cannot Start Display

Thu Oct 13, 2016 7:43 am
Just did the updates on my HP laptop which has dual AMD/ATI graphics.

Same problem. Had to delete all my Activities before updating.


The Town Site Buy your own town and promote it however you want.
User avatar kinoe
Registered Member
Posts
70
Karma
0
OS

Re: 5.8.1 Cannot Start Display

Thu Oct 13, 2016 8:01 am
Same problem. Had to delete all my Activities before updating.

if that solved your problem, could you go into detail what exactly you did?


Reality is frequently inaccurate.
Image
User avatar Cobber
Registered Member
Posts
53
Karma
0
OS

Re: 5.8.1 Cannot Start Display

Thu Oct 13, 2016 8:14 am
kinoe wrote:
if that solved your problem, could you go into detail what exactly you did?


Sure. Just go into System Settings>Desktop Behavior>Activities and delete all the activities you have created there. Rename the only one left to - Default.

Ensure your desktop layout is set to - Desktop and not - Folder View, by right-clicking on your desktop and click on - Configure Desktop.

You need to reboot your system to ensure no activities exist anymore.

You can then apply the updates and everything should work fine.


The Town Site Buy your own town and promote it however you want.
User avatar Cobber
Registered Member
Posts
53
Karma
0
OS

Re: 5.8.1 Cannot Start Display

Thu Oct 13, 2016 8:52 am
Have raised a bug report at https://bugs.kde.org/show_bug.cgi?id=370630


The Town Site Buy your own town and promote it however you want.
User avatar kinoe
Registered Member
Posts
70
Karma
0
OS

Re: 5.8.1 Cannot Start Display

Thu Oct 13, 2016 9:11 am
Ok but this way is effective only before the update? What about when the update has already run?
Did you rollback the update to 5.8.0? How?


Reality is frequently inaccurate.
Image
User avatar Cobber
Registered Member
Posts
53
Karma
0
OS

Re: 5.8.1 Cannot Start Display

Thu Oct 13, 2016 9:18 am
kinoe wrote:Did you rollback the update to 5.8.0? How?


Ah. Years of experience! Always create regular system images so you can restore to an earlier, working copy if necessary.

You an use Redo Backup to create these images in Linux.


The Town Site Buy your own town and promote it however you want.
User avatar kinoe
Registered Member
Posts
70
Karma
0
OS

Re: 5.8.1 Cannot Start Display

Thu Oct 13, 2016 9:37 am
Well I'll do it with snapper/ btrfs.
Thx for help.


Reality is frequently inaccurate.
Image

 
Reply to topic

Bookmarks



Who is online

Registered users: 4m, abury, Arkengheist, Baidu [Spider], Bing [Bot], bluesky, boudewijn, DaniilDragon, Deevad, Exabot [Bot], farid, Google [Bot], jamesdavis, KAMiKAZOW, Lembritt, m4TZ, Merlimau, mohammedhn, mszorady, stanleyf, Underrr, Yahoo [Bot]