Reply to topic

[Solved] 5.8.1 Cannot Start Display

User avatar Cobber
Registered Member
Posts
53
Karma
0
OS

Re: 5.8.1 Cannot Start Display

Wed Oct 19, 2016 2:54 pm
aironeousb wrote:I have this problem also. In my attempt to fix it after trying all regular things I took a shot in the dark and installed 4.9rc1


Seeing as no one has answered your post, here are my thoughts.

I would re-install Neon, making sure you format your partitions in the process. Do not try using kernels not available by default. If you have problems with your graphics, purge Nvidia and use the default video driver.

I also suggest you get in the habit of making backup system images on a portable HDD using something like Redo Backup. That way, you can quickly put your installation back the way it was before it broke.

The problem with the Activity Pager widget is being fixed in 5.8.2 as it was tracked down by the developer to a Qt conflict. If you still have problems, start a new thread so people can help you.


The Town Site Buy your own town and promote it however you want.
aironeousb
Registered Member
Posts
13
Karma
0

Re: 5.8.1 Cannot Start Display

Wed Oct 19, 2016 8:26 pm
Reinstalling will cause me to lose lots of games which took a long time to download. I would much rather get around this lock, purge nvidia and go install any missing firmware but I need help.
aironeousb
Registered Member
Posts
13
Karma
0

Re: 5.8.1 Cannot Start Display

Thu Oct 20, 2016 2:49 am
Did anyone's black screen get fixed with this latest update 5.8.2?
aironeousb
Registered Member
Posts
13
Karma
0

Re: 5.8.1 Cannot Start Display

Thu Oct 20, 2016 4:23 am
It looks like I was also experiencing this bug. https://bugs.kde.org/show_bug.cgi?id=360700
User avatar Cobber
Registered Member
Posts
53
Karma
0
OS

Re: 5.8.1 Cannot Start Display

Thu Oct 20, 2016 5:24 am
aironeousb wrote:Did anyone's black screen get fixed with this latest update 5.8.2?


Yes, the Activity Pager widget now works in 5.8.2, and the black screen with pointer does not occur.

Your need to fix your broken installation is a separate issue that will not get the attention it should by using this thread. Again, I suggest you start a new one of your own so there is no confusion as to what you require fixed.


The Town Site Buy your own town and promote it however you want.
aironeousb
Registered Member
Posts
13
Karma
0
I'm not talking to you, I'm asking everyone else. I appreciate your efforts. There are several bugs that got fixed that were related to what I was experiencing. I want to find out from everyone else their answer, not your answer.
aironeousb
Registered Member
Posts
13
Karma
0
I think I got it fixed. I followed the commands at the bottom of this.
http://askubuntu.com/questions/469553/h ... it-version
except for the first file i had the rest of them and those commands worked to remove the lock. I was able to do an update and I'm doing a dist upgrade now.
We'll see if I am able to see my laptop screen and boot in now.

Nope it got stuck at trying to install laptop-mode-tools again. How do I keep that thing from trying to install?
Edit : I was able to uninstall it and laptop-detect and what came with it and now I am stuck at the same error when it tries doing the upgrade right after it says setting up sddm
invoke-rc.d: could not determine current runlevel
aironeousb
Registered Member
Posts
13
Karma
0
I got all of my problems fixed and now I am back to the bug that is the topic of this thread. Black screen after logging in.
5.8.2 did not fix this bug for me. I have 2 laptops, this one that works and is older and has integrated graphics and the other one with an nvidia 960m in it,
with both running the same kernel, same KDE Neon, same update one has the problem one doesn't.
The one with the nvidia card has the problem. After the update I get 1 to 3 boots with the desktop there and then it disappears. Black screen after login.
darinmiller
Registered Member
Posts
10
Karma
0
I also had the black screen issue with Neon user and Neon dev unstable distros dual booting on a Dell Inspiron 7559 w/ Nvidia 960 card. I was able to fix the Neon unstable session by uninstalling the Nvidia drivers, running updates, then re-installing the Nvidia driver (370.28). The Neon user session was fixed just by running updates a couple weeks after SDDM 1.4 was available.

NVidia drive seems to have a bug and occasionally the GPU will "fall of the bus" on wake. This issue has been noted on the NVidia forums. The only remedy is a hard power down. The other issue that I suspect is kernel or GPU related is removing the laptop power causes a complete lockups after about 1-2 minutes. I strongly suspect a skylake issue, but I do not know for sure.
aironeousb
Registered Member
Posts
13
Karma
0
Thank you Darin. How do I uninstall Nvidia? sudo apt uninstall Nvidia-370? Do I have to do nvidia- settings also? If I uninstall this can I be certain that nouveau will kick in? Is there a way to make sure it is installed and will kick in? I have the newest firmware from Intel website related to Skylake but not the kabylake or the other one which it does give me the warnings for but I do not have those I have a Skylake.
aironeousb
Registered Member
Posts
13
Karma
0
So I purged nvidia and autoremoved then I did an update and then tried to boot and it would not login into any kernel I tried. As soon as I put the password in it would freeze.
So I went into recovery on 4.4.045 kernel tried regenerating grub and fix broken packages. That got me a little farther, now it would get passed the login screen to the spinner but would freeze at that point no matter what kernel I tried.
So then I reinstalled nvidia 370 and now I am back to the same point I was at when I started down this whole road trying to fix the problem that I can only see my laptop screen if I am connected to an external monitor.
But hey, at least I can use my laptop again. Now I at least have a desktop. I can probably play some steam games now.

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], gfielding, Google [Bot], hiteshshah, lucianosalomoni, Majestic-12 [Bot], nharvey, pseco, TheBeheader, Yahoo [Bot]