Reply to topic

Installing QtCreator (unmet dependencies)

FLK
Registered Member
Posts
2
Karma
0
Hi there :) !

I'm trying to get into Linux/KDE development (interested by Plasma Mobile), so for now I'm just trying to setup the dev environment.

I'm using KDE Neon devstable (also tested on the User edition) with Plasma 5.8.2 / KF 5.28.0 / Qt 5.7.

Code: Select all
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Starting pkgProblemResolver with broken count: 1
Starting 2 pkgProblemResolver with broken count: 1
Investigating (0) qtcreator [ amd64 ] < none -> 3.5.1+dfsg-2ubuntu2 > ( universe/devel )
Broken qtcreator:amd64 Depends on qtbase-abi-5-5-1 [ amd64 ] < none > ( none )
  Considering libqt5core5a:amd64 2804 as a solution to qtcreator:amd64 9999
  Considering libqt5core5a:amd64 2804 as a solution to qtcreator:amd64 9999
Broken qtcreator:amd64 Depends on qtdeclarative-abi-5-5-0 [ amd64 ] < none > ( none )
  Considering libqt5qml5:amd64 338 as a solution to qtcreator:amd64 9999
Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 qtcreator : Depends: qtbase-abi-5-5-1
             Depends: qtdeclarative-abi-5-5-0
             Recommends: qmlscene
             Recommends: qtdeclarative5-dev-tools
             Recommends: qtxmlpatterns5-dev-tools
E: Unable to correct problems, you have held broken packages


`dpkg --get-selections | grep hold` returns no results.

If I try to manually install qtbase

Code: Select all
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package qtbase-abi-5-5-1 is a virtual package provided by:                                                                                           
  libqt5core5a 5.5.1+dfsg-16ubuntu7.1 [Not candidate version]                                                                                         
  libqt5core5a 5.5.1+dfsg-16ubuntu7 [Not candidate version]                                                                                           
                                                                                                                                                     
E: Package 'qtbase-abi-5-5-1' has no installation candidate 


Am I missing the obvious ?

Thanks!
levmyskin
Registered Member
Posts
1
Karma
1
Hi, browsing around some forums I saw lots of people reporting this problem. I think the easiest solution is to simply download the .run file on Qt website (https://www.qt.io/download/) and then run it: install Qt creator ( under tools section i think) only since you don't need qt libraries ( kde neon already has 5.7 installed) and it works like a charm ( or at least it did on my machine).
FLK
Registered Member
Posts
2
Karma
0
Yes, this is what I ended up doing, and it's working!

Would love to understand the issue but well at least I can start learning all those new stuff :D

Thanks.
User avatar benrob0329
Registered Member
Posts
2
Karma
0
OS
This is still a problem.
sstaeglich
Registered Member
Posts
36
Karma
0
Yes, it would be very nice if that could be solved. Installing QtCreator via *.run file is a workaround and no solution! This problem affects other Qt software as well.
User avatar subdiff
Registered Member
Posts
59
Karma
0
OS
The problem is, that we use more recent Qt version than the Ubuntu base. Qt Creator from the Ubuntu archives was compiled targeting the older version. Now you say "Well, why not use the most recent Qt Creator version aswell in the Neon depos." and I don't know the answer to it. I assume if it could be done easily, it would've been done since, although Qt Creator is not a KDE app (and Neon primarily only updates these to more recent versions than in Ubuntu base), it's still very related.
sstaeglich
Registered Member
Posts
36
Karma
0
I think for QtCreator would be the best solution providing the actual version as part of KDE neon.

For all other Qt software would maybe already help to provide an virtual Qt 5.5 package if the ABI is compatible.
tuxflo
Registered Member
Posts
1
Karma
0
Almost may and this is still an issue. Any ideas how to fix? Is there an PPA for qtcreator that provides the "correct" version for Neon?
sstaeglich
Registered Member
Posts
36
Karma
0
Hello,

you could use the packages of Ubuntu 17.04.

Stefan
sstaeglich
Registered Member
Posts
36
Karma
0
Many thanks for the new packages :)

 
Reply to topic

Bookmarks



Who is online

Registered users: ajmoss, Baidu [Spider], Bing [Bot], claydoh, Exabot [Bot], Google [Bot], Saru, Snudl, Sogou [Bot], spierrel, Yahoo [Bot]