Reply to topic

Titlebars/frames gone, taskbar non functional and more.

kaese_nachos
Registered Member
Posts
2
Karma
0
Hello,

one of the latest updates (from last weekend) has broken my system a little bit. Titlebars/frames are completly gone, the taskbar seems to be non functional too (it is always empty) and switching the focus of windows is almost impossible either.
I am using the stable dev version of Neon, with the latest updates.

Plasma Version: 5.8.95
KDE Framework: 5.31.0
QT Version: 5.7.0

What I have done so far:
Updated the nvidia drivers from 370~ to the current 378.09 from the repository.
Created a new user.

That did not help.

I also looked at some logs, without knowing what to search for.
I picked up these lines from the xsession-errors log:
The X11 connection broke (error 1). Did the X11 server die?
No DBUS session-bus found. Check if you have started the DBUS server.
The X11 connection broke: I/O error (code 1)
XIO: fatal IO error 6 (Kein passendes Gerät bzw. keine passende Adresse gefunden) on X server ":0"
after 208 requests (208 known processed) with 0 events remaining.
kdeinit5: Communication error with launcher. Exiting!


The log contained this more than once and this might be the only relevant part I was able to find. But I do not know what I am after anyway.

How shall I proceed with this problem? Should I need to provide more info, I will do that of course :)

Thanks in advance.
kaese_nachos
Registered Member
Posts
2
Karma
0
I figured what was wrong and fixed it, yeah :)

So I noticed that kwin just was not running. Trying to start it manually gave me an error, a package was missing. I just needed to install "libxkbcommon0" with apt-get and my system is fine again.

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], freddylegen, Google [Bot], grahm, irvingarrietavazquez, Majestic-12 [Bot], nrykhe, paleo, rblackwell, Sogou [Bot]