Reply to topic

Boot stuck on loading logo after installing AppArmor

LuckyScooby
Registered Member
Posts
2
Karma
0
Hello guys!
I loved the KDE Neon distro, it is exactly what I was looking for: KDE, no bloats, latest Plasma updates, clean and lightweight. Great work, I'm not replacing that for anything.

Well, I was looking for some security and found SELinux. Installed it (reboot was normal) and then after researching I found out Ubuntu provides and recommends AppArmor.
I removed SELinux and right after installed AppArmor. When I rebooted, Neon got stuck in its loading logo (right after GRUB), it loads like forever.

I tried some options in the recovery mode, but with no success. The only way I can boot is by selecting the recovery mode on GRUB and then "Resume", however window animations are clearly laggy (some are not even working) and by looking at system monitor, systemd and kdeinit5 are abnormally consuming CPU (around 15 - 30% each, constantly).

I've tried removing and purging selinux and apparmor, and even reinstalling it, but the issue persists.
Boot Repair also could not fix it.

I've tried
sudo apt install -f

and
sudo dpkg-reconfigure -a

This last one strangely returns Unknown option: a.
Update:
Reading Ubuntu Manpages, I realized the -a option in dpkg-reconfigure was dropped since 15.10.

http://manpages.ubuntu.com/manpages/xen ... ure.8.html

Please, I have no idea on how to fix this; I really wish not to reinstall everything. =[
Thanks in advance!

Reply to topic

Bookmarks



Who is online

Registered users: Awang Ruoto, Baidu [Spider], bgroper, Bing [Bot], cylverbak, Don B. Cilly, funkyskywalker, gfielding, Google [Bot], ineuw, ipwizard, Majestic-12 [Bot], mawoka, maxmu, peje, Sogou [Bot], sylvainrousseau, YaCy [Bot], Yahoo [Bot]