Reply to topic

Proper way to disable automatic package update checks?

vishalrao
Registered Member
Posts
156
Karma
0
OS
Hello,

What's the proper and complete way to disable KDE Neon (I'm using dev unstable edition if that makes a difference) from automatically checking for updates and displaying the "updates" icon in system tray?

Note I don't just want to hide the icon, I want to prevent the automatic checking for updates itself - mainly to preserve internet bandwidth usage.

I've already changed the /etc/apt/apt.conf.d/10periodic settings from 1 to 0 and also tried searching online for packagekit/pkcon info but could only find the suggestion to do "systemctl disable packagekit" but then it seems to re-enable (I guess needed for systemd to satisfy some dependencies)... there is also the "mask" command but that is apparently powerful/risky.

So, again, what's the proper way to disable automatic updates checking?

Thanks!


"Thou shalt not follow the null pointer for at its end madness and chaos lie."
vishalrao
Registered Member
Posts
156
Karma
0
OS
Well, uninstalling plasma-discover packages seems to have also removed packagekit and hence no auto update checks anymore. But would have preferred to keep discover/packagekit but locate where/how to configure it to stop checking for updates.


"Thou shalt not follow the null pointer for at its end madness and chaos lie."
User avatar codywohlers
Registered Member
Posts
4
Karma
0
OS
Any solution? My PackageKit keeps running at 7am despite all cron entries being changed. **** systemd
gfielding
Registered Member
Posts
149
Karma
0
OS
You just need to take the tick out of the box. If you right-click on the triangle box on the bottom right of the screen (by the clock) there will be a menu with a series of functions bluetooth etc. Just take the tick out of the 'check for updates' tab.

This will disable the automatic check but discover will still work in the normal way - so you can check for updates whenever you want to.
User avatar codywohlers
Registered Member
Posts
4
Karma
0
OS
you mean right-click -> system tray settings -> entries ? Then change the visibility of Updates? This just controls the visibility. It still runs packagekitd.

And if I right click on the "updates" in the system tray my 2 options are "see updates" and "update settings", neither of which have any options to disable automatic updates.

The reason I'm writing this at 3am is because my laptop fan went full speed because of packagekitd that i disabled in software-properties. It needs to die NOW.
User avatar codywohlers
Registered Member
Posts
4
Karma
0
OS
I tried `systemctl disable packagekitd` but it still tries to run so I had to do `chmod a-x /usr/lib/packagekit/packagekitd` as a workaround but i'm sure a future update will undo that.
User avatar abury
Registered Member
Posts
190
Karma
1
OS
Because I have Muon installed, it was easy to configure...
Software Sources > Updates > and deselect "Check for updates"
Done!


KDE neon 5.20 - Plasma 5.20.5 - Frameworks 5.78 - Qt 5.15.2 - Kernel 5.4.0-65

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], Google [Bot], Graham Perrin, grumpfel, halla, howtokdenlive, jaydentheveryadvancedlinuxuseronthekdeforums, PhobosK, radoeka, Yahoo [Bot], znull