Reply to topic

Keyboard localisation on login screen (SDDM)

frantek
Registered Member
Posts
16
Karma
0
OS
Hi,

I've tried Kubuntu, Linux Mint KDE and now KDE Neon. The only distribution which handles keyboard localization correctly is Kubuntu. Linux Mint KDE and KDE Neon fails in using the correctly localized keyboard mapping in SDDM. What do I have to do to get a correctly localized keyboard in SDDM?

TIA
User avatar Rog131
Registered Member
Posts
828
Karma
10
At here, with the Arch Linux & X, SDDM is following the /usr/share/sddm/scripts/Xsetup.

Adding to /usr/share/sddm/scripts/Xsetup:

Code: Select all
#!/bin/sh
# Xsetup - run as root before the login dialog appears
setxkbmap "fi,us"


So now the SDDM Breeze (5.9) theme is showing the options at the lower left corner:

Image



More of sddm and keyboard layout

Bug 343427 - kcm_sddm : Allow keyboard layout selection: https://bugs.kde.org/show_bug.cgi?id=343427
[SOLVED] SDDM Keyboard Slelection: https://bbs.archlinux.org/viewtopic.php?id=194408
KDA
Registered Member
Posts
2
Karma
0
OS
Just dropping by from the future to update the solution. For Wayland and X11 under SDDM (and GDM), run the following:
Code: Select all
sudo localectl set-x11-keymap fi,us

(Where “fi” and “us” refers to Finish and U.S. keyboard layouts.) You can specify a single keyboard layout or a comma-separated list. —and yes, the X11 keyboard configuration is used in Wayland too.

 
Reply to topic

Bookmarks



Who is online

Registered users: Bing [Bot], blue_bullet, eight-bit, Google [Bot], mixtou, sirjitsu, Yahoo [Bot]