Reply to topic

What is the best way to install KDE Neon plasma 5.9

rgoss
Registered Member
Posts
12
Karma
0
Hello everyone, this is my first posting here so I hope this is in the right section. I am trying to install KDE Neon 5.9 on my Dell optiplex but it's asking me for a user and password the screen is black with the text in the left corner of the screen asking for user name and passs. I have no clue what the user and password is and cannot get pass this login screen

I cannot not get to the live desktop env any help would be greatly appreciated

Last edited by rgoss on Mon Feb 06, 2017 11:56 am, edited 1 time in total.
thurstan
Registered Member
Posts
3
Karma
0

.

Mon Feb 06, 2017 7:44 am
.

Last edited by thurstan on Mon May 01, 2017 7:54 am, edited 1 time in total.
rgoss
Registered Member
Posts
12
Karma
0
I don't believe it's suppose to ask for a password in the live desktop ENV so I'm not sure why it's asking for a password and will not load the Live desktop
rgoss
Registered Member
Posts
12
Karma
0
BUMP anyone have a clue to this issue?
User avatar claydoh
Registered Member
Posts
629
Karma
5
OS
Have you tried re-creating the install disk, or checking/re-downloading the iso image? There is not supposed to be a login for this. You can try using "neon" as the username with no password.

This could be a sign of a corrupted download or a bad "burn", what you are seeing is a terminal login, which means that the gui desktop components are not automatically loading for some reason.


claydoh, proud to be a member of KDE forums since 2008-Oct, and KDE user since 2001
rgoss
Registered Member
Posts
12
Karma
0
claydoh wrote:Have you tried re-creating the install disk, or checking/re-downloading the iso image? There is not supposed to be a login for this. You can try using "neon" as the username with no password.

This could be a sign of a corrupted download or a bad "burn", what you are seeing is a terminal login, which means that the gui desktop components are not automatically loading for some reason.



Thanks so much for your reply

I'm seeing a black screen as I try to boot into the live desktop

It's asking for a user name and password, in a text format. When I tried entering neon as the user it droped down and ask for a password. I tried leaving it blank and using neon also for the password didn't work

This happens only on two of my machines and there are both Dell 755 Optiplex, If I try loading that same USB with Neon on another brand other then Optiplex I can boot to the live desktop

This is what I'm seeing

Neon_ tt1y
Neon_login

I do get this same black screen when I try loading Kubuntu on the same machine but only for a second and then the live desktop will load
vishalrao
Registered Member
Posts
154
Karma
0
OS
Which flavour of ISO are you trying? Did you try pressing "ALT+F7" to try and switch to the GUI when you get the login prompt?

Alternatively, try booting with the "nomodeset" linux kernel option, search online for how to add that option during boot.


"Thou shalt not follow the null pointer for at its end madness and chaos lie."
rgoss
Registered Member
Posts
12
Karma
0
I'm trying Neon.5.9, how would I get the nomodeset option?

Thanks so much

Last edited by rgoss on Sun Feb 12, 2017 11:19 am, edited 1 time in total.
vishalrao
Registered Member
Posts
154
Karma
0
OS
You can search online for ubuntu method of adding the nomodeset option, but I'll try to explain off the top of my head:

1. While booting off USB initially, keep pressing ESC and/or SHIFT till you see the GRUB boot menu with listed options to boot.
2. Press "e" when the default item is selected to get the editor where you can see some boot options code.
3. Move cursor to the linux line where you see "quiet splash" and remove those two words and replace with "nomodeset" with space around it.
4. Press CTRL+X to boot.


"Thou shalt not follow the null pointer for at its end madness and chaos lie."
rgoss
Registered Member
Posts
12
Karma
0
Sounds good I'll give it a try

Thanks so much
User avatar kc1di
Registered Member
Posts
6
Karma
0
OS
It would also be helpful to know a little about your machine,
esp. your graphics card model.

If it's nvidia the nomodset should get you in.
if it does not let us know.
rgoss
Registered Member
Posts
12
Karma
0
I was able to boot in to the live desktop using the ESC and Shift key, but after launching the desktop I was wondering is there and way for me to install preparatory drivers for this OS

Thanks so much
vishalrao
Registered Member
Posts
154
Karma
0
OS
No just install it if you got to the live desktop, it should keep the "nomodeset" option in your installed OS, if not, you can add it again. Then after you boot into your installed OS then go ahead installing drivers for your video card.


"Thou shalt not follow the null pointer for at its end madness and chaos lie."
rgoss
Registered Member
Posts
12
Karma
0
vishalrao wrote:No just install it if you got to the live desktop, it should keep the "nomodeset" option in your installed OS, if not, you can add it again. Then after you boot into your installed OS then go ahead installing drivers for your video card.


I don't see the driver option in the settings
User avatar kc1di
Registered Member
Posts
6
Karma
0
OS
rgoss wrote:I was able to boot in to the live desktop using the ESC and Shift key, but after launching the desktop I was wondering is there and way for me to install preparatory drivers for this OS

Thanks so much

There are a couple ways
if your card is nvidia It's drivers are in the repositories up to version 367
you may also be able to use the Ubuntu PPA - as neon is based on Ubuntu base.
Or you can download the needed driver and install it manually.

You never said which video card you have so can't say for sure what you need to do.

 
Reply to topic

Bookmarks



Who is online

Registered users: alra, Baidu [Spider], Bing [Bot], bovender, claydoh, colstar, farid, flyingbear, Google [Bot], ipwizard, lbettini, Mace68, sandro4912, Sogou [Bot], TheraHedwig, Yahoo [Bot]