Reply to topic

Can't install libkf5*-dev-pakcages

michaelkraemer
Registered Member
Posts
4
Karma
0
OS

Can't install libkf5*-dev-pakcages

Tue Feb 07, 2017 6:49 pm
Hi guys,

I got a dependency problem, and I don't know how to solve it. Following command:

Code: Select all
sudo apt-get install plasma-workspace-dev libkf5runner-dev libkf5jsembed-dev libkf5wallet-dev libkf5doctools-dev libkf5notifyconfig-dev libkf5su-dev libkf5newstuff-dev libkf5kcmutils-dev libkf5idletime-dev libkf5textwidgets-dev libkf5kdelibs4support-dev libkf5crash-dev libkf5globalaccel-dev libkf5dbusaddons-dev libkf5wayland-dev


causes some output, that those packages depend on other packages in another version. But when I try to apt-get -f install them, it won't work.
It seems, that all depends on libkf5plasma-dev, but konsole says:

Code: Select all
 libkf5plasma-dev : Hängt ab von (depends on): libkf5package-dev (>= 5.28.0~) soll aber nicht installiert werden (shall not be installed)
                    Hängt ab von: libkf5service-dev (>= 5.28.0~) soll aber nicht installiert werden
                    Hängt ab von: plasma-framework (= 5.30.0+p16.04+git20170126.1521-0) aber 5.30.0-0neon+16.04+build29 soll installiert werden


Don't know what to do...

thx for your help.
michaelkraemer
Registered Member
Posts
4
Karma
0
OS
I solved it by changing my sources from User-Edition to Developer-Edition.

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], boospy007, claydoh, Exabot [Bot], Google [Bot], nshiell, Sogou [Bot], TG