Reply to topic

Dependencies are not satisfied for libgles1-mesa

User avatar wferreira
Registered Member
Posts
58
Karma
0
OS
Code: Select all
~$ apt list --upgradable
Listing... Pronto
kapptemplate/xenial 4:16.12.2-0neon+16.04+build15 amd64 [upgradable from: 4:16.12.1-0neon+16.04+build13]
kapptemplate-dbgsym/xenial 4:16.12.2-0neon+16.04+build15 amd64 [upgradable from: 4:16.12.1-0neon+16.04+build13]
libgl1-mesa-dev/xenial 17.0.0~git20170212+17.0.e81e2846-0ubuntu0ricotz~xenial amd64 [upgradable from: 17.0.0~git20170206+17.0.07571cd8-0ubuntu0ricotz~xenial]
libgl1-mesa-glx/xenial 17.0.0~git20170212+17.0.e81e2846-0ubuntu0ricotz~xenial amd64 [upgradable from: 17.0.0~git20170206+17.0.07571cd8-0ubuntu0ricotz~xenial]
libglapi-mesa/xenial 17.0.0~git20170212+17.0.e81e2846-0ubuntu0ricotz~xenial amd64 [upgradable from: 17.0.0~git20170206+17.0.07571cd8-0ubuntu0ricotz~xenial]
libgles2-mesa/xenial 17.0.0~git20170212+17.0.e81e2846-0ubuntu0ricotz~xenial amd64 [upgradable from: 17.0.0~git20170206+17.0.07571cd8-0ubuntu0ricotz~xenial]
libosmesa6/xenial 17.0.0~git20170212+17.0.e81e2846-0ubuntu0ricotz~xenial amd64 [upgradable from: 17.0.0~git20170206+17.0.07571cd8-0ubuntu0ricotz~xenial]
mesa-common-dev/xenial 17.0.0~git20170212+17.0.e81e2846-0ubuntu0ricotz~xenial amd64 [upgradable from: 17.0.0~git20170206+17.0.07571cd8-0ubuntu0ricotz~xenial]

After I run the command "upgrade"
Code: Select all
taverna@ASUS:~$ sudo apt upgrade
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
Entering ResolveByKeep... 10%[color=#FF0000]
  Dependencies are not satisfied for libgles1-mesa [ amd64 ] < 17.0.0~git20170206+17.0.07571cd8-0ubuntu0ricotz~xenial > ( libs )
Keeping package libgles1-mesa:amd64
  Dependencies are not satisfied for libgles1-mesa [ amd64 ] < 17.0.0~git20170206+17.0.07571cd8-0ubuntu0ricotz~xenial > ( libs )
Package libgles1-mesa:amd64 libgles1-mesa:amd64 Depende on libglapi-mesa [ amd64 ] < 17.0.0~git20170206+17.0.07571cd8-0ubuntu0ricotz~xenial -> 17.0.0~git20170212+17.0.e81e2846-0ubuntu0ricotz~xenial > ( libs ) (= 17.0.0~git20170206+17.0.07571cd8-0ubuntu0ricotz~xenial)
  Keeping Package libglapi-mesa:amd64 due to Depende
  Dependencies are not satisfied for libgl1-mesa-glx [ amd64 ] < 17.0.0~git20170206+17.0.07571cd8-0ubuntu0ricotz~xenial -> 17.0.0~git20170212+17.0.e81e2846-0ubuntu0ricotz~xenial > ( libs )
Keeping package libgl1-mesa-glx:amd64
  Dependencies are not satisfied for libgl1-mesa-glx [ amd64 ] < 17.0.0~git20170206+17.0.07571cd8-0ubuntu0ricotz~xenial -> 17.0.0~git20170212+17.0.e81e2846-0ubuntu0ricotz~xenial > ( libs )
Package libgl1-mesa-glx:amd64 libgl1-mesa-glx:amd64 Quebra on libgl1-mesa-glx [ i386 ] < 17.0.0~git20170206+17.0.07571cd8-0ubuntu0ricotz~xenial -> 17.0.0~git20170212+17.0.e81e2846-0ubuntu0ricotz~xenial > ( libs ) (!= 17.0.0~git20170206+17.0.07571cd8-0ubuntu0ricotz~xenial)
  Keeping Package libgl1-mesa-glx:i386 due to Quebra
  Dependencies are not satisfied for libglapi-mesa [ amd64 ] < 17.0.0~git20170206+17.0.07571cd8-0ubuntu0ricotz~xenial -> 17.0.0~git20170212+17.0.e81e2846-0ubuntu0ricotz~xenial > ( libs )
Keeping package libglapi-mesa:amd64
  Dependencies are not satisfied for libglapi-mesa [ amd64 ] < 17.0.0~git20170206+17.0.07571cd8-0ubuntu0ricotz~xenial -> 17.0.0~git20170212+17.0.e81e2846-0ubuntu0ricotz~xenial > ( libs )
Package libglapi-mesa:amd64 libglapi-mesa:amd64 Quebra on libglapi-mesa [ i386 ] < 17.0.0~git20170206+17.0.07571cd8-0ubuntu0ricotz~xenial -> 17.0.0~git20170212+17.0.e81e2846-0ubuntu0ricotz~xenial > ( libs ) (!= 17.0.0~git20170206+17.0.07571cd8-0ubuntu0ricotz~xenial)
  Keeping Package libglapi-mesa:i386 due to Quebra
  Dependencies are not satisfied for libosmesa6 [ amd64 ] < 17.0.0~git20170206+17.0.07571cd8-0ubuntu0ricotz~xenial -> 17.0.0~git20170212+17.0.e81e2846-0ubuntu0ricotz~xenial > ( libs )
Keeping package libosmesa6:amd64
  Dependencies are not satisfied for libosmesa6 [ amd64 ] < 17.0.0~git20170206+17.0.07571cd8-0ubuntu0ricotz~xenial -> 17.0.0~git20170212+17.0.e81e2846-0ubuntu0ricotz~xenial > ( libs )
Package libosmesa6:amd64 libosmesa6:amd64 Quebra on libosmesa6 [ i386 ] < 17.0.0~git20170206+17.0.07571cd8-0ubuntu0ricotz~xenial -> 17.0.0~git20170212+17.0.e81e2846-0ubuntu0ricotz~xenial > ( libs ) (!= 17.0.0~git20170206+17.0.07571cd8-0ubuntu0ricotz~xenial)
  Keeping Package libosmesa6:i386 due to Quebra
  Dependencies are not satisfied for libgles2-mesa [ amd64 ] < 17.0.0~git20170206+17.0.07571cd8-0ubuntu0ricotz~xenial -> 17.0.0~git20170212+17.0.e81e2846-0ubuntu0ricotz~xenial > ( libs )
Keeping package libgles2-mesa:amd64
  Dependencies are not satisfied for libgl1-mesa-dev [ amd64 ] < 17.0.0~git20170206+17.0.07571cd8-0ubuntu0ricotz~xenial -> 17.0.0~git20170212+17.0.e81e2846-0ubuntu0ricotz~xenial > ( libdevel )
Keeping package libgl1-mesa-dev:amd64
  Dependencies are not satisfied for libgl1-mesa-dev [ amd64 ] < 17.0.0~git20170206+17.0.07571cd8-0ubuntu0ricotz~xenial -> 17.0.0~git20170212+17.0.e81e2846-0ubuntu0ricotz~xenial > ( libdevel )
Package libgl1-mesa-dev:amd64 libgl1-mesa-dev:amd64 Depende on mesa-common-dev [ amd64 ] < 17.0.0~git20170206+17.0.07571cd8-0ubuntu0ricotz~xenial -> 17.0.0~git20170212+17.0.e81e2846-0ubuntu0ricotz~xenial > ( libdevel ) (= 17.0.0~git20170206+17.0.07571cd8-0ubuntu0ricotz~xenial)
  Keeping Package mesa-common-dev:amd64 due to Depende
  Policy breaks with upgrade of kapptemplate [ amd64 ] < 4:16.12.1-0neon+16.04+build13 -> 4:16.12.2-0neon+16.04+build15 > ( devel )
Keeping package kapptemplate:amd64
  Dependencies are not satisfied for kapptemplate-dbgsym [ amd64 ] < 4:16.12.1-0neon+16.04+build13 -> 4:16.12.2-0neon+16.04+build15 > ( debug )
Keeping package kapptemplate-dbgsym:amd64
Calculando atualização... Pronto
Os pacotes a seguir serão mantidos em suas versões atuais:
  kapptemplate kapptemplate-dbgsym libgl1-mesa-dev libgl1-mesa-glx libgl1-mesa-glx:i386
  libglapi-mesa libglapi-mesa:i386 libgles2-mesa libosmesa6 libosmesa6:i386 mesa-common-dev
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 11 não atualizados.[/color]


Someone know how to fix this? ??? ??? ???


LPIC-1 SysAdmin l Entrepreneur - IT Enthusiast
XFCE & KDE Plasma
User avatar wferreira
Registered Member
Posts
58
Karma
0
OS
I tried to install libgles1-mesa but it is already in the latest version

Code: Select all
~$ sudo apt install libgles1-mesa
[sudo] password for taverna:
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
libgles1-mesa is already the newest version (17.0.0~git20170206+17.0.07571cd8-0ubuntu0ricotz~xenial).
libgles1-mesa configurado para instalar manualmente.
Starting pkgProblemResolver with broken count: 0
Starting 2 pkgProblemResolver with broken count: 0
Done
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 11 não atualizados.

:(


LPIC-1 SysAdmin l Entrepreneur - IT Enthusiast
XFCE & KDE Plasma
NoNameNoBlame
Karma
0
1)
Which KDE Neon Edition do You run?
User? User LTS? Develeoper?


2)
In User Edition, the up-to-date package-version availability is:

$ apt list -a libgles1-mesa
Listing... Done
libgles1-mesa/xenial-updates,now 12.0.6-0ubuntu0.16.04.1 amd64 [installed]
libgles1-mesa/xenial 11.2.0-1ubuntu2 amd64


3) Where do Your packages come from?


4) Please, prepend 'LC_ALL=C'+<SPACE> in front of your command line input.
User avatar claydoh
Registered Member
Posts
465
Karma
5
OS
Try using the preferred
Code: Select all
apt full-upgrade

instead of
Code: Select all
apt upgrade


full-upgrade (analogous to apt-get dist-upgrade) will install new packages as needed,, whereas upgrade will not, which is very likely why there are dependency problems.


claydoh, proud to be a member of KDE forums since 2008-Oct, and KDE user since 2001
User avatar wferreira
Registered Member
Posts
58
Karma
0
OS
claydoh wrote:Try using the preferred
Code: Select all
apt full-upgrade

instead of
Code: Select all
apt upgrade


full-upgrade (analogous to apt-get dist-upgrade) will install new packages as needed,, whereas upgrade will not, which is very likely why there are dependency problems.


I tried full-upgrade and dist-upgrade and gave errors

Last edited by wferreira on Wed Feb 15, 2017 3:19 pm, edited 1 time in total.


LPIC-1 SysAdmin l Entrepreneur - IT Enthusiast
XFCE & KDE Plasma
User avatar wferreira
Registered Member
Posts
58
Karma
0
OS
NoNameNoBlame wrote:1)
Which KDE Neon Edition do You run?
User? User LTS? Develeoper?


2)
In User Edition, the up-to-date package-version availability is:

$ apt list -a libgles1-mesa
Listing... Done
libgles1-mesa/xenial-updates,now 12.0.6-0ubuntu0.16.04.1 amd64 [installed]
libgles1-mesa/xenial 11.2.0-1ubuntu2 amd64


3) Where do Your packages come from?


4) Please, prepend 'LC_ALL=C'+<SPACE> in front of your command line input.


I've managed to resolve it I've used the apt upgrade and updated it with no errors.


LPIC-1 SysAdmin l Entrepreneur - IT Enthusiast
XFCE & KDE Plasma

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], camoore, Google [Bot], joshiravi, Majestic-12 [Bot], skylerjett, tosky, TristanDee, Yahoo [Bot]