Reply to topic

Unable to update to Kernel 4.9

louparker
Registered Member
Posts
15
Karma
0

Unable to update to Kernel 4.9

Mon Feb 13, 2017 9:52 pm
Unsuccessful at updating or upgrading to kernel 4.9 in Neon User edition. (I think I'm supposed to be able to do this.) Opened the console and entered the following:
wget http://kernel.ubuntu.com/~kernel-ppa/ma ... 31_all.deb

wget http://kernel.ubuntu.com/~kernel-ppa/ma ... _amd64.deb

wget http://kernel.ubuntu.com/~kernel-ppa/ma ... _amd64.deb

sudo dpkg -i *.deb

sudo update-grub

sudo reboot

It boots to the menu splash screen, and I hear the sound card connect with a noise, but from then out I get a blank screen. What do I have to do next, blacklist the 4.4 kernel or purge the 4.4 kernel? I thought I was supposed leave an alternative bootable kernel in the system. Thanks for all your help.

This is a learning exercise for me an a fresh install of neon with 5.9.1. Thanks!!!!!!!!!!!!!
NoNameNoBlame
Karma
0

Re: Unable to update to Kernel 4.9

Tue Feb 14, 2017 12:57 am
Maybe, You Didn't run this:

update-initramfs

###

$ update-initramfs -h
Usage: /usr/sbin/update-initramfs [OPTION]...

Options:
-k version Specify kernel version or 'all'
-c Create a new initramfs
-u Update an existing initramfs
-d Remove an existing initramfs
-t Take over a custom initramfs with this one
-b directory Set alternate boot directory
-v Be verbose
-h This message

###
User avatar claydoh
Registered Member
Posts
445
Karma
5
OS

Re: Unable to update to Kernel 4.9

Tue Feb 14, 2017 1:05 am
You possibly need to build video drivers for this Ubuntu mainline kernels which is unmodified and purely for testing purposes.


claydoh, proud to be a member of KDE forums since 2008-Oct, and KDE user since 2001
User avatar alideda
Registered Member
Posts
200
Karma
0
OS

Re: Unable to update to Kernel 4.9

Tue Feb 14, 2017 1:47 pm
The latest mainline kernel is 4.9.9. You need to grub menu when you select a kernel push E and add to the end kernel line nomodeset
louparker
Registered Member
Posts
15
Karma
0

Re: Unable to update to Kernel 4.9

Tue Feb 14, 2017 3:15 pm
Thanks gentlemen for all the help. I have been learning Linux for the past four years and I am amazed what is left out of the"helpful" bloggers posts around the internet. Yes, on 4.9 in Tumbleweed, I have to build video drivers. I forgot that. I'll all the suggestions. What makes Neon so appealing is that the media codecs work 99% of the time. In OpenSUSE, I have to fumble around for media codecs and they do not work all the time in TW or Leap in spite of carefully reading the media install wikis. Thanks!!!!!!!!!
User avatar alideda
Registered Member
Posts
200
Karma
0
OS

Re: Unable to update to Kernel 4.9

Wed Feb 15, 2017 4:49 pm
louparker wrote:Thanks gentlemen for all the help. I have been learning Linux for the past four years and I am amazed what is left out of the"helpful" bloggers posts around the internet. Yes, on 4.9 in Tumbleweed, I have to build video drivers. I forgot that. I'll all the suggestions. What makes Neon so appealing is that the media codecs work 99% of the time. In OpenSUSE, I have to fumble around for media codecs and they do not work all the time in TW or Leap in spite of carefully reading the media install wikis. Thanks!!!!!!!!!

Tumbleweed kernel 4.9.9
Make all media codecs and player to pacman repositorium...

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], gfielding, Google [Bot], Majestic-12 [Bot], nharvey, peje, pseco, Yahoo [Bot]