Reply to topic

Hash sum mismatch

Terces
Registered Member
Posts
6
Karma
0
OS

Hash sum mismatch

Thu Feb 16, 2017 9:38 pm
Whenever I try to run
Code: Select all
sudo apt update
I get two hash sum mismatches.

Code: Select all
Get:33 http://archive.ubuntu.com/ubuntu xenial-backports/main DEP-11 128x128 Icons [29 B]
Err:33 http://archive.ubuntu.com/ubuntu xenial-backports/main DEP-11 128x128 Icons
  Hash Sum mismatch
[.......]
Get:56 http://security.ubuntu.com/ubuntu xenial-security/multiverse DEP-11 128x128 Icons [29 B]
Err:56 http://security.ubuntu.com/ubuntu xenial-security/multiverse DEP-11 128x128 Icons
  Hash Sum mismatch
Fetched 1117 kB in 3s (365 kB/s)                       
Reading package lists... Done
E: Failed to fetch copy:/var/lib/apt/lists/partial/security.ubuntu.com_ubuntu_dists_xenial-security_multiverse_dep11_icons-64x64.tar.gz  Hash Sum mismatch
E: Failed to fetch copy:/var/lib/apt/lists/partial/archive.ubuntu.com_ubuntu_dists_xenial-backports_main_dep11_icons-64x64.tar.gz  Hash Sum mismatch
E: Some index files failed to download. They have been ignored, or old ones used instead.


It always happens to exactly those two repositories and I don't understand why at first it tries to get 128x128 icons and later fails to get the 64x64. disabling those two repositories works, but I worry that I might lose some important updates and make my system unstable.

Any recommendations are really appreciated.
vishalrao
Registered Member
Posts
146
Karma
0
OS

Re: Hash sum mismatch

Fri Feb 17, 2017 5:19 pm
Well duh. I am getting the exact same error (same files too!) when I just booted into my Neon dev unstable edition, using sweden mirrors for ubuntu archives.

Searching online found this:

http://askubuntu.com/questions/41605/tr ... atch-error
and
https://bugs.launchpad.net/ubuntu/+sour ... bug/972077

Apparently some sort of internet caching/filtering issue. Now I am curious as to why you and I are getting the exact same errors on the same files :)

@Terces - Can you tell me where you are located and what ISP you use? I am in India using Airtel 4G.


"Thou shalt not follow the null pointer for at its end madness and chaos lie."
User avatar acheronuk
KDE Developer
Posts
85
Karma
1

Re: Hash sum mismatch  Topic is solved

Fri Feb 17, 2017 5:38 pm
The actual bug being hit here is:

https://bugs.debian.org/cgi-bin/bugrepo ... bug=838441

as latest plasma-discover/appstream wants the new higher res icons.

Neon are looking at solutions. Preferable option being a backported patch for the apt version in the ubuntu archive for Xenial.
vishalrao
Registered Member
Posts
146
Karma
0
OS

Re: Hash sum mismatch

Fri Feb 17, 2017 5:45 pm
I should add this issue is not happening on my desktop just my laptop (both using wifi to same ISP router device).

Very intriguing, will try and dig around some more...


"Thou shalt not follow the null pointer for at its end madness and chaos lie."
vishalrao
Registered Member
Posts
146
Karma
0
OS

Re: Hash sum mismatch

Fri Feb 17, 2017 6:13 pm
@acheronuk thanks for the bug link.

I had uninstalled packagekit, plasma-discover (but not appstream) from my desktop a few days ago but not on my laptop where the issue was occurring.

Removed appstream, packagekit with --purge option which also got rid of plasma-discover and a few other items and now this hash mismatch issue isn't occurring.

Like the debian bug you linked mentions in the last comment where the fix is checked in, probably 2 appstream files being empty both resulting in same hash/url causing apt bug.


"Thou shalt not follow the null pointer for at its end madness and chaos lie."
User avatar acheronuk
KDE Developer
Posts
85
Karma
1

Re: Hash sum mismatch

Fri Feb 17, 2017 6:25 pm
The apt config change made by appstream is I think

/etc/apt/apt.conf.d/50appstream

i.e. that conf change triggers the bug.
Terces
Registered Member
Posts
6
Karma
0
OS

Re: Hash sum mismatch

Fri Feb 17, 2017 11:21 pm
Thanks for the replies.

vishalrao: I am located in Germany and use 1und1. I don't think there's a connection there.

acheronuk: Thank you for posting the link to the bug report. Good to know that they are aware of it and that it is fixed already. But I do wonder how long it will take until that patch will be available for me.
vishalrao
Registered Member
Posts
146
Karma
0
OS

Re: Hash sum mismatch

Sat Feb 18, 2017 7:20 am
If not patching the apt fix, neon team could try working around it with their version of the appstream package to NOT try to pull empty tarballs of 64x64 and/or 128x128 (hidpi) icons, (in that file /etc/apt/apt.conf.d/50appstream) but i dont know how appstream is supposed to work here.

Terces: yeah, that caching/ISP idea was based on me reading old/outdated stuff online, i went into conspiracy theory mode there :-)

Maybe you can edit the file to comment out one of the entries (for 64x64 or 128x128) in the apt conf file that should resolve the issue for you for now? (if you dont want to uninstall stuff like i did and just use terminal for apt updates)


"Thou shalt not follow the null pointer for at its end madness and chaos lie."
vishalrao
Registered Member
Posts
146
Karma
0
OS

Re: Hash sum mismatch

Wed Feb 22, 2017 4:14 pm
Looks like the apt packages are now updated in neon repos. Probably includes the patch to fix this issue?


"Thou shalt not follow the null pointer for at its end madness and chaos lie."
User avatar kde-jriddell
Registered Member
Posts
63
Karma
0
OS

Re: Hash sum mismatch

Wed Feb 22, 2017 4:30 pm
This was a bug in apt which was exposed when we started using appstream icons from apt sources. I've updated apt today with a fix. This also fixes the ISO generation which was broken.
clintonthegeek
Registered Member
Posts
49
Karma
0

Re: Hash sum mismatch

Sat Jun 03, 2017 5:38 am
Code: Select all
Fetched 7,622 kB in 7s (992 kB/s)                                                                                                                                                                                   
Reading package lists... Done
E: Failed to fetch http://security.ubuntu.com/ubuntu/dists/xenial-security/main/dep11/icons-128x128.tar  Could not open file /var/lib/apt/lists/partial/security.ubuntu.com_ubuntu_dists_xenial-security_main_dep11_icons-128x128.tar.gz - open (13: Permission denied) [IP: 91.189.88.162 80]
E: Some index files failed to download. They have been ignored, or old ones used instead.


This started happening to me the other day. This thread is the closest thing I could find when I searched it. Could it be related?

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], boudewijn, claydoh, dhealey, Exabot [Bot], farid, Google [Bot], keyths, kyrhammer, rubendecrop, Rytelier, Sogou [Bot]