Reply to topic

Screen Tearing on video files, and not on WebBrowser videos

alquimista
Registered Member
Posts
10
Karma
0
Hi,

I'm testing KDE Neon, and step by step I'm configuring it to have it as I want... Things so far, are going well. The only problem is that for videos reproduced in players like VLC, stored in my HD are shown with some tearing. I have searched the web about it and there are lots of solutions, have tried some with no success. I have an nvidia 340 card yet I'm not using the driver, since installing it causes more problems with GTK applications and font sizing. Video tearing is not present in videos played within browsers like Opera and FFox.

I'd appreciate your help please

Regards !
NoNameNoBlame
Karma
0
Do a test:

$ glxgears
Running synchronized to the vertical refresh. The framerate should be
approximately the same as the monitor refresh rate.
301 frames in 5.0 seconds = 60.012 FPS
300 frames in 5.0 seconds = 59.861 FPS

What FPS-numbers do You get?
NoNameNoBlame
Karma
0
Check this:

SystemSettings->DisplayAndMonitor->Compositor
cristianadam
Registered Member
Posts
4
Karma
0
OS
I've installed Neon on two computers with NVidia cards. I've installed the proprietary drivers via sudo ubuntu-drivers autoinstall. I haven't had any Gtk font issues.

To remove the tearing I've had to add to the Xorg.conf the following line:
Code: Select all
    Option         "metamodes" "nvidia-auto-select +0+0 { ForceCompositionPipeline = On }"

The line might get funky if you have multiple monitors. I use the nvidia-settings tool to get Xorg.conf dumps.

I don't understand why ForceCompositionPipeline is not enabled by default.
alquimista
Registered Member
Posts
10
Karma
0
cristianadam wrote:I've installed Neon on two computers with NVidia cards. I've installed the proprietary drivers via sudo ubuntu-drivers autoinstall. I haven't had any Gtk font issues.

To remove the tearing I've had to add to the Xorg.conf the following line:
Code: Select all
    Option         "metamodes" "nvidia-auto-select +0+0 { ForceCompositionPipeline = On }"

The line might get funky if you have multiple monitors. I use the nvidia-settings tool to get Xorg.conf dumps.

I don't understand why ForceCompositionPipeline is not enabled by default.


This line goes within section "Device" ?

The edit was:
Code: Select all
Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    Option         "metamodes" "nvidia-auto-select +0+0 { ForceCompositionPipeline = On }"
EndSection
alquimista
Registered Member
Posts
10
Karma
0
NoNameNoBlame wrote:Do a test:

$ glxgears
Running synchronized to the vertical refresh. The framerate should be
approximately the same as the monitor refresh rate.
301 frames in 5.0 seconds = 60.012 FPS
300 frames in 5.0 seconds = 59.861 FPS

What FPS-numbers do You get?
´I get these values:

Code: Select all
[email protected]:~$ glxgears
Running synchronized to the vertical refresh.  The framerate should be
approximately the same as the monitor refresh rate.
303 frames in 5.0 seconds = 60.429 FPS
301 frames in 5.0 seconds = 60.000 FPS
300 frames in 5.0 seconds = 59.997 FPS
301 frames in 5.0 seconds = 59.998 FPS
300 frames in 5.0 seconds = 60.000 FPS
300 frames in 5.0 seconds = 59.999 FPS
300 frames in 5.0 seconds = 60.000 FPS
300 frames in 5.0 seconds = 59.999 FPS
301 frames in 5.0 seconds = 59.999 FPS
301 frames in 5.0 seconds = 60.001 FPS
300 frames in 5.0 seconds = 59.997 FPS
alquimista
Registered Member
Posts
10
Karma
0
NoNameNoBlame wrote:Check this:

SystemSettings->DisplayAndMonitor->Compositor


Thank you
I played with different combinations of "Animation speed" , "Escalation method". Any specific value here, or any other parameters I should test with a specific value ?
Eneen
Registered Member
Posts
71
Karma
0
OS
I know it's not solution, but have you tried mpv?
NoNameNoBlame
Karma
0
This works for me: Try it.

Enable Compositor: yes
Speed: Middle
Scale: Crisp
Backend: OpenGL 3.1
Tearing: FullScreenRepaints
Thumbnails: OnlyForShownWindows
AllowToBlock: yes
cristianadam
Registered Member
Posts
4
Karma
0
OS
alquimista wrote:This line goes within section "Device" ?


No, it goes to section "Screen". I have the following:

Code: Select all
Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-6"
    Option         "TripleBuffer" "True"
    Option         "metamodes" "nvidia-auto-select +0+0 { ForceCompositionPipeline = On }"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
cristianadam
Registered Member
Posts
4
Karma
0
OS
NoNameNoBlame wrote:This works for me: Try it.

Enable Compositor: yes
Speed: Middle
Scale: Crisp
Backend: OpenGL 3.1
Tearing: FullScreenRepaints
Thumbnails: OnlyForShownWindows
AllowToBlock: yes


I played also with the settings and tested it with this youtube video.

No combination worked for me with the nvidia proprietary driver, except for ForceCompositionPipeline set to On.
NoNameNoBlame
Karma
0
Your youtube test-video tip is excellent!

Thank You!
alquimista
Registered Member
Posts
10
Karma
0
cristianadam wrote:
NoNameNoBlame wrote:This works for me: Try it.

Enable Compositor: yes
Speed: Middle
Scale: Crisp
Backend: OpenGL 3.1
Tearing: FullScreenRepaints
Thumbnails: OnlyForShownWindows
AllowToBlock: yes


I played also with the settings and tested it with this youtube video.

No combination worked for me with the nvidia proprietary driver, except for ForceCompositionPipeline set to On.


This completely solved my problem. Tank you very much !!

^-^

 
Reply to topic

Bookmarks



Who is online

Registered users: alra, Baidu [Spider], Bing [Bot], boospy007, Google [Bot], passegua, raudt, Sogou [Bot], Yahoo [Bot]