Reply to topic

Black Screen of Boot with KDE Neon

behrangs
Registered Member
Posts
1
Karma
0

Black Screen of Boot with KDE Neon

Fri Apr 14, 2017 5:44 am
Hi all,

Just tried to install KDE Neon on my system but it stops at the black screen of boot.

I have captured a video of the boot issue here: https://vimeo.com/213190356#t=120s

System details:

* Lenovo ThinkCentre desktop
* Intel Core i7 6700
* 32GB RAM
* 2x Dell 27" displays connected over DisplayPort
* Built in Intel HD Graphics 530

FYI, Ubuntu 16.10, Fedora 25, Manjaro i3*, and Windows 10 all boot fine.

Any suggestions for fixing this issue?

* Manjaro i3 boots without any problem but with very low resolution and with mirrored display by default that can be fixed using xrandr, etc.
NoNameNoBlame
Karma
0
In Grub menu, try:

1) Type:
'c'

2) Type:
gfxmode <pixelwidth>x<pixelheigth>x24

3) Type:
ESC

4) Boot Your entry

# Correction: Grub command Line

# An example

$ cat /boot/grub/grub.cfg | grep 'set.*gfx'
set gfxmode=1920x1200x24
set gfxpayload=keep

set linux_gfx_mode=1920x1200x24

Now, press ESC and boot entry.

If this doesn't help: Edit the menu entry (press 'e') directly.

Last edited by NoNameNoBlame on Fri Apr 14, 2017 7:34 pm, edited 2 times in total.
NoNameNoBlame
Karma
0
Can You watch Your own Vimeo video?
I can't. Not even with Firefox-all-extensions-disabled.
I tested other browsers…

Do You have to enable all cookies for Vimeo, or what?
User avatar fredhoud
Registered Member
Posts
110
Karma
1
OS
I was able to watch the video without any problem on Firefox as well as Chromium. ;)
NoNameNoBlame
Karma
0
I did see the video now. With Konqueror…


When You boot the kernel, the first kernel boot messages are visible.

But then, presumably, the kernel's video driver takes over,
and You get a blank screen.
I have a similar effect on my screen

(nvidia proprietary driver; the free and open nouveau driver doesn't do this):

The Linux Virtual Text Consoles go black
and their colors don't ever come back again.

But they are still working. You can blindly login on them
and do a reboot from there, for example.

After waiting, the graphical sddm login comes up, and
graphical desktop is fully functional.

If Your graphical desktop doesn't come up,
try a generic X video driver (fbdev).

And: Test it with only the primary display plugged in.

From Grub's command line, You can use 'cat'
to view (<disk>,<partition>)/var/log/Xorg.0.log
to see what went wrong with 'X'.
8draco8
Registered Member
Posts
1
Karma
0
Hi,

I found this topic when I had problems with installing KDE Neon on my desktop with Nvidia graphic card. The solution was in this post https://askubuntu.com/questions/162075/ ... -to-fix-it

Black/purple screen after you boot Ubuntu for the first time

This usually happens because you have an Nvidia or AMD graphics card, or a laptop with Optimus or switchable/hybrid graphics, and Ubuntu does not have the proprietary drivers installed to allow it to work with these.

The solution is to boot Ubuntu once in nomodeset mode (your screen may look weird) to bypass the black screen, download and install the drivers, and then reboot to fix it for ever.

Start your computer, and press the Right Shift when booting up, to get the Grub menu. Use the ← ↑ → ↓ keys to navigate/highlight the entry you want (usually the first one).

screen shot 5
Press e to edit that entry, which will show you the details:

screen shot 6
Find the linux entry as shown above, use the ← ↑ → ↓ keys to get to it, and then press the End key to get to that line's end (which may be on the next line!).

screen shot 7
Enter nomodeset as shown, and press Ctrl+X to boot to where you can successfully install your graphics drivers.
If you are running Ubuntu 12.04 or 12.10, and have a ATI/AMD graphics card, you have to follow the instructions here, otherwise you will run into this problem every time you restart your computer.


This will allow you to boot in to installer after installation you will still not be able to boot in to installed system. To boot there you have to edit bootloader again and again add nomodeset plus change gfxmode to your resolution, example: 1920x1200x24

After booting to freshly installed system you have to install nvidia drivers. After installation of drivers all the issues with boot and resolutions will be solved.
krzysztofb
Registered Member
Posts
1
Karma
0
Hello,
I have similar problem (Notebook Erazer x7849 for reference) and can't get installer to work. I set gfxmode and change splash & quiet options with nomodeset, but installer hangs just on the beginning with secure boot off. What is interesting with secure boot on installer is working for a bit - it boots normally to a point when i see briefly "login" and then shows _ in left top of the screen and hangs.
Do you know what have i done wrong? I used stable dev distro and made usb pen with Universal-USB-Installer-1.9.7.8 on Win10.

Thank you!

Edit 1
I tried also
Code: Select all
acpi_osi=Linux
Code: Select all
grub_gfxmode=1920x1080x24
Code: Select all
nvidia.modeset=0
and
Code: Select all
i915.modeste=0
Everything change slightly how the process of booting looks like, but still at the end I see black screen or cursor in right left.

Edit 2
After dozens of reboots with different parameters I found that
Code: Select all
nouveau.modeset=0
is best way. It doesn't show black screen or hangs like other parameters, but I get loop of blinking screen on login (I will edit this post during the weekend and and photos of my screen). Screen gets black for a second and come back to kde neon login and again and again. So I tried Kubuntu with nouveau.modeset=0 and it booted properly to live distro! So half success... No I can continue to fight with Neon or try installing Kubuntu and with repos to Neon.

 
Reply to topic

Bookmarks



Who is online

Registered users: ajmoss, Baidu [Spider], Bing [Bot], djarvie, Exabot [Bot], fbg13, flipwise, Google [Bot], kyrhammer, malger, mathewm, mathpfvr, OlafLostViking, Saru, Snudl