Reply to topic

Default plasmoid cmake installation directory

cdfghglz
Registered Member
Posts
3
Karma
0
I've recently tried to build and install some plasmoids from source on KDE neon. It was a success, but: the install directory is missing /usr in the beginning w.r.t. the installations that actually worked on other distros (Kubuntu). At the same time, all other plasmoids are in the correct directory - /usr/share/plasma/plasmoids/... . A generic CMakeLists.txt I tried to build&install with:
Code: Select all
cmake_minimum_required(VERSION 2.8.12 FATAL_ERROR)

set(QT_MIN_VERSION "5.4.0")
set(KF5_MIN_VERSION "5.0.0")

find_package(ECM 0.0.11 REQUIRED NO_MODULE)

set(CMAKE_MODULE_PATH ${ECM_MODULE_PATH} ${ECM_KDE_MODULE_DIR})

include(KDEInstallDirs)
include(KDECMakeSettings)
include(KDECompilerSettings)

find_package(Qt5 ${REQUIRED_QT_VERSION} CONFIG REQUIRED Quick)
find_package(KF5 ${KF5_MIN_VERSION} REQUIRED COMPONENTS Plasma)

add_subdirectory(plugin)
add_subdirectory(translations)

plasma_install_package(package org.kde.plasma.packagename)

install( DIRECTORY icons/breeze DESTINATION ${ICON_INSTALL_DIR})


Is the ECM responsible for the resulting paths or is there anything else to be adapted in KDE neon?
User avatar wferreira
Registered Member
Posts
58
Karma
0
OS
You try install using:
Code: Select all
sudo
?


LPIC-1 SysAdmin l Entrepreneur - IT Enthusiast
XFCE & KDE Plasma

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], bartoloni, Bing [Bot], Bladeforce, boudewijn, claydoh, Data007, Gallaecio, googie, Google [Bot], jeffarnholt, kamathraghavendra, Mace68, mauromol, rblackwell, Sogou [Bot], TheraHedwig, wind_rose_2, Yahoo [Bot]