Reply to topic

Can't install Calibre, unmet dependecies

User avatar gkdeb
Registered Member
Posts
2
Karma
0
OS
Hi, I'm trying to install calibre but got unmet dependencies:

Code: Select all
gkdeb ~ $  sudo apt install calibre
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Starting pkgProblemResolver with broken count: 1
Starting 2 pkgProblemResolver with broken count: 1
Investigating (0) calibre [ amd64 ] < none -> 2.55.0+dfsg-1 > ( universe/text )
Broken calibre:amd64 Depends on calibre-bin [ amd64 ] < none -> 2.55.0+dfsg-1 > ( universe/text ) (>= 2.55.0+dfsg-1)
  Considering calibre-bin:amd64 0 as a solution to calibre:amd64 9998
  Re-Instated libchm1:amd64
  Re-Instated libpodofo0.9.3:amd64
    Reinst Failed early because of qtbase-abi-5-5-1:amd64
Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 calibre : Depends: calibre-bin (>= 2.55.0+dfsg-1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
mesoptafel
Registered Member
Posts
26
Karma
0
you can install calibre from the website: https://calibre-ebook.com/download_linux
There you will find a long command. With copy & paste you can install (or update) Calibre.


This method works for me.
User avatar gkdeb
Registered Member
Posts
2
Karma
0
OS
mesoptafel wrote:you can install calibre from the website: https://calibre-ebook.com/download_linux
There you will find a long command. With copy & paste you can install (or update) Calibre.


This method works for me.


Thanks mesoptafel! Yes, you can install it that way, but It would be nice to install it from the repos, like any other packages, so I think this unmet dependencies problem should be solved.
User avatar claydoh
Registered Member
Posts
715
Karma
5
OS
Neon are not responsible for Calibre packaging, which has been broken for most if not all Ubuntu 16.04 based distros, based on googling the dependency error message. The package in the Ubuntu repos is old, and is something automatically imported from the Debian snapshot they make when they start working on a distro release. It is in the so-called "universe" component, and is not truly supported by Ubuntu at all.

Calibre themselves maintain up to date packages, so in this case outside stuff is the best way to go.


claydoh, proud to be a member of KDE forums since 2008-Oct, and KDE user since 2001
sstaeglich
Registered Member
Posts
55
Karma
0
@claydoh Sorry, but what your are saying is totally nonsense. Of course is this a (known!) problem of neon. Ubuntu 16.04 ships Qt 5.5, but neon updated Qt actually to 5.9 without providing a solution for all Qt-based non-KDE software. So all this software is not usable without hacks with neon.

If this problem will not be fixed, I think many users will switch back to Kubuntu with 18.04 because incompatibility really sucks.

EDIT: And yes I tested it. It was no problem to install calibre on a pure Ubuntu i386.

EDIT2: And there are many possible solutions:
[list=]
[*] Update also Qt-based software.
[*] Rebuild only all Qt-based software (AFAIK this solution is preferred actually)
[*] Provide a meta package for Qt 5.5 (Works of course only if the ABI has not be changed.)
[/list]
sstaeglich
Registered Member
Posts
55
Karma
0
sstaeglich wrote:@claydoh Sorry, but what your are saying is totally nonsense. Of course is this a (known!) problem of neon. Ubuntu 16.04 ships Qt 5.5, but neon updated Qt actually to 5.9 without providing a solution for all Qt-based non-KDE software. So all this software is not usable without hacks with neon.

If this problem will not be fixed, I think many users will switch back to Kubuntu with 18.04 because incompatibility really sucks.

EDIT: And yes I tested it. It was no problem to install calibre on a pure Ubuntu i386.

EDIT2: And there are many possible solutions:
  1. Update also Qt-based software (Would be the best for all users)
  2. Rebuild only all Qt-based software (AFAIK this solution is preferred actually)
  3. Provide a meta package for Qt 5.5 (Works of course only if the ABI has not be changed.)
jakeroberts
Registered Member
Posts
1
Karma
0
Is there a reason nobody has tried making a snap for this yet?
iookde
Registered Member
Posts
9
Karma
0
I am trying to install this software 2 years after the original user posted this message and I am getting the same error. Has this not been fixed 2 years later?

Is this a typical situation for KDE neon to have these broken and incompatible software packages?
User avatar claydoh
Registered Member
Posts
715
Karma
5
OS
iookde wrote:I am trying to install this software 2 years after the original user posted this message and I am getting the same error. Has this not been fixed 2 years later?

Is this a typical situation for KDE neon to have these broken and incompatible software packages?



It is the same neon-specific problem. the outdated package in Ubuntu , which is a direct import from Debian, has a hard dependency on the Qt version in Ubuntu. Neon ships with its own more up to date Qt, which is required for the latest Plasma versions. This breaks a very small number of less popular Qt based programs in Ubuntu's repos ( 5-ish last I looked) that have this built-in hard dep. For these very few applications, neon users simply have to get a more current source. In this case, Calibre themselves provide software that will work on Neon just fine. It is something Neon has absolutely zero control over. Ubuntu don't even package these themselves.

This could be fixed but you would have to convince Ubuntu's MOTUs, who manage these unsupported "Universe" packages, to fix something that from Ubuntu's perspective is not broken.

People just have to sort of deal with the minor inconvenience of installing a fresh version from other sources

https://calibre-ebook.com/download_linux
easier: https://flathub.org/apps/details/com.ca ... ok.calibre


claydoh, proud to be a member of KDE forums since 2008-Oct, and KDE user since 2001
User avatar blue_bullet
Registered Member
Posts
73
Karma
0
OS
mesoptafel wrote:you can install calibre from the website: https://calibre-ebook.com/download_linux
There you will find a long command. With copy & paste you can install (or update) Calibre.


This method works for me.

This has always worked for me as well. I am installing Calibre 5.3 on KDE Neon via Konsole as I write this.

Be advised if you rely on DRM removal routines in Calibre to work for digital media you have purchased, the most recent version of Calibre will not help you. The move to Python 3 clobbered the De_DRM_tools. You have to use an old version of Calibre like 4.x until the wizards at Apprentice Alf figure out how to get Python 3 to work with Calibre 5.x. Old versions of Calibre can be found here.
https://download.calibre-ebook.com/

Not trying to muddy the water; just saying what I learned the past week. I have to do my DRM removal on Windows where I have kept Calibre at 4.23.


Migrated from Linux Mint 17.3/18.3 KDE to KDE neon User Edition. Now 5.20.

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], clh333, egerlach, Gibtnix, Google [Bot], robertotamburrino, Sogou [Bot], vasyok, Yahoo [Bot]