Reply to topic

[SOLVED] KDE Neon with Plasma 5.10.3 won't suspend

emirz
Registered Member
Posts
3
Karma
0
Hello,

I've set up suspend to be on when I close my laptop's lid. Sadly it won't work. It's a freshly installed KDE Neon with Plasma 5.10.3.

My inxi output:

Code: Select all
System:    Kernel: 4.8.0-58-generic x86_64 (64 bit) Desktop: KDE Plasma 5.10.3
           Distro: neon 16.04 xenial
Machine:   Mobo: Acer model: Larne v: V1.01 Bios: Insyde v: V1.01 date: 05/27/2014
CPU:       Quad core AMD A8-6410 APU with AMD Radeon R5 Graphics (-MCP-) cache: 8192 KB
           clock speeds: max: 2000 MHz 1: 1400 MHz 2: 1200 MHz 3: 1800 MHz 4: 1200 MHz
Graphics:  Card-1: Advanced Micro Devices [AMD/ATI] Mullins [Radeon R4/R5 Graphics]
           Card-2: Advanced Micro Devices [AMD/ATI] Jet XT [Radeon R5 M240]
           Display Server: X.Org 1.18.4 drivers: ati,radeon (unloaded: fbdev,vesa) Resolution: [email protected]
           GLX Renderer: Gallium 0.4 on AMD MULLINS (DRM 2.46.0 / 4.8.0-58-generic, LLVM 3.8.0)
           GLX Version: 3.0 Mesa 12.0.6
Audio:     Card-1 Advanced Micro Devices [AMD] FCH Azalia Controller driver: snd_hda_intel
           Card-2 Advanced Micro Devices [AMD/ATI] Kabini HDMI/DP Audio driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.8.0-58-generic
Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller driver: r8169
           Card-2: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter driver: ath9k
Drives:    HDD Total Size: 240.1GB (80.9% used) ID-1: /dev/sda model: TOSHIBA_Q300. size: 240.1GB
Sensors:   System Temperatures: cpu: 50.2C mobo: N/A gpu: 49.0,N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 204 Uptime: 2:22 Memory: 2081.0/6935.7MB Client: Shell (bash) inxi: 2.2.35


Is this issue known? If so, then I'm sorry, but I couldn't find it on the forums.
Please advise in case you need more logs or other input. Thanks.

Last edited by emirz on Thu Jul 27, 2017 8:45 pm, edited 1 time in total.
NoNameNoBlame
Karma
0
Do You have enough swap-space?

# Test:
$ swapon --verbose --show
NAME TYPE SIZE USED PRIO
/dev/sdb6 partition 16G 0B -1
/dev/sdb3 partition 16G 0B -2
emirz
Registered Member
Posts
3
Karma
0
Code: Select all
swapon --verbose --show
NAME      TYPE      SIZE  USED PRIO
/dev/sda2 partition  12G 74,5M   -1


12 GB should be enough for 8 GB.

After restarting, it works, but it fails when baloo is active and searching for files. I'll monitor it and keep updating.

Another thing: I've unplugged the charger, but KDE still thinks it's plugged in. Weird.
NoNameNoBlame
Karma
0
Maybe, the reason is this functionality:

# Sleep and Shutdown Inhibition:

https://www.freedesktop.org/software/sy ... hibit.html
NoNameNoBlame
Karma
0
And look under: Power Management

https://www.kde.org/announcements/plasma-5.2.95.php

Else search for:

"site:www.kde.org inhibit"

in <Your Favorite Search Engine>.
NoNameNoBlame
Karma
0
Try and check:

System Settings
-Power Management
--Activity Settings
---Define a special behavior
----Never suspend or shutdown the computer, etc.
emirz
Registered Member
Posts
3
Karma
0
Thanks for all of your answers. Suspend now works fine. I think it had to do with Baloo hogging the memory and the system probably presuming the machine was busy. I'm marking this as solved.
NoNameNoBlame
Karma
0
For Hibernating (Suspend to Disk), there's
the 'resume=…' kernel parameter, too.

# Example:
$ cat /etc/default/grub | grep resume
GRUB_CMDLINE_LINUX_DEFAULT="resume=UUID=8e518044-87f8-412f-b874-f7ff8cabfffd"

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], bartoloni, Bing [Bot], Google [Bot], jmacleod, Majestic-12 [Bot]