Reply to topic

File search on Dolphin not working

User avatar trintadosete
Registered Member
Posts
23
Karma
0
OS

File search on Dolphin not working

Wed Jul 26, 2017 1:49 pm
Hi,

The file search in Dolphin is not returning any results... event if I search for something using exactly an existing file name.

Baloo is installed, balooctl status returns:

Code: Select all
Baloo File Indexer is running
Indexer state: Idle
Indexed 40578 / 40578 files
Current size of index is 338.51 MiB


The file search is activated on System settings.
Kfind works nively, but I do like the search feature on Dolphin...

Any idea what could be going on?

BTW, I am using KDE Neon 5.10.
NoNameNoBlame
Karma
0
Well, for me it works (balloosearch), BUT:

I have questions, too.

If I search my home directory+subdirectories for
files containing 'xsession', then this happens:

In the input-field, I type 'x': Lots of files appear.
Then I add an 's': 'xs' gives zero results. List formerly filled is emptied.
After having input 'xse', correct results appear again.

Edit: Addition

$ dolphin --version
dolphin 17.04.3

$ balooctl --version
baloo 5.36.0

$ lsb_release -sd
KDE neon User Edition 5.10
NoNameNoBlame
Karma
0
To the original poster:

I suppose, You did check this:

$ kcmshell5 kcm_baloofile

(if I understand You correctly) ?
User avatar trintadosete
Registered Member
Posts
23
Karma
0
OS
Yes. Both options are ON.
User avatar trintadosete
Registered Member
Posts
23
Karma
0
OS
Actually, I just noticed that baloo is finding some files, but a very reduced number of them and I can not identify any pattern in what is searched and what is not...

On the other hand, when I search using the command baloosearch, it is working perfectly.

Any ideas?
NoNameNoBlame
Karma
0
For my next question, I apologize in advance.
But is has to be asked to be sure.

Here it comes:

After selecting 'Find' within Dolphin,
under 'More Options',
did You check 'Any'+'AnyTime'+'AnyRating'?

'
NoNameNoBlame
Karma
0
User avatar trintadosete
Registered Member
Posts
23
Karma
0
OS
I was checking the page https://community.kde.org/Baloo/Configuration and everything was correct. By the end, I decided to run
Code: Select all
balooctl check

And the problem was fixed! Apparently, for some reason, baloo had not indexed the majority of files on my home. After the command above, all files were indexed and the search is working perfectly.

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], Google [Bot], Majestic-12 [Bot], Yahoo [Bot]