Reply to topic

Enigmail not decrypting/ encrypting mails

marvmaverick
Registered Member
Posts
2
Karma
0
Hi everyone,
I recently switched to KDE neon and I cannot get Enigmail in Thunderbird to work properly. I installed pinentry-qt and pinentry-gtk2 and get a graphic interface asking for my passphrase. When I enter my passphrase I get an error:
Error - no matching private/secret key found to decrypt message

gpg: decryption failed: No secret key

Note: The message is encrypted for the following User ID's / Keys:
my key
key of sender

When I enter a wrong passphrase, I get the same error, but no error that the passphrase is not correct. I tried to use my Enigmail backup on Debian and it worked perfectly.
When I try to send a mail, the follwing error pops up: Error - encryption command failed

I wanted to check my gpg-agent.conf but when I try to open it (via double clicking on the file), I get the following error: Unable to run the command specified. The file or folder /home/marv/.gnupg/gpg-agent.conf does not exist.

I am using Thunderbird 52.2.1 (64-bit) and Enigmail 1.9.8.2

Did anyone have the same problem and solved it? Any help will be appreciated.

Thanks in advance,
Marv
raddison
Registered Member
Posts
513
Karma
0
marvmaverick wrote:Hi everyone,
I recently switched to KDE neon and I cannot get Enigmail in Thunderbird to work properly. I installed pinentry-qt and pinentry-gtk2 and get a graphic interface asking for my passphrase. When I enter my passphrase I get an error:
Error - no matching private/secret key found to decrypt message

gpg: decryption failed: No secret key

Note: The message is encrypted for the following User ID's / Keys:
my key
key of sender

When I enter a wrong passphrase, I get the same error, but no error that the passphrase is not correct. I tried to use my Enigmail backup on Debian and it worked perfectly.
When I try to send a mail, the follwing error pops up: Error - encryption command failed

I wanted to check my gpg-agent.conf but when I try to open it (via double clicking on the file), I get the following error: Unable to run the command specified. The file or folder /home/marv/.gnupg/gpg-agent.conf does not exist.

I am using Thunderbird 52.2.1 (64-bit) and Enigmail 1.9.8.2

Did anyone have the same problem and solved it? Any help will be appreciated.

Thanks in advance,
Marv


It's hard to believe such a thing would happen on Neon. The installer says "security, privacy and autonomy ... " and I have no reason not to doubt those claims. Issue a bug report. Perhaps a missing package you can apt install but not included in the image?!


Proud to be powered by Plasma
marvmaverick
Registered Member
Posts
2
Karma
0
raddison wrote:It's hard to believe such a thing would happen on Neon. The installer says "security, privacy and autonomy ... " and I have no reason not to doubt those claims. Issue a bug report. Perhaps a missing package you can apt install but not included in the image?!


Thank you for your answer. I still haven't figured it out and will probably ask the Enigmail support.
But if anyone else solved this problem, I would still be interested in a solution ;)

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], claydoh, cmb, cylverbak, Google [Bot], JesusM, kevjon, scummos, Sogou [Bot], YaCy [Bot]