Reply to topic

Notifications broken

sandres
Registered Member
Posts
5
Karma
0

Notifications broken

Mon Dec 04, 2017 3:14 pm
Hi,

the notifications popping up seem to be broken. When I run notify-send a it looks like this:

https://ibb.co/bQwuPb

I already tried to change "Look and Feel" as well as "Desktop Theme" with no success. Does someone know a fix or workaround?

Kind regards,
Sascha
sandres
Registered Member
Posts
5
Karma
0

Re: Notifications broken

Mon Dec 04, 2017 4:06 pm
Hi,

it turned out, that an autostart application pushed a notification before the splash screen was done. When that happens, the notifications loose their style. I inserted a sleep 5 before the launch ( bash -l -c 'sleep 5 && yakuake' ) and mystery was solved.

Shouldn't the nodifications beeing silenced while the session is loaded?

Kind regards,
Sascha
airdrik
Registered Member
Posts
1745
Karma
5
OS

Re: Notifications broken

Tue Dec 05, 2017 7:46 pm
Well I think rather than silencing notifications during startup they should be queued up until the session is done loading to ensure that the user does get a chance to see them.


airdrik, proud to be a member of KDE forums since 2008-Dec.
sandres
Registered Member
Posts
5
Karma
0

Re: Notifications broken

Thu Dec 07, 2017 1:31 pm
@airdrik Sure, this would be the best solution, but as I am not the developer of the app this is hard to do. Besides, maybe the receiver could accept but queue instead of doing this for all application again and again
airdrik
Registered Member
Posts
1745
Karma
5
OS

Re: Notifications broken

Thu Dec 07, 2017 7:54 pm
I was referring to if the devs were to change plasma to do something about notifications during session startup then they should change it to queue them up rather than just silence them.


airdrik, proud to be a member of KDE forums since 2008-Dec.

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Belliric, Bing [Bot], Google [Bot], leodd, Yahoo [Bot]