Reply to topic

fcitx mozc japanese input in qt apps

Ignis
Registered Member
Posts
3
Karma
0
Hello,

お世話になっております。

Time to time I have to write in Japanese on KDE Neon, and for that I have installed fcitx and fcitx-mozc, and configured it with
Code: Select all
im-config -n fcitx


Everything was basically working out of the box until recently (no idea on precise time), when I have noticed that fcitx have stopped working in Qt apps like Kate or Konsole etc, while still working in gtk apps like LibreOffice and Firefox.

Any suggestions where to check if my environment variables are set correctly or am I missing some packages?
Or perhaps qt was updated recently, but fcitx did not follow?

Here is my fcitx-diagnose output:
Code: Select all
# System Info:
1.  `uname -a`:

        Linux neon-desktop 4.13.0-36-generic #40~16.04.1-Ubuntu SMP Fri Feb 16 23:25:58 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

2.  `lsb_release -a`:

        No LSB modules are available.
        Distributor ID:   neon
        Description:   KDE neon LTS User Edition 5.12
        Release:   16.04
        Codename:   xenial

3.  `lsb_release -d`:

        Description:   KDE neon LTS User Edition 5.12

4.  `/etc/lsb-release`:

        DISTRIB_ID=neon
        DISTRIB_RELEASE=16.04
        DISTRIB_CODENAME=xenial
        DISTRIB_DESCRIPTION="KDE neon LTS User Edition 5.12"

5.  `/etc/os-release`:

        NAME="KDE neon LTS"
        VERSION="5.12"
        ID=neon
        ID_LIKE="ubuntu debian"
        PRETTY_NAME="KDE neon LTS User Edition 5.12"
        VERSION_ID="16.04"
        HOME_URL="http://neon.kde.org/"
        SUPPORT_URL="http://neon.kde.org/"
        BUG_REPORT_URL="http://bugs.kde.org/"
        VERSION_CODENAME=xenial
        UBUNTU_CODENAME=xenial

6.  Desktop Environment:

    Desktop environment is `kde`.

7.  Bash Version:

        BASH_VERSION='4.3.48(1)-release'

# Environment:
1.  DISPLAY:

        DISPLAY=':0'

2.  Keyboard Layout:

    1.  `setxkbmap`:

            xkb_keymap {
               xkb_keycodes  { include "evdev+aliases(qwerty)"   };
               xkb_types     { include "complete"   };
               xkb_compat    { include "complete+japan"   };
               xkb_symbols   { include "pc+jp+inet(evdev)"   };
               xkb_geometry  { include "pc(pc101)"   };
            };

    2.  `xprop`:

            _XKB_RULES_NAMES(STRING) = "evdev", "pc101", "jp", "", ""

3.  Locale:

    1.  All locale:

            C
            C.UTF-8
            en_AG
            en_AG.utf8
            en_AU.utf8
            en_BW.utf8
            en_CA.utf8
            en_DK.utf8
            en_GB.utf8
            en_HK.utf8
            en_IE.utf8
            en_IN
            en_IN.utf8
            en_NG
            en_NG.utf8
            en_NZ.utf8
            en_PH.utf8
            en_SG.utf8
            en_US.utf8
            en_ZA.utf8
            en_ZM
            en_ZM.utf8
            en_ZW.utf8
            ja_JP.utf8
            POSIX
            ru_RU.utf8

    2.  Current locale:

            LANG=en_GB.UTF-8
            LANGUAGE=en_GB
            LC_CTYPE="en_GB.UTF-8"
            LC_NUMERIC=ja_JP.UTF-8
            LC_TIME=en_GB.UTF-8
            LC_COLLATE="en_GB.UTF-8"
            LC_MONETARY=ja_JP.UTF-8
            LC_MESSAGES="en_GB.UTF-8"
            LC_PAPER=ja_JP.UTF-8
            LC_NAME=ja_JP.UTF-8
            LC_ADDRESS=ja_JP.UTF-8
            LC_TELEPHONE=ja_JP.UTF-8
            LC_MEASUREMENT=ja_JP.UTF-8
            LC_IDENTIFICATION=ja_JP.UTF-8
            LC_ALL=

4.  Directories:

    1.  Home:

            /home/neverov

    2.  `${XDG_CONFIG_HOME}`:

        Environment variable `XDG_CONFIG_HOME` is not set.

        Current value of `XDG_CONFIG_HOME` is `~/.config` (`/home/neverov/.config`).

    3.  Fcitx Settings Directory:

        Current fcitx settings directory is `~/.config/fcitx` (`/home/neverov/.config/fcitx`).

5.  Current user:

    The script is run as neverov (1000).

# Fcitx State:
1.  executable:

    Found fcitx at `/usr/bin/fcitx`.

2.  version:

    Fcitx version: `4.2.9.1`

3.  process:

    Found 2 fcitx processes:

         1222 fcitx
         1703 fcitx-dbus-watc

4.  `fcitx-remote`:

    `fcitx-remote` works properly.

# Fcitx Configure UI:
1.  Config Tool Wrapper:

    Found fcitx-configtool at `/usr/bin/fcitx-configtool`.

2.  Config GUI for gtk2:

    **Config GUI for gtk2 not found.**

3.  Config GUI for gtk3:

    Found `fcitx-config-gtk3` at `/usr/bin/fcitx-config-gtk3`.

4.  Config GUI for kde:

# Frontends setup:
## Xim:
1.  `${XMODIFIERS}`:

    Environment variable XMODIFIERS is set to "@im=fcitx" correctly.
    Xim Server Name from Environment variable is fcitx.

2.  XIM_SERVERS on root window:

    Xim server name is the same with that set in the environment variable.

## Qt:
1.  qt4 - `${QT4_IM_MODULE}`:

    Environment variable QT4_IM_MODULE is set to "fcitx" correctly.

2.  qt5 - `${QT_IM_MODULE}`:

    Environment variable QT_IM_MODULE is set to "fcitx" correctly.

3.  Qt IM module files:
    Found fcitx im module for Qt5: `/usr/lib/x86_64-linux-gnu/qt5/plugins/platforminputcontexts/libfcitxplatforminputcontextplugin.so`.
    Found unknown fcitx qt module: `/usr/lib/x86_64-linux-gnu/qt5/plugins/kcm_fcitx.so`.
    Found fcitx im module for Qt4: `/usr/lib/x86_64-linux-gnu/qt4/plugins/inputmethods/qtim-fcitx.so`.

## Gtk:
1.  gtk - `${GTK_IM_MODULE}`:

    Environment variable GTK_IM_MODULE is set to "fcitx" correctly.

2.  `gtk-query-immodules`:

    1.  gtk 2:

        **Cannot find `gtk-query-immodules` for gtk 2**

        **Cannot find fcitx im module for gtk 2.**

    2.  gtk 3:

        **Cannot find `gtk-query-immodules` for gtk 3**

        **Cannot find fcitx im module for gtk 3.**

3.  Gtk IM module cache:

    1.  gtk 2:

        Found immodules cache for gtk `2.24.30` at `/usr/lib/x86_64-linux-gnu/gtk-2.0/2.10.0/immodules.cache`.
        Version Line:

            # Created by /usr/lib/x86_64-linux-gnu/libgtk2.0-0/gtk-query-immodules-2.0 from gtk+-2.24.30

        Found fcitx im modules for gtk `2.24.30`.

            "/usr/lib/x86_64-linux-gnu/gtk-2.0/2.10.0/immodules/im-fcitx.so"
            "fcitx" "Fcitx (Flexible Input Method Framework)" "fcitx" "/usr/share/locale" "ja:ko:zh:*"

    2.  gtk 3:

        Found immodules cache for gtk `3.18.9` at `/usr/lib/x86_64-linux-gnu/gtk-3.0/3.0.0/immodules.cache`.
        Version Line:

            # Created by /usr/lib/x86_64-linux-gnu/libgtk-3-0/gtk-query-immodules-3.0 from gtk+-3.18.9

        Found fcitx im modules for gtk `3.18.9`.

            "/usr/lib/x86_64-linux-gnu/gtk-3.0/3.0.0/immodules/im-fcitx.so"
            "fcitx" "Fcitx (Flexible Input Method Framework)" "fcitx" "/usr/share/locale" "ja:ko:zh:*"

4.  Gtk IM module files:

    1.  gtk 2:

        All found Gtk 2 immodule files exist.

    2.  gtk 3:

        All found Gtk 3 immodule files exist.

# Configuration:
## Fcitx Addons:
1.  Addon Config Dir:

    Found fcitx addon config directory: `/usr/share/fcitx/addon`.

2.  Addon List:

    1.  Found 24 enabled addons:

            fcitx-autoeng
            fcitx-chttrans
            fcitx-classic-ui
            fcitx-clipboard
            fcitx-dbus
            fcitx-freedesktop-notify
            fcitx-fullwidth-char
            fcitx-imselector
            fcitx-ipc
            fcitx-keyboard
            fcitx-kimpanel-ui
            fcitx-lua
            fcitx-mozc
            fcitx-notificationitem
            fcitx-punc
            fcitx-quickphrase
            fcitx-remote
            fcitx-spell
            fcitx-unicode
            fcitx-vk
            fcitx-x11
            fcitx-xim
            fcitx-xkb
            fcitx-xkbdbus

    2.  Found 0 disabled addons:

3.  Addon Libraries:

    All libraries for all addons are found.

4.  User Interface:

    Found 2 enabled user interface addons:

        fcitx-classic-ui
        fcitx-kimpanel-ui

    Kimpanel process:

         1360 /usr/bin/plasmashell

## Input Methods:
1.  Found 2 enabled input methods:

        fcitx-keyboard-jp
        mozc

2.  Default input methods:

    You have a keyboard input method "fcitx-keyboard-jp" correctly added as your default input method.

# Log:
1.  `date`:

        Tue 27 Feb 15:41:04 JST 2018

2.  `~/.config/fcitx/log/`:

        total 0

3.  `~/.config/fcitx/log/crash.log`:

    `~/.config/fcitx/log/crash.log` not found.
dcbuist
Registered Member
Posts
14
Karma
0
Do you have a file called ".xinputrc" in your home directory? It should contain the following line of code:

Code: Select all
run_im fcitx


I had to manually create this file. Before I created it, Japanese input worked in Firefox, but not in Kate or kwrite.
Ignis
Registered Member
Posts
3
Karma
0
dcbuist wrote:Do you have a file called ".xinputrc" in your home directory? It should contain the following line of code:

Code: Select all
run_im fcitx




I do, and it was generated by im-config.
So it must be something else.
dinhnam
Registered Member
Posts
1
Karma
0
dcbuist wrote:Do you have a file called ".xinputrc" in your home directory? It should contain the following line of code:

Code: Select all
run_im fcitx


I had to manually create this file. Before I created it, Japanese input worked in Firefox, but not in Kate or kwrite.

Oh man, thank you so much. Now I can type Vietnamese in qt5 app, don't think the solution is so so simple like that. But after this fix, my fcitx systray icon becomes so weird and look ugly. How can I change it's icon?

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], Dibo, Google [Bot], Sogou [Bot]