Reply to topic

Font rendering in GTK applications after update to Bionic.

nybac
Registered Member
Posts
14
Karma
0
OS
Hey guys,
I successfully updated my KDE NEon to Bionic, and I notice that menus' fonts in GTK apps look slightly different from Qt apps, although they're set identically.
Anyone experiencing the same issue ?
Thanks.
User avatar waynes
Registered Member
Posts
54
Karma
0
No Problems here.
Fonts are a bit of a pain in KDE. I always find to get them all the same, the Fonts need to be set identically using the qt4-qtconfig & qt5ct packages, then in system settings make sure the GTK fonts match the system fonts. Then repeat the steps using systemsettings5 as root.
If that fails try deleting the fonts cache in your home folder.
I can't be more specific at present as I'm away from my Neon install.
nybac
Registered Member
Posts
14
Karma
0
OS
The problem seems to be related to Noto Sans fonts. If I try another font, everything is OK.
jactor
Registered Member
Posts
1
Karma
0
Same problem here.
raddison
Registered Member
Posts
511
Karma
0
Bionic User Edition updated to the latest. Stock settings. I cannot confirm the issue. Please post an image so we can see the faulty font rendering.


Proud to be powered by Plasma
nybac
Registered Member
Posts
14
Karma
0
OS
User avatar bobbywibowo
Registered Member
Posts
13
Karma
0
OS
Having similar issue as the user above ^
User avatar ytomino
Registered Member
Posts
6
Karma
0
OS
https://i.imgur.com/qeK5UxP.png (this image is over 720px)

Hi. Firefox uses Noto Sans against my preferences. Is this same problem?
I have installed the package "fonts-liberation2". fontconfig seems to be taking it as Arial by terminal. However Firefox does not use it.
Also I tried with "fonts-ipafont" (that is a Japanese font set) and visited some Japanese pages. Noto Sans seems to be prioritized on this case, too.

I installed KDE neon after it's rebased on Bionic, but have updated 2 or 3 times.
Thanks.
User avatar bobbywibowo
Registered Member
Posts
13
Karma
0
OS
ytomino wrote:https://i.imgur.com/qeK5UxP.png (this image is over 720px)

Hi. Firefox uses Noto Sans against my preferences. Is this same problem?
I have installed the package "fonts-liberation2". fontconfig seems to be taking it as Arial by terminal. However Firefox does not use it.
Also I tried with "fonts-ipafont" (that is a Japanese font set) and visited some Japanese pages. Noto Sans seems to be prioritized on this case, too.

I installed KDE neon after it's rebased on Bionic, but have updated 2 or 3 times.
Thanks.

I'm not sure if it's the right way, but I created a new config file at ~/.config/fontconfig/conf.d (name it whatever), https://gist.github.com/BobbyWibowo/37d ... deed9c8afd, to basically set preferred fonts for all 3 of the basic font families. Previously doing fc-match sans-serif would indeed print out Noto Sans, but now it prints out my preferred font and Firefox been using it just fine ever since (make sure you restore fonts to Default in about:preferences).

EDIT: From what I know, KDE neon will set Noto Sans, and a bunch of other fallback fonts, as the default preferred fonts for sans-serif (as well as other Noto's for the other families) at /etc/fonts/conf.d/56-neon-noto.conf. User configs however, are being loaded at order 50 (so yeah, before 56), so the previous config I linked would take precedence.

EDIT 2: Also check out the font being used in ~/.gtkrc-2.0, however this should automatically be generated by System Settings > Application Style > GNOME Application Style (GTK).
User avatar ytomino
Registered Member
Posts
6
Karma
0
OS
bobbywibowo, thanks for your replying and gist.
I tried it and somethings...

So, Firefox seems to have two problems:
(1) The font settings of its about:preferences is ignored.
(2) It cannot load any local fonts except default fonts that assigned to one of "serif", "sans-serif", or "monospace".
# "fantasy" and "cursive" are not loaded.
# Web fonts are always loaded.

Adding <prefer> tags into ~/.config/fontconfig/conf.d resolves (1).
Adding @font-face for the not-loaded local fonts into userContent.css resolves (2).

Perhaps, both are not solutions to the root of the problems. about:preferences has been ignored still.
Well, although, my fonts can be displayed now for the present. :-)

Additionally, ~/.gtkrc-2.0 and ~/.config/gtk-3.0/settings.ini seems to be ineffective for web contents of Firefox.
User avatar bobbywibowo
Registered Member
Posts
13
Karma
0
OS
ytomino wrote:(2) It cannot load any local fonts except default fonts that assigned to one of "serif", "sans-serif", or "monospace".
# "fantasy" and "cursive" are not loaded.
# Web fonts are always loaded.

I guess I shouldn't be surprised, but this was also caused by neon's 56-neon-noto.conf.
Reference: https://askubuntu.com/a/1082070/847385

UPDATE: Today's updates have fixed this (reference: viewtopic.php?f=309&t=155233#p405721).
User avatar ytomino
Registered Member
Posts
6
Karma
0
OS
bobbywibowo wrote:UPDATE: Today's updates have fixed this (reference: viewtopic.php?f=309&t=155233#p405721).

Oh, about:preferences works now. Thanks!

By the way, I took some screenshots of the gtk applications before the updating, compared after, and did not find difference between them...
I think fontconfig is not a cause of nybac's problem.
Surely the gtk menu font seems to be higher than qt slightly, but they look same roughly.

Perhaps the rounding is a cause, because 10pt equals to 13.33...px and it would be rounded up to 14 in gtk, but rounded down to 13 in Qt.
Unfortunately the font setting dialog of "GNOME Application Style (GTK)" does not accept a decimal point. (9pt is just 12.0px)
So I edited ~/.gtkrc-2.0 and ~/.config/gtk-3.0/settings.ini with the editor. The changing of ~/.config/gtk-3.0/settings.ini is reflected.

Image
nybac
Registered Member
Posts
14
Karma
0
OS
@ytomino
Thanks a lot, this looks very much better. Do you have a clue to do the same for root GTK applications such as Synaptic ?
Thanks :)

 
Reply to topic

Bookmarks



Who is online

Registered users: archjedi, Baidu [Spider], Bing [Bot], Exabot [Bot], Frederik vom Hofe, Google [Bot], mcoudert, PaulThePerson, pparent, scottpetrovic, Sogou [Bot], vladimirkhusainov, william.tambellini, Yahoo [Bot]