Reply to topic

Broken Depencies for fcitx-frontend-qt5 on fresh install

BadBunny
Registered Member
Posts
3
Karma
0
Hi,
I've just installed KDE Neon based on bionic.
But now i have issues settin up fcitx and mozc.

Code: Select all
:~$ sudo apt install fcitx fcitx-frontend-qt5 kde-config-fcitx fcitx-mozc
Reading package lists... Done
Building dependency tree       
Reading state information... Done
kde-config-fcitx is already the newest version (0.5.5-1).
Starting pkgProblemResolver with broken count: 1
Starting 2 pkgProblemResolver with broken count: 1
Investigating (0) fcitx-frontend-qt5:amd64 < none -> 1.1.1-1build3 @un puN Ib >
Broken fcitx-frontend-qt5:amd64 Depends on qtbase-abi-5-9-5:amd64 < none @un H >
  Considering libqt5core5a:amd64 3038 as a solution to fcitx-frontend-qt5:amd64 10003
Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 fcitx-frontend-qt5 : Depends: qtbase-abi-5-9-5
E: Unable to correct problems, you have held broken packages.


Anyone knows how to install fcitx-frontend-qt5 anyways?
User avatar acheronuk
KDE Developer
Posts
69
Karma
1
BadBunny wrote:Anyone knows how to install fcitx-frontend-qt5 anyways?


You would need to rebuild the package from source against Neon's Qt 5.11.

The package from the Ubuntu repositories you are trying to install was built against and depends on the Qt 5.9.5 ABI from Ubuntu, so is not installable on Neon.
BadBunny
Registered Member
Posts
3
Karma
0
I think I could work with apt-get source?
If yes, a little how to would be nice.
BadBunny
Registered Member
Posts
3
Karma
0
OK, japanese input is now working in qt5 applications now.

All I had to do was building it from source via apt.

Code: Select all
sudo apt-get build-dep fcitx-frontend-qt5
sudo apt-get source --compile fcitx-frontend-qt5
sudo dpkg -i fcitx-frontend-qt5_1.1.1-1build3_amd64.deb


acheronuk wrote:You would need to rebuild the package from source against Neon's Qt 5.11.


This was the needed hint. Thanks.
User avatar apachelogger
KDE Developer
Posts
467
Karma
5
OS
I feel like we had fcitx rebuilds in neon to prevent this problem. I'll see if I can find out what happened to them.


Annoyed with bbcode since 1999.

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], daret, Exabot [Bot], gfielding, Google [Bot], irina_r, jmacleod, mainetomy, robgriff444, scottpetrovic, scummos, Sogou [Bot], TheraHedwig, W.M.Bat