Reply to topic

Bionic emojis

User avatar bobbywibowo
Registered Member
Posts
26
Karma
0
OS

Bionic emojis

Mon Oct 08, 2018 7:53 am
Hey there,

So I noticed neon-desktop is now forcing fonts-noto-color-emoji (forcing, since removing it asks neon-desktop to be removed too for some reason). That's all fine and dandy.

But my issue is, the emojis aren't even working properly.

Screenshot:


  • In title bar, some glyphs are missing (notice how only scissor emoji is appearing), and noto emojis aren't being used (again notice how scissor emoji is b&w).
  • In tab bar and tootltip, noto emojis are being used but scissor emoji is still b&w. Basically noto emojis are being used if the glyphs are missing?

Here's my FD_DEBUG=1024 log: https://gist.github.com/BobbyWibowo/ebc ... 11718b067e

And here's my ~/.config/fontconfig/conf.d/10-default.conf: https://gist.github.com/BobbyWibowo/0e6 ... 5462d7e8a1 (it's the only user config I have)

Previously I've tried the following config, https://gist.github.com/BobbyWibowo/3f7 ... d72c21fe55, but I placed it into /etc/fonts/conf.d since it seemed plasma workspace (window title bars) will not pick up user config. The result in title bar was, scissor emoji using noto emoji, but missing glyphs were still missing.

Any help would be appreciated.
User avatar bobbywibowo
Registered Member
Posts
26
Karma
0
OS

Re: Bionic emojis

Mon Oct 08, 2018 7:56 am
In addition, I don't actually use Chromium as my primary browser.
I use Firefox, but Firefox has its own built-in emojis so I figured it wouldn't be as relevant.
Though I should mention that in Firefox, tabs and tooltips use its own built-in emojis, but webpage content use noto emojis (title bar is the same as Chromium of course).
User avatar apachelogger
KDE Developer
Posts
485
Karma
5
OS

Re: Bionic emojis

Mon Oct 08, 2018 11:49 am
The window decoration problem seems to me that kwin doesn't know how to render color emoji. https://bugs.kde.org/show_bug.cgi?id=376813

The fact that scissors are not colored emoji in both cases is because the glypth gets resolves through the regular sans family and unfortunately it seems one of the CJK fonts actually has the scissors inside the font still, instead of having it outsourced to the new Noto Symbols font. We have all symbolic fonts ordered at the end of the preference, so any of the actual fonts containing a symbol would override the emoji variant (and the symbolic variant from Noto Symbols). I think that's actually a bug in Noto upstream and probably should be filed as a bug there. As I understand it all Noto Sans variants should not contain any of the symbols as they are all provided by Noto Sans Symbols(2).

Code: Select all
$ FC_DEBUG=4 pango-view --font='sans' -q -t '✂' 2>&1 | grep -o 'family: "[^"]\+' | cut -c  10- | tail -n 1
Noto Sans CJK SC


Moving the symbolic fonts to the top of the preference list would probably solve that, but I am unsure about any negative side effects that might have. Well, performance certainly would take a hit as resolution will always hit up 3 fonts which only contain a marginal subset of glyphs and zero text relevant glyphs.

Last edited by apachelogger on Mon Oct 08, 2018 11:55 am, edited 1 time in total.
Reason: added kwin bug report


Annoyed with bbcode since 1999.
User avatar bobbywibowo
Registered Member
Posts
26
Karma
0
OS

Re: Bionic emojis

Mon Oct 08, 2018 3:41 pm
Ah yeah, I actually ended up making a bug report although it got marked as duplicate of that one instead, haha.

Thanks. I guess I'll try moving it up the order. Or I'll just temporarily get rid off of CJK fonts.., probably.
User avatar bobbywibowo
Registered Member
Posts
26
Karma
0
OS

Re: Bionic emojis

Tue Oct 09, 2018 10:32 am
Removing these lines from 56-neon-noto.conf (it starts from line 980):
Code: Select all
  <!-- Firefox is weird. Explicitly force emoji to the top. Agressive what whatevs -->
  <match target="pattern">
    <test name="prgname"><string>firefox</string></test>
    <edit name="family" mode="prepend">
      <string>Noto Color Emoji</string>
    </edit>
  </match>

  <match target="pattern">
    <test name="prgname"><string>plugin-container</string></test>
    <edit name="family" mode="prepend">
      <string>Noto Color Emoji</string>
    </edit>
  </match>

will cause Firefox to STOP using its OWN built-in emojis in its tab bars and tooltips:



However web content will end up using symbols from CJK fonts you mentioned wherever possible.
But getting rid of the symbols from CJK or just removing CJK fonts should result in the best outcome.

Other than that this will also fix Firefox not being able to use locally installed fonts in webpages (reference: viewtopic.php?f=309&t=154077#p405717).

EDIT: I don't know about the plugin-container thing, but it sounds like a Firefox thing, so I also commented it out.
User avatar apachelogger
KDE Developer
Posts
485
Karma
5
OS

Re: Bionic emojis

Tue Oct 09, 2018 10:44 am
This is already fixed.


Annoyed with bbcode since 1999.
User avatar bobbywibowo
Registered Member
Posts
26
Karma
0
OS

Re: Bionic emojis

Tue Oct 09, 2018 11:02 am
Oh yeah lmao, today's updates. I noticed the updates but forgot to do it before I did this. Thanks.
User avatar bobbywibowo
Registered Member
Posts
26
Karma
0
OS

Re: Bionic emojis

Tue Feb 12, 2019 11:44 pm
Anybody else getting something like this in Firefox with KDE Framework 5.55.0 + KDE Plasma 5.15.0?

Basically emojis have zero width for some reason.
User avatar bobbywibowo
Registered Member
Posts
26
Karma
0
OS

Re: Bionic emojis

Wed Mar 13, 2019 11:47 pm
bobbywibowo wrote:Anybody else getting something like this in Firefox with KDE Framework 5.55.0 + KDE Plasma 5.15.0?

Basically emojis have zero width for some reason.

Turns out it was because I had a local fontconfig to enable antialias.
A relevant bug report in Mozilla's bugzilla here: https://bugzilla.mozilla.org/show_bug.c ... 454152#c22.
After removing it, it sorta works, but it gets mixed up with Noto Sans Symbols2 font.

The yellow emojis in the center came from Noto Color Emoji, the yellow one on the most left came from Firefox's built-in Twemoji, the blue ones came from Noto Sans Symbols2.
Noto Sans Symbols2 came from fonts-noto-unhinted package, and removing the said package will only end up making those symbols become unavailable (you know, the boxes thing with the X thing in the center).
I tried adding alias-prefer to my fontconfig to alias Noto Sans Symbols2 to Noto Color Emoji (as well as Symbols and Noto Sans Symbols), but while it works with fc-match, Firefox will still use symbols from Noto Sans Symbols2.
Not sure what the logic is.

The above screenshot came from this page: http://www.fileformat.info/info/unicode ... f8test.htm.

On a side note, the same thing happens with Chrome as well. Though the raise hand emoji (the one on the most left from the previous screenshot) will use Noto Color Emoji instead (unlike Firefox that for some reason uses its own built-in Twemoji).


I don't know man, it's a clusterf*ck.
User avatar apachelogger
KDE Developer
Posts
485
Karma
5
OS

Re: Bionic emojis

Tue Mar 26, 2019 9:47 am
Well, as far as chrome is concerned this looks fine. I mean, it doesn't look fine obviously, but it is expected. Color Emoji (or at least the version in 18.04) does not have

Character: 🖑 U+1F591
Name: REVERSED RAISED HAND WITH FINGERS SPLAYED

which is why it uses the symbols variant.

It does however have

Character: 🖐 U+1F590
Name: RAISED HAND WITH FINGERS SPLAYED

Possibly firefox' builtin set also doesn't cover the hands other than U+1F590 though, so font resolution applies same as in chrome.


Annoyed with bbcode since 1999.

 
Reply to topic

Bookmarks



Who is online

Registered users: Arran, Baidu [Spider], Bing [Bot], Clancularius, Exabot [Bot], Google [Bot], grscott, hpicq, jeremyfisher, saadams, shayeg, Snudl, Sogou [Bot], Yahoo [Bot]