Reply to topic

Discover "Update button" not activated

User avatar valtermura
Registered Member
Posts
11
Karma
0
OS
Hi All,

since some days ago, in my Discover the "Update All" button isn't activated, even if there are updates. I think this is a strange behaviour.

I can normally update through "Muon".

The only change I made in my system is changing the server from "Server in Italy" to "Main server".

Any workaround? Or should I open a bug report?

TIA,
Valter


Valter
Open Source is better!
La bici non consuma e non produce emissioni, non ingombra e non fa rumore:
è un mezzo ecologico per definizione e ad alta efficienza energetica.
La bicicletta migliora il traffico, l'ambiente, la salute e l'umore.
eggomanic
Registered Member
Posts
1
Karma
0
Same for me, just a greyed out update button. I had to wait till they tray icon popped up with "New Updates Available" then click on that to get it to work. ;)
User avatar robgriff444
Registered Member
Posts
10
Karma
0
I'm on Neon Dev Stable, there are a few bug reports about this and it seems to come and go with updates to Discover and maybe even the weather! They are looking at it so it will get fixed soon.

For now, close Discover and restart and it should be ok.

Btw, KDE uses the following for system updates (not sure if the Debian updater might introduce niggles?):

Code: Select all
sudo pkcon refresh && pkcon update
User avatar valtermura
Registered Member
Posts
11
Karma
0
OS
robgriff444 wrote:I'm on Neon Dev Stable, there are a few bug reports about this and it seems to come and go with updates to Discover and maybe even the weather! They are looking at it so it will get fixed soon.

For now, close Discover and restart and it should be ok.

Btw, KDE uses the following for system updates (not sure if the Debian updater might introduce niggles?):

Code: Select all
sudo pkcon refresh && pkcon update


Thanks for the suggestion :)

Presently I'm using Muon for updates. Do you think it is better to update with pkcon command?


Valter
Open Source is better!
La bici non consuma e non produce emissioni, non ingombra e non fa rumore:
è un mezzo ecologico per definizione e ad alta efficienza energetica.
La bicicletta migliora il traffico, l'ambiente, la salute e l'umore.
User avatar robgriff444
Registered Member
Posts
10
Karma
0
I guess it's up to you - I don't 'expect' a problem but I use it in place of apt because 1) KDE told me to! and 2) because of the way apt housecleans i.e. autoremove. I don't know how pkcon handles this so I use KDE tools where I can and then apt tools when I must. I'm just being technically cautious, I've not heard anyone say that they don't easily coexist and I must therefore assume things work most of the time.
User avatar valtermura
Registered Member
Posts
11
Karma
0
OS
Well, presently I find Muon better than the pkcon commands. Today I updated almost two hundred of packets, pkcon returns to me an error that I solved with Muon.

But Discover still having the same problems... I'm going to open a bug.


Valter
Open Source is better!
La bici non consuma e non produce emissioni, non ingombra e non fa rumore:
è un mezzo ecologico per definizione e ad alta efficienza energetica.
La bicicletta migliora il traffico, l'ambiente, la salute e l'umore.
SF6
Registered Member
Posts
6
Karma
0
Has this been resolved? I still encounter this on a recent Neon build. I had not noticed this bug before because I usually use the terminal to update.
srgmro33
Registered Member
Posts
40
Karma
0
SF6 wrote:Has this been resolved? I still encounter this on a recent Neon build. I had not noticed this bug before because I usually use the terminal to update.

I checked the last update (plasma 5.14.5) and now i observe a crash of Discover at each start !!

SM
User avatar Arran
Registered Member
Posts
226
Karma
0
OS
Why don't you use the terminal? This way has several advances over the graphic way: no graphics interfering during the run, faster, more secure and more.

Just to do it, choose CTRL+ALT. Don't be afraid, a totally black screen with 2 lines top left. 1st line is your computername, 2nd your password, the space remains black.

Once the interface responses, do a «sudo apt-get dist-update» and then «sudo apt-get dist-upgrade».

When finished you exit with CTRL (STRG) + ALT + F7 and the graphic screen comes back.

It is now important to do a restart.


Best greetings from Scotland's nicest holiday island.
Kubuntu 14.04-5 & KDE neon, 64 bits, Nvidia 4800GS, 4MB Ram, 4 core, HP Monitor 2550 x 1600 pixels.
User avatar alideda
Registered Member
Posts
200
Karma
0
OS
ciolansteen
Registered Member
Posts
2
Karma
0
Ikd if this issue is still present, but just in case it is - try delete ~/.config/atticarc file (backup it first if for any reason you might think of). This fixed my Discover updates issue with Archlinux.
User avatar alideda
Registered Member
Posts
200
Karma
0
OS
I installed a new version of the Btrfs file system. I has a different version on the ext4 file system. Update to a new plasma I worked with pkcon refres and pkcon update. Discoveri works fine with me right now. A new update arrived, and I did it through Discover and everything works properly.

Operating System: KDE neon 5.14 (It should be written 5.15)
KDE Plasma Version: 5.15.0
KDE Frameworks Version: 5.55.0
Qt Version: 5.12.0
j8a
Registered Member
Posts
145
Karma
0
OS
Hi,
I often use aptitude to update the system and works fine. On Monday I updated to KDE Plasma version 15.4.5 and today I found a notification from Discover on the Panel. It seems that the bug was solved. Please, take a look at this link: https://pointieststick.com/
Regards
User avatar alideda
Registered Member
Posts
200
Karma
0
OS
These are nice news, but there is a problem, not everything is so nice. My first neon / user was installed with a plasma of 5.14.5, the second neon / user was installed very long on Ubuntu 16.04LTS and it was updated based on Ubuntu18.04LTS. These Neon's are different, the first has been updated on the plasma 5.15.0 and it's not all there as shown in the images from the link. The second neon has not yet had a choice of monitors at startup, do not have options around the panel aplication menu bar, etc. My goal is to have a functional linux and not to have Windows 98 and I need to reinstall it from scratch every time a large update is made. The Btrfs file system is more tolerant of errors than the ext4 file system. I am sufficiently disturbed that after each update sddm I have to return a script that runs two monitors.
Best regards :)
User avatar alideda
Registered Member
Posts
200
Karma
0
OS
j8a wrote:Hi,
I often use aptitude to update the system and works fine. On Monday I updated to KDE Plasma version 15.4.5 and today I found a notification from Discover on the Panel. It seems that the bug was solved. Please, take a look at this link: https://pointieststick.com/
Regards


I know that Discover works because I tried, on the next update that he arrived. As for the new improvements, now this does not work, it does not exist.
Image
The search is still where there was a 5.14.5 version
What is the purpose of this serach field. I have an optic connection, I have a wi-fi backup connection to my godfather, unify limites share of my service provider's connection and 20 out-of-range connections. Unifi serves as a mobile connection for Android and laptop if I am outside my house.
Update plazma to version 5.15.0 deleted my localization, my language, system setups are empty, the login screen is the only one remaining localized. This is the identical situation in 2 Neon and Manjaro. I reported the bug and the screenshot but I do not see it accepted, there is no feedback.
Best regards :)

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], claydoh, Google [Bot], jsalatas, kdetefo, kinghat, Majestic-12 [Bot], ngraham, npeter, Sogou [Bot], vinnywright, Willov