Reply to topic

How to stop packagekit (Discover) from auto-update

pa
Registered Member
Posts
12
Karma
0
on the latest neon (18.04 based), every time i log in, after a few minutes, i get notified about updates.
I would like to prevent packagekit to auto spawn an apt-get update on its own.
Is this possible? if not, can it be made possible?
gfielding
Registered Member
Posts
113
Karma
0
OS
Right-click the triangle (bottom right next to the clock), select 'configure-system-tray' and take the tick-out of the box
pa
Registered Member
Posts
12
Karma
0
Does this really stop the apt-get update running in the background?
gfielding
Registered Member
Posts
113
Karma
0
OS
Yes it works.

Switched on today, then ran 'discover' manually and there are lots of vlc updates. If it was still running (despite the tick being removed) these would have been shown after boot.
User avatar kdeoldster
Registered Member
Posts
38
Karma
0
OS
Discover, by default, doesn't use apt/apt-get commands. It uses the pkcon refresh command to look for updates since it is based on packagekit and the apt or apt-get commands might not pull all packages needed for a "full" update/upgrade. Quote from FAQ on KDE neon homepage:


How do I Update to the Latest Software?
KDE neon does continuous deployment of the latest KDE software which means there are nearly always new versions of our software to update to. We recommend using Plasma Discover's updater which appears in your panel:

If you prefer to use the command line you can use the pkcon command:

pkcon refresh
pkcon update
This will install all new packages and uses the same PackageKit code as Plasma Discover. Some uses of apt do not install new packages which makes it less suitable for KDE neon.
pa
Registered Member
Posts
12
Karma
0
AFAIK packagekit uses apt in some form (obviously). So i don't see how apt-get, apt or aptitude can't upgrade the same packages as packagekit.
In any case, it would be good if Discover could be configured not to fire its automatic pkcon refresh on its own.
It also so happens to do it *always* at the wrong time
User avatar alideda
Registered Member
Posts
191
Karma
0
OS
Discover just doing auto-update but not upgrading. I do not see why the problem is to be seen in the panel. It may be a problem if someone does not have an internet connection, so there is an announcement of a crackdown.
pkcon refresh
pkcon update
=airplane
and discoveri
=like bicycle
pa
Registered Member
Posts
12
Karma
0
The problem arises when i am on a paid connection. I do not want something to auto pull stuff from the internet on my back. Thank you for understanding.
User avatar alideda
Registered Member
Posts
191
Karma
0
OS
We all pay for an internt connection, I have a contract with the provider and I pay the internet. I have unlimited data flow. You most likely have a limited data flow, a limited quota as much as you can dowload and everything over the limit is charged much more. Some mobile providers are doing this in my country.
If I can give advice if you have a facebook stop using it and find, for example, in browsers (Firefox, Opera, Chrome), these programs bring you a bunch of data without your knowledge and push ads that pop up on the screen, even if you do not use the browser at that time. My wife is using my mobile phone for facebook, I delete 700-800MB of data each day from a facebook.
pa
Registered Member
Posts
12
Karma
0
Thanks for your advices. I pay internet per MB. I do not use facebook and i keep data counters.
So it would be wise if the developers of "Discover" would at the very least offer a checkbox where to disable the auto updating of the catalogs.
I have seen this has generated many complaints already by people claiming it was even upgrading their system.
So, also to avoid misunderstanding, just have a "fully manual operation" option there. SHouldn't take long to add, should it?
(Please note, if some of the developers would come to say this is "by design", i would very much appreciate it. So i can stop using plasma without regrets)
ndotb
Registered Member
Posts
1
Karma
0
@pa, I don't know if you found your answer but I understand your pain and find some of the responses you've received to be caustic, unprofessional, and highly dismissive.

I have several machines at a remote site running kubuntu with a satellite connection to hughes on a two-tier data contract: 50gb during the day, and 50gb from 2am-8am. There's a slightly sophisticated setup using things like squid (proxy caching) and dnsmasq/iptables (trash blocking) at the gateway to keep traffic down. However there is a way to make it work for one machine if neon has software-properties-kde.

If you can run sudo software-properties-kde, then click the Updates tab and uncheck everything under the Software updates group and the Automatic updates group, and close. This will prevent Discover from going crazy whenever it wants.

Now you can use Discover to... discover, but it can no longer control your updates.

If you're like me and have the night time tier, you can add some lines to /etc/crontab to make the magic happen at night:
Code: Select all
05 2 * * * root /usr/bin/apt update > /var/log/apt-updated.log
35 2 * * * root /usr/bin/apt dist-upgrade -dy > /var/log/apt-downloaded.log

The first line will update sources at 2:05 (the 05 2 part) on every day of the month, every month, and every day of the week (the * * *). If you only want to check twice a week, try replacing * * * with * * 1,4 to check Monday and Thursday.

The second line will download updates at 2:35 (35 2) but not install them. When you wake up, Discover will say that it found some updates and give you the option of installing them on your schedule. Once again play with the * * * to suit your bandwidth tolerance for update traffic.

You can see what it's doing with the two log files created. To keep appending to the files instead of overwriting them, replace > with >>.

Good luck! I, too, find it odd that while many tech people want to "bring the internet to the world," they're not exactly in tune with the realities of what that entails. The hardware behind rural & remote telecommunications infrastructure is expensive and limited. You pay for what you get and wow, do you pay!
martinki
Registered Member
Posts
31
Karma
0
OS
don't do that @pa. you "beat up" your neon standard repos. in my case it deactivated the security-repo's & much more, although i didn't save anything with this ubuntu/kubuntu sources config tool! therefore this is also a security risk. especially the last days have shown how important securtiy updates are (intel).

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], DaniilDragon, dikasetyaprayogi, distrobro, eezacque, Exabot [Bot], farid, Google [Bot], Google Adsense [Bot], jmacleod, m4TZ, mirdaki, msknight, OscarOswaldoNR, santiagocezar, Sogou [Bot], stianv, Yahoo [Bot], zakazak