Reply to topic

Long Wifi autoconnect after upgrade to 18.04

Dibo
Registered Member
Posts
17
Karma
0
Hi,

Problem occur when I restart system. Previously on 16.04, after login I saw immediately popup hint that wifi is connected. Now after upgrade to 18.04 I see spinner and status "authorization..." and after some time I get error popup hint "wifi disconnected", then I see it try connect again and connected immediately. Whole connecting process is taking around 20-30 seconds. What I do after login is force disconnect and click connect again which do the job.

Some details:

Code: Select all
lspci -nnk | grep net -A2
00:1f.6 Ethernet controller [0200]: Intel Corporation Ethernet Connection I219-V [8086:1570] (rev 21)
        Subsystem: Hewlett-Packard Company Ethernet Connection I219-V [103c:8079]
        Kernel driver in use: e1000e
        Kernel modules: e1000e


Code: Select all
sudo lshw -C network
  *-network                 
       description: Wireless interface
       product: Wireless 8260
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlp2s0
       version: 3a
       serial: e4:a7:a0:fa:05:3c
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=4.15.0-39-generic firmware=34.0.1 ip=192.168.1.2 latency=0 link=yes multicast=yes wireless=IEEE 802.11
       resources: irq:130 memory:e1100000-e1101fff
  *-network
       description: Ethernet interface
       product: Ethernet Connection I219-V
       vendor: Intel Corporation
       physical id: 1f.6
       bus info: pci@0000:00:1f.6
       logical name: enp0s31f6
       version: 21
       serial: 98:e7:f4:ea:0a:e9
       capacity: 1Gbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=3.2.6-k firmware=0.13-4 latency=0 link=no multicast=yes port=twisted pair
       resources: irq:126 memory:e1200000-e121ffff
User avatar fredhoud
Registered Member
Posts
101
Karma
1
OS
Go to wireless network, and make sure the auto connect box is checked.
Second, go to Wi-Fi security, and chose "Store password for all users (not encrypted)".
Dibo
Registered Member
Posts
17
Karma
0
fredhoud wrote:Second, go to Wi-Fi security, and chose "Store password for all users (not encrypted)".

Worked! Thanks! But how / why ? I guess that "store for this user only (encrypted)" is default option when connect to the new Wifi and it worked fine for years, no? What changed?
User avatar fredhoud
Registered Member
Posts
101
Karma
1
OS
Dibo wrote:
fredhoud wrote:Second, go to Wi-Fi security, and chose "Store password for all users (not encrypted)".

Worked! Thanks! But how / why ? I guess that "store for this user only (encrypted)" is default option when connect to the new Wifi and it worked fine for years, no? What changed?


I know. I ran into the same issue myself, and it was driving me crazy! It took me a while to figure this out by simply fooling around with different settings! I'm not sure why or how it got switched to encrypted to begin with, but as long as it works! ;)

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], Exabot [Bot], gkroeger, Google [Bot], kives