Reply to topic

Wrong Language

User avatar Arran
Registered Member
Posts
221
Karma
0
OS

Wrong Language

Sat Dec 29, 2018 1:06 pm
Hello
I am installing KDE neon and am stumbling about the settings of the Language. Up to now with my Kubuntu 14,04 there was no problem.

Situation: I have German Swiss keyboard, witch is different to the German and Austrian ones. At presenrt I can only install a German version for the Keyboard, at the usual spaces I could use with Kubuntu are no mentioning of the several Swiss versions generally avaiable.

Before I go further with the installation, I have to find the solution for this malfunction, as this is one of the basic problems if it can not be resolved.


Best greetings from Scotland's nicest holiday island.
Kubuntu 14.04-5 & KDE neon, 64 bits, Nvidia 4800GS, 4MB Ram, 4 core, HP Monitor 2550 x 1600 pixels.
NoNameNoBlame
Karma
0

Re: Wrong Language

Sun Dec 30, 2018 5:09 am
For a start, You could try:

$ sudo dpkg-reconfigure console-data

Afterwards, reboot.

If not solved now, then use/check Plasma's
Configuration-Dialogue Windows

Good Luck.
User avatar Arran
Registered Member
Posts
221
Karma
0
OS

Re: Wrong Language

Sun Dec 30, 2018 2:30 pm
Quick response, Thanks.

The answer is:
Code: Select all
dpkg-query: package 'console-data' is not installed and no information is available


The following text is nothing I can use, as I don't really understand it.
Code: Select all
Use dpkg --info (= dpkg-deb --info) to examine archive files,
and dpkg --contents (= dpkg-deb --contents) to list their contents.
/usr/sbin/dpkg-reconfigure: console-data is not installed


Where can I find
/check Plasma's
Configuration-Dialogue Windows


Best greetings from Scotland's nicest holiday island.
Kubuntu 14.04-5 & KDE neon, 64 bits, Nvidia 4800GS, 4MB Ram, 4 core, HP Monitor 2550 x 1600 pixels.
NoNameNoBlame
Karma
0

Re: Wrong Language

Sun Dec 30, 2018 4:23 pm
1/2:
Plasma Desktop
System Settings
Hardware: Input Devices
Keyboard: Layouts
Click check mark; Configure Layouts
Check Layout Table below for Swiss or CH
Click ADD
Use Menu: Limit selection by language
Select: German, Swiss

Confirm

Logoff and re-logon.

2/2:
console-data and console-common
should be installed. Maybe they are not by default.
On Debian-based GNU-Linuxes it's standard, as far
as I can tell from experience during the last
decades.

But I admit:
$ apt show console-common 2>/dev/null | grep Priority
Priority: optional

$ apt show console-data 2>/dev/null | grep Priority
Priority: optional

Only "optional".

Good Luck, again.
User avatar Arran
Registered Member
Posts
221
Karma
0
OS

Re: Wrong Language

Mon Dec 31, 2018 3:03 pm
Thanks a lot for your response. I will now try to follow your suggestions.

Until then, please have a nice end of Year and a very good one for 2019.


Best greetings from Scotland's nicest holiday island.
Kubuntu 14.04-5 & KDE neon, 64 bits, Nvidia 4800GS, 4MB Ram, 4 core, HP Monitor 2550 x 1600 pixels.
User avatar Arran
Registered Member
Posts
221
Karma
0
OS

Re: Wrong Language

Mon Dec 31, 2018 3:23 pm
This was a short one. After I installed console-data and console-common and restarted the computer, the miracle happened and my texts are now in German.

Thanks again.


Best greetings from Scotland's nicest holiday island.
Kubuntu 14.04-5 & KDE neon, 64 bits, Nvidia 4800GS, 4MB Ram, 4 core, HP Monitor 2550 x 1600 pixels.
User avatar stanislavzu
Registered Member
Posts
11
Karma
0

Re: Wrong Language

Sat Feb 02, 2019 8:31 pm
hello! do you know should i change the ubuntu language or i can do it just in the programm? im trying KDENLive. Thanks

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], diaslarissa, Exabot [Bot], farid, Google [Bot], Google Adsense [Bot], gregorymartinez, Hito, Sogou [Bot]