Reply to topic

No panel transparency in KDE Neon.

nybac
Registered Member
Posts
18
Karma
0
OS

No panel transparency in KDE Neon.

Sun Jan 13, 2019 10:13 am
Hi guys,
I'm a longtime KDE Neon user. I installed it on a new ASUS X541S laptop and noticed that bottom panel and appications menu are not as transparent as they are in my old Toshiba Satellite L450 laptop.
Any help please ?
Thanks :)
User avatar waynes
Registered Member
Posts
118
Karma
0
The transparency of the Panel and Menu is determined by the Desktop Theme you choose. So if you go into system settings / Workspace Theme /Desktop Theme. Then "Get New Themes" Pick a theme like Transdarc & you will find much more Transparency.
nybac
Registered Member
Posts
18
Karma
0
OS
@waynes : I'm using the default theme (Breeze) and I got the transparency with the same config on my old PC.
User avatar waynes
Registered Member
Posts
118
Karma
0
KDE 5.14.5 offers very little transparency on my system, using the Breeze desktop theme. Not sure if it has in the past. But changing the theme helps. There are plenty of Desktop Themes with various degrees of transparency.
Was your old PC running exactly the same version of KDE as your new one?

Edit... The other thing you might want to check is do you have your Compositor enabled in your Display & Monitor setting. Disabling it would cause all transparency to fail.
User avatar abury
Registered Member
Posts
142
Karma
0
OS
Mmm... saying that "bottom panel and applications menu are not as transparent" is somewhat subjective... however I get your drift as I also wish that there were user-friendly opacity options for the panel itself, however...
Have you looked at tweaking "Desktop Effects"... like "Blur" maybe?
Or the transparency options under "Application Style"?
Sure they have don't have what I'd like them to have... but other than that, it's about finding/making a desktop theme that works for you!
Also then there is Latte... that does a decent job of having a whatever-opacity-mac-type-panel and some more... that normal panel can't do!

EDIT
https://www.reddit.com/r/kde/comments/822egl/making_panel_transparent_for_current_kde_theme/
please ignore my idiotic reply-attempts above... you were asking about the panel, so...
(a) disabled my Latte panel, (b) enabled a default panel then (c) followed shmerl's instructions above and hey... that works too!
while it may not be as granular as Latte, i.e. in Latte you can have 0% opacity or whatever but hey, having the default panel looking like this... works for me!


Kubuntu 19.10 - Plasma 5.18.3 - Frameworks 5.67.0 - Qt 5.12.4 - Kernel 5.3.0-51
kirolosmater
Registered Member
Posts
1
Karma
0
Go to System Settings -> Plasma Style -> Get New Plasma Styles -> Search -> Breeze Transparent Dark
User avatar xanadux
Registered Member
Posts
27
Karma
0
OS
Transparency is one of the things I miss after using XFCE. With that desktop, the user could adjust the transparency from 0-100%.

I have found that changing the rendering backend to "XRender" gave me more transparency, but it was only by chance that I discovered this while trying to fix another problem.


Acer Aspire TC-120 Desktop. 8GB RAM.

 
Reply to topic

Bookmarks



Who is online

Registered users: aleksander, Alexa [Bot], Baidu [Spider], Bing [Bot], gfielding, Google [Bot], grahm, ineuw, sandro4912, Sogou [Bot], Yahoo [Bot]